1# cwdaemon.spec
2#
3# Copyright (C) 2003 - 2004 Joop Stakenborg pg4i@amsat.org
4# Copyright (C) 2012 - 2015 Kamil Ignacak <acerion@wp.pl>
5#
6%define name cwdaemon
7%define version @VERSION@
8%define release 1
9
10# required items
11Name: %{name}
12Version: %{version}
13Release: %{release}
14Copyright: GPL
15Group: Daemons
16Prefix: /usr
17BuildRoot: /var/tmp/%{name}-%{version}
18Summary:  Morse daemon for the parallel or serial port
19Vendor: Kamil Ignacak <acerion@wp.pl>
20URL: http://cwdaemon.sourceforge.net/
21Packager: Kamil Ignacak <acerion@wp.pl>
22Source: %{name}-%{version}.tar.gz
23
24%description
25Cwdaemon is a small daemon which uses the pc parallel or serial port
26and a simple transistor switch to output morse code to a transmitter
27from a text message sent to it via the udp internet protocol.
28
29%prep
30%setup -q
31
32%build
33export RPM_OPT_FLAGS="-O2 -march=i386"
34export CFLAGS="-O2"
35%configure
36make
37
38%install
39rm -rf $RPM_BUILD_ROOT
40mkdir -p $RPM_BUILD_ROOT
41make DESTDIR=$RPM_BUILD_ROOT install
42
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46%files
47%defattr(-,root,root)
48%doc ChangeLog
49/usr/sbin/cwdaemon
50/usr/share/man/man8/cwdaemon.8.gz
51/usr/share/cwdaemon/README
52/usr/share/cwdaemon/parallelport_circuit.ps
53/usr/share/cwdaemon/serialport_circuit.ps
54/usr/share/cwdaemon/parallelport_circuit.jpg
55/usr/share/cwdaemon/serialport_circuit.jpg
56/usr/share/cwdaemon/cwtest.sh
57/usr/share/cwdaemon/cwsetup.sh
58/usr/share/cwdaemon/cwtest.c
59/usr/share/cwdaemon/cwdaemon.png
60
61%changelog
62* Sat Jan 18 2003 Joop Stakenborg
63- Initial spec file
64* Tue Jul 03 2012 Kamil Ignacak
65- Updating the file after taking the project over by new maintainer.
66