1%define ver      @LBDB_VERSION@
2%define rel      2
3%define prefix   /usr
4
5Summary: The Little Brother's Database
6Name: lbdb
7Version: %ver
8Release: %rel
9Copyright: GNU General Public Licence
10URL: http://www.spinnaker.de/lbdb/
11Packager: Horms <horms@vergenet.net>
12Vendor: Horms
13Group: Applications/Databases
14Source: http://www.spinnaker.de/debian/lbdb_%{ver}.tar.gz
15NoSource: 0
16BuildRoot: /var/tmp/lbdb-%{PACKAGE_VERSION}-root
17Docdir: %{prefix}/doc
18
19%description
20This package was inspired by the Big Brother Database package available for
21various Emacs mailers, and by Brandon Long's "external query" patch for the
22Mutt mail user agent. (Note that this patch has been incorporated into the
23main-line mutt versions as of mutt 0.93.)
24
25The package doesn't use any formal database libraries or languages,
26although it should be quite easy to extend it to use, e.g., an installed
27PostgreSQL server as it's back end.
28
29%prep
30%setup -q
31
32%build
33%configure 2>&1 | tee -a Configurings-`date +%Y.%m.%d`
34
35#Funky NPROC code to speed things up courtesy of Red Hat's kernel rpm
36if [ -x /usr/bin/getconf ] ; then
37    NRPROC=$(/usr/bin/getconf _NPROCESSORS_ONLN)
38    if [ $NRPROC -eq 0 ] ; then
39        NRPROC=1
40    fi
41else
42    NRPROC=1
43fi
44NRPROC=`expr $NRPROC + $NRPROC`
45
46make -j $NRPROC  2>&1 | tee -a Makings-`date +%Y.%m.%d`
47
48%install
49rm -rf $RPM_BUILD_ROOT
50mkdir -p ${RPM_BUILD_ROOT}/%{prefix}/etc
51
52make install_prefix=${RPM_BUILD_ROOT} install 2>&1 \
53    | tee -a Makings-Install-`date +%Y.%m.%d`
54
55%clean
56rm -rf ${RPM_BUILD_DIR}/lbdb-%{ver}
57rm -rf ${RPM_BUILD_ROOT}
58
59%files
60%defattr(-,root,root)
61%doc README COPYING
62# Keep copies of the configure, build, install reports in the
63# documentation of the package.
64%doc Makings-Install-`date +%Y.%m.%d`
65%doc Makings-`date +%Y.%m.%d`
66%doc Configurings-`date +%Y.%m.%d`
67%{prefix}
68
69%changelog
70* Sat Dec 30 2000 Rob Payne <rnspayne@adelphia.net>
71- Changed to fit version 0.22
72- Change installation process to include RPM_BUILD_ROOT
73- Removed auto-generated files list that did not take into account RPM
74  4's automatic compression of the man pages *after* the
75  auto-generation was running.
76- Removed the empty post, postun, preun scripts.
77
78* Mon Apr 10 2000 Horms <horms@vergenet.net>
79- created for version 0.18.5
80