1Name:           log4cplus
2Version:        1.1.2
3Release:        1%{?dist}
4Summary:        log4cplus, C++ logging library
5
6License:        Apache
7Group:          Development/Libraries
8URL:            http://log4cplus.sourceforge.net/
9Source0:        http://downloads.sourceforge.net/project/log4cplus/log4cplus-stable/1.1.2/log4cplus-1.1.2.tar.gz
10
11BuildArch:      noarch
12
13BuildRequires:  mingw32-filesystem >= 95
14BuildRequires:  mingw32-gcc
15BuildRequires:  mingw32-binutils
16BuildRequires:  mingw32-gettext
17BuildRequires:  mingw32-win-iconv
18BuildRequires:  mingw32-zlib
19
20BuildRequires:  mingw64-filesystem >= 95
21BuildRequires:  mingw64-gcc
22BuildRequires:  mingw64-binutils
23BuildRequires:  mingw64-gettext
24BuildRequires:  mingw64-win-iconv
25BuildRequires:  mingw64-zlib
26
27%description
28log4cplus is a simple to use C++ logging API providing thread-safe,
29flexible, and arbitrarily granular control over log management and
30configuration. It is modeled after the Java log4j API.
31
32# Strip removes essential information from the .dll.a file, so disable it
33%define __strip /bin/true
34
35# Win32
36%package -n mingw32-log4cplus
37Summary:    MinGW compiled log4cplus library for the Win32 target
38
39%description -n mingw32-log4cplus
40MinGW compiled log4cplus library for the Win32 target
41
42%package -n mingw32-log4cplus-devel
43Summary:    Headers for the MinGW compiled log4cplus library for the Win32 target
44
45%description -n mingw32-log4cplus-devel
46Headers for the MinGW compiled log4cplus library for the Win32 target
47
48# Win64
49%package -n mingw64-log4cplus
50Summary:    MinGW compiled log4cplus library for the Win64 target
51
52%description -n mingw64-log4cplus
53MinGW compiled log4cplus library for the Win64 target
54
55%package -n mingw64-log4cplus-devel
56Summary:    Headers for the MinGW compiled log4cplus library for the Win64 target
57
58%description -n mingw64-log4cplus-devel
59Headers for the MinGW compiled log4cplus library for the Win64 target
60
61%prep
62%setup -q -n log4cplus-%{version}
63
64%build
65%mingw_configure
66%mingw_make %{?_smp_mflags}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70%mingw_make_install DESTDIR=$RPM_BUILD_ROOT
71find $RPM_BUILD_ROOT -name "*.la" -delete
72find $RPM_BUILD_ROOT -name "stamp-*" -delete
73find $RPM_BUILD_ROOT -name "*.in" -delete
74find $RPM_BUILD_ROOT -name macosx.h -delete
75find $RPM_BUILD_ROOT -name windowsh-inc.h -delete
76find $RPM_BUILD_ROOT -name cygwin-win32.h -delete
77find $RPM_BUILD_ROOT -name syncprims-win32.h -delete
78# find $RPM_BUILD_ROOT -name liblog4cplus.a -delete
79find $RPM_BUILD_ROOT -name .svn -type d -exec find '{}' -delete \;
80
81# Win32
82%files -n mingw32-log4cplus
83%{mingw32_bindir}/lib*.dll
84
85%files -n mingw32-log4cplus-devel
86%defattr(-,root,root,755)
87%{mingw32_includedir}/log4cplus/*.h
88%{mingw32_includedir}/log4cplus/helpers/*.h
89%{mingw32_includedir}/log4cplus/spi/*.h
90%{mingw32_includedir}/log4cplus/boost/*.hxx
91%{mingw32_includedir}/log4cplus/config.hxx
92%{mingw32_includedir}/log4cplus/config/defines.hxx
93%{mingw32_includedir}/log4cplus/config/win32.h
94%{mingw32_includedir}/log4cplus/internal/*.h
95%{mingw32_includedir}/log4cplus/thread/impl/*.h
96%{mingw32_includedir}/log4cplus/thread/*.h
97%attr(644,root,root)
98%{mingw32_libdir}/*.dll.a
99%{mingw32_libdir}/liblog4cplus.a
100%{mingw32_libdir}/pkgconfig/log4cplus.pc
101
102# Win64
103%files -n mingw64-log4cplus
104%{mingw64_bindir}/lib*.dll
105
106%files -n mingw64-log4cplus-devel
107%defattr(-,root,root,755)
108%{mingw64_includedir}/log4cplus/*.h
109%{mingw64_includedir}/log4cplus/helpers/*.h
110%{mingw64_includedir}/log4cplus/spi/*.h
111%{mingw64_includedir}/log4cplus/boost/*.hxx
112%{mingw64_includedir}/log4cplus/config.hxx
113%{mingw64_includedir}/log4cplus/config/defines.hxx
114%{mingw64_includedir}/log4cplus/config/win32.h
115%{mingw64_includedir}/log4cplus/internal/*.h
116%{mingw64_includedir}/log4cplus/thread/impl/*.h
117%{mingw64_includedir}/log4cplus/thread/*.h
118%attr(644,root,root)
119%{mingw64_libdir}/*.dll.a
120%{mingw64_libdir}/liblog4cplus.a
121%{mingw64_libdir}/pkgconfig/log4cplus.pc
122
123%changelog
124* Wed Aug 14 2013 John Smits <japsmits@gmail.com> - 1.1.1-1
125- Initial release
126