1#
2# spec file for package padthv1
3#
4# Copyright (C) 2017-2021, rncbc aka Rui Nuno Capela. All rights reserved.
5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14#
15# Please submit bugfixes or comments via http://bugs.opensuse.org/
16#
17
18%define name    @PACKAGE_TARNAME@
19%define version @PACKAGE_VERSION@
20%define release 64.1
21
22%define _prefix	@ac_prefix@
23
24%if %{defined fedora}
25%define debug_package %{nil}
26%endif
27
28Summary:	An old-school polyphonic additive synthesizer
29Name:		%{name}
30Version:	%{version}
31Release:	%{release}
32License:	GPL-2.0+
33Group:		Productivity/Multimedia/Sound/Midi
34Source0:	%{name}-%{version}.tar.gz
35URL:		http://padthv1.sourceforge.net
36Packager:	rncbc.org
37
38BuildRoot:	%{_tmppath}/%{name}-%{version}-%{release}-buildroot
39
40BuildRequires:	coreutils
41BuildRequires:	pkgconfig
42BuildRequires:	glibc-devel
43BuildRequires:	gcc-c++
44BuildRequires:	cmake
45%if %{defined fedora}
46#BuildRequires:	qt5-qtbase-devel >= 5.1, qt5-linguist
47#BuildRequires:	qt5-qtsvg-devel, qt5-qtwayland-devel
48BuildRequires:	jack-audio-connection-kit-devel
49BuildRequires:	alsa-lib-devel
50%else
51#BuildRequires:	libqt5-qtbase-devel >= 5.1, libqt5-linguist-devel
52#BuildRequires:	libqt5-qtsvg-devel, libqt5-qtwayland-devel
53BuildRequires:	libjack-devel
54BuildRequires:	alsa-devel
55%endif
56BuildRequires:	qtbase6-static >= 6.1
57BuildRequires:	qttools6-static >= 6.1
58BuildRequires:	qttranslations6-static >= 6.1
59BuildRequires:	qtwayland6-static >= 6.1
60BuildRequires:	qtsvg6-static >= 6.1
61BuildRequires:	fftw3-devel
62BuildRequires:	liblo-devel
63BuildRequires:	lv2-devel
64
65BuildRequires:	pkgconfig(egl)
66
67%description
68  An old-school all-digital polyphonic additive synthesizer with stereo fx.
69
70
71%package -n %{name}-jack
72Summary:	An old-school polyphonic additive synthesizer - JACK standalone
73Provides:	%{name}_jack
74Obsoletes:	%{name}-common <= %{version}, %{name} <= %{version}
75
76%description -n %{name}-jack
77  An old-school all-digital polyphonic additive synthesizer with stereo fx.
78  .
79  This package provides the standalone JACK client application (padthv1_jack)
80
81
82%package -n %{name}-lv2
83Summary:	An old-school polyphonic additive synthesizer - LV2 plugin
84Provides:	%{name}_lv2, %{name}_lv2ui
85Obsoletes:	%{name}-common <= %{version}
86
87%description -n %{name}-lv2
88  An old-school all-digital polyphonic additive synthesizer with stereo fx.
89  .
90  This package provides the LV2 plugin (http://padthv1.sourceforge.net/lv2)
91
92
93%prep
94%setup -q
95
96%build
97source /opt/qt6.1-static/bin/qt6.1-static-env.sh
98cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} -Wno-dev -B build -S .
99%__make %{?_smp_mflags} -C build
100
101%install
102%__make DESTDIR="%{buildroot}" -C build install
103
104%clean
105[ -d "%{buildroot}" -a "%{buildroot}" != "/" ] && %__rm -rf "%{buildroot}"
106
107
108%files -n %{name}-jack
109%defattr(-,root,root)
110%doc AUTHORS COPYING ChangeLog README TODO
111#dir %{_datadir}/applications
112%dir %{_datadir}/metainfo
113#dir %{_datadir}/mime
114#dir %{_datadir}/mime/packages
115%dir %{_datadir}/icons/hicolor
116%dir %{_datadir}/icons/hicolor/32x32
117%dir %{_datadir}/icons/hicolor/32x32/apps
118%dir %{_datadir}/icons/hicolor/32x32/mimetypes
119%dir %{_datadir}/icons/hicolor/scalable
120%dir %{_datadir}/icons/hicolor/scalable/apps
121%dir %{_datadir}/icons/hicolor/scalable/mimetypes
122#dir %{_datadir}/man
123#dir %{_datadir}/man/man1
124#dir %{_datadir}/man/fr
125#dir %{_datadir}/man/fr/man1
126%{_bindir}/%{name}_jack
127%{_datadir}/metainfo/%{name}.appdata.xml
128%{_datadir}/applications/%{name}.desktop
129%{_datadir}/mime/packages/%{name}.xml
130%{_datadir}/icons/hicolor/32x32/apps/%{name}.png
131%{_datadir}/icons/hicolor/32x32/mimetypes/application-x-%{name}*.png
132%{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
133%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-%{name}*.svg
134%{_datadir}/man/man1/%{name}.1.gz
135%{_datadir}/man/fr/man1/%{name}.1.gz
136
137%files -n %{name}-lv2
138%defattr(-,root,root)
139%dir %{_libdir}/lv2
140%dir %{_libdir}/lv2/%{name}.lv2
141%{_libdir}/lv2/%{name}.lv2/manifest.ttl
142%{_libdir}/lv2/%{name}.lv2/%{name}.ttl
143%{_libdir}/lv2/%{name}.lv2/%{name}.so
144%{_libdir}/lv2/%{name}.lv2/%{name}_ui.ttl
145
146
147%changelog
148* Wed Jul  7 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.23
149- An Early-Summer'21 Release.
150* Thu May 13 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.22
151- A Spring'21 Release.
152* Tue Mar 16 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.21
153- An End-of-Winter'21 Release.
154* Wed Feb 10 2021 Rui Nuno Capela <rncbc@rncbc.org> 0.9.20
155- A Winter'21 Release.
156* Sat Dec 19 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.19
157- A Winter'20 Release.
158* Tue Oct 27 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.18
159- A Fall'20 Release.
160* Tue Sep  8 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.17
161- A Late Summer'20 Release.
162* Thu Aug  6 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.16
163- A Summer'20 Release.
164* Mon Jun 22 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.15
165- An Early-Summer'20 Release.
166* Tue May  5 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.14
167- A Mid-Spring'20 Release.
168* Thu Mar 26 2020 Rui Nuno Capela <rncbc@rncbc.org> 0.9.13
169- A Spring'20 Release.
170* Thu Dec 26 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.9.12
171- The Winter'19 Release.
172* Thu Oct 31 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.9.11
173- A Halloween'19 Release.
174* Thu Oct  3 2019 Rui Nuno Capela <rncbc@rncbc.org>
175- [xstatic] Prepared for qtbase5-static build.
176* Tue Sep 24 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.9.10
177- An Early-Fall'19 release.
178* Thu Jul 18 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.9.9
179- A Summer'19 release.
180* Thu Jun  6 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.9.8
181- A Spring'19 release.
182* Sun Apr 14 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.9.7
183- A Spring-Break'19 release.
184* Mon Mar 18 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.9.6
185- Pre-LAC2019 release frenzy.
186* Mon Mar  4 2019 Rui Nuno Capela <rncbc@rncbc.org> 0.9.5
187- The End of Winter'19 release.
188* Wed Dec 12 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.9.4
189- A Late Autumn'18 release.
190* Mon Oct 22 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.9.3
191- An Autumn'18 release.
192* Tue Jul 24 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.9.2
193- A Summer'18 release.
194* Tue Jun 26 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.9.1
195- An Early Summer'18 release.
196* Wed Mar  7 2018 Rui Nuno Capela <rncbc@rncbc.org> 0.9.0
197- The End of Winter'18 release.
198* Wed Dec 20 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.8.6
199- The End of Autumn'17 release.
200* Sun Oct 29 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.8.5
201- An Autumn'17 release.
202* Tue Aug 22 2017 Rui Nuno Capela <rncbc@rncbc.org> 0.8.4
203- A Late-Summer'17 release.
204- First public release.
205* Thu Jul 20 2017 Rui Nuno Capela <rncbc@rncbc.org>
206- Created initial padthv1.spec
207