1# -*- RPM-SPEC -*-
2%define name    @PACKAGE@
3%define version @VERSION@
4%define release SNAP
5
6Name:      %{name}
7Version:   %{version}
8Release:   %{release}
9Summary:   Rasqal RDF Query Library
10
11Group:     System Environment/Libraries
12License:   LGPLv2+ or ASL 2.0
13Source:    http://download.librdf.org/source/%{name}-%{version}.tar.gz
14URL:       http://librdf.org/rasqal/
15BuildRoot: /tmp/%{name}-%{version}
16
17BuildRequires: libxml2-devel
18BuildRequires: mpfr-devel
19BuildRequires: pcre-devel
20BuildRequires: raptor2-devel >= @RAPTOR_MIN_VERSION@
21# for the testsuite
22BuildRequires:  perl(XML::DOM)
23
24Packager:  Dave Beckett <dave@dajobe.org>
25
26# Not needed since raptor2-devel require above will pull this in.
27# Requires: raptor2 >= @RAPTOR_MIN_VERSION@
28
29%description
30
31Rasqal is a library providing full support for querying Resource
32Description Framework (RDF) including parsing query syntaxes, constructing
33the queries, executing them and returning result formats.  It supports
34parsing and executing the SPARQL query language.
35
36%package devel
37Summary: Development files for the Rasqal RDF query library
38Group: Development/Libraries
39Requires: rasqal = %{version}
40Requires: gtk-doc
41Requires: pkgconfig
42Requires: raptor2-devel >= @RAPTOR_MIN_VERSION@
43%description devel
44Libraries, includes etc to develop with the Rasqal RDF query language library.
45
46%prep
47%setup -q
48
49%build
50
51%configure --enable-release
52
53%{__make} OPTIMIZE="$RPM_OPT_FLAGS"
54
55%install
56[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
57
58install -d $RPM_BUILD_ROOT%{_mandir}/man1
59install -d $RPM_BUILD_ROOT%{_mandir}/man3
60
61%makeinstall
62
63# Fedora deletes .la files here
64
65%clean
66[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
67
68%post -p /sbin/ldconfig
69
70%postun -p /sbin/ldconfig
71
72%files
73%defattr(-, root, root)
74%doc AUTHORS COPYING COPYING.LIB ChangeLog LICENSE.txt NEWS README
75%doc LICENSE-2.0.txt NOTICE
76%doc *.html
77%{_bindir}/roqet
78%{_libdir}/librasqal*.so.*
79%doc %{_mandir}/man1/roqet.1*
80
81%files devel
82%defattr(-, root, root)
83%doc docs/README.html
84%{_bindir}/rasqal-config
85%{_includedir}/rasqal/
86%{_libdir}/librasqal*.so
87%{_libdir}/pkgconfig/rasqal.pc
88%{_mandir}/man1/rasqal-config.1*
89%{_mandir}/man3/librasqal.3*
90%{_datadir}/gtk-doc/html/rasqal/
91
92# Fedora rasqal-devel package does not include these
93%{_libdir}/librasqal*.a
94%{_libdir}/librasqal*.la
95
96
97%changelog
98* Tue Feb 1 2011  Dave Beckett <dave@dajobe.org>
99- Raptor 2 attempt
100
101* Wed Aug 11 2005  Dave Beckett <dave.beckett@bristol.ac.uk>
102- Update Source:
103- Use %makeinstall
104
105* Wed Aug 10 2005  Dave Beckett <dave.beckett@bristol.ac.uk>
106- Use %configure.
107
108* Fri Jul 28 2005  Dave Beckett <dave.beckett@bristol.ac.uk>
109- Updated for gtk-doc locations
110
111* Fri Oct 22 2004 <Dave.Beckett@bristol.ac.uk>
112- License now LGPL/Apache 2
113- Added LICENSE-2.0.txt and NOTICE
114
115* Wed May 5 2004 <Dave.Beckett@bristol.ac.uk>
116- Ship roqet and roqet.1
117
118* Sat May 1 2004 <Dave.Beckett@bristol.ac.uk>
119- Requires raptor 1.3.0
120
121* Mon Feb 24 2004 <Dave.Beckett@bristol.ac.uk>
122- Requires raptor
123
124* Mon Aug 11 2003 <Dave.Beckett@bristol.ac.uk>
125- Initial packaging
126