1# $Id: bbkeys.spec.in,v 1.2 2005/03/05 16:59:07 vanrijn Exp $
2
3%define name		@PACKAGE@
4%define version		@VERSION@
5%define release		1
6%define builddir	$RPM_BUILD_DIR/%{name}-%{version}
7%define x11_libdir	/usr/X11R6/lib
8
9Summary: A completely configurable key-combo grabber for blackbox.
10Name:		%{name}
11Version:	%{version}
12Release:	%{release}
13License: GPL
14Group: User Interface/Desktops
15URL: http://bbkeys.sourceforge.net/
16Source: http://bbkeys.sourceforge.net/downloads/%{name}-%{version}.tar.gz
17BuildRequires: XFree86-devel, gcc-c++
18BuildRoot: %{_tmppath}/%{name}-root
19
20%description
21bbkeys is a configurable key-grabber designed for the blackbox window manager
22which is written by Brad Hughes.  Thanks to it (and blackbox) being
23EWMH-compliant, it also works well with any EWMH-compliant window manager
24(openbox, Gnome, KDE, etc.).  It was based on the bbtools object code
25created by John Kennis, but has been completely re-written for versions
260.9.0 and greater.  Blackbox 0.70.0 (on which it is dependent) now
27provides a common library, which bbkeys 0.9.0 makes use of.
28bbkeys is easily configurable via directly hand-editting the user's
29~/.bbkeysrc file, or by using the GUI total blackbox configurator, bbconf.
30
31%prep
32%setup -q
33
34%build
35%configure
36make %{?_smp_mflags}
37
38%install
39rm -rf %{buildroot}
40make install DESTDIR=%{buildroot}
41
42%clean
43rm -rf %{buildroot}
44
45%files
46%defattr(-, root, root)
47%doc AUTHORS BUGS ChangeLog LICENSE NEWS README TODO
48%exclude %{_prefix}/share/doc
49%{_bindir}/*
50%dir %{_datadir}/bbkeys
51%config %{_datadir}/bbkeys/*
52%{_mandir}/man?/*
53
54%changelog
55* Sat Mar  5 2005 Jason 'vanRijn' Kasper <vR@movingparts.net>
56- basing on previous work... updating for 0.9.0
57
58* Fri Nov  7 2003 Matthias Saou <http://freshrpms.net/> - 0.8.6-3.fr
59- Rebuild for Fedora Core.
60
61* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
62- Rebuilt for Red Hat Linux 9.
63
64* Thu Mar  6 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
65- Update to 0.8.6.
66
67* Tue Aug 13 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
68- Spec file cleanup.
69
70* Sat Jan 12 2002 Jason 'vanRijn' Kasper <vR@movingparts.net>
71- removing README.bbkeys and adding BUGS and NEWS
72
73* Sat Jan 5 2002 Jason 'vanRijn' Kasper <vR@movingparts.net>
74- gzipping man pages by default and changing file list to reflect this
75
76* Mon Nov 5 2001 Jason 'vanRijn' Kasper <vR@movingparts.net>
77- removing bbkeysConfigC and replacing with bbkeysconf.pl
78
79* Tue Sep 18 2001 Jason Kasper <vR@movingparts.net>
80- changing to a dynamically-created bbkeys.spec
81
82* Sun Aug 5 2001 Jason Kasper <vR@movingparts.net>
83- added to file list for newly included files (docs and man pages)
84- install to %{prefix} instead of /usr
85
86* Sun May 6 2001 Hollis Blanchard <hollis@terraplex.com>
87- removed file list in favor of explicit %files section
88- install to /usr instead of /usr/local
89- buildroot = /var/tmp/bbkeys-buildroot instead of /tmp/buildroot
90
91