1Name: thrulay
2Summary: thrulay - network throughput and delay tester
3Version: @VERSION@
4Release: 1
5License: Internet2 License (modified BSD-like)
6Group: *Development/Libraries*
7URL: http://www.internet2.edu/~shalunov/thrulay/
8Source: %{name}-%{version}.tar.gz
9Packager: Federico Montesino Pouzols <fedemp@altern.org>
10BuildRequires: autoconf
11BuildRequires: automake
12BuildRequires: libtool
13Requires: thrulay-client, thrulay-server
14
15%description
16The program thrulay is used to measure the capacity of a network by
17sending a bulk TCP stream over it.
18
19Like other tools (such as iperf, netperf, nettest, nuttcp, ttcp,
20etc.), thrulay can report TCP throughput periodically so that TCP
21performance plots can be produced. Unlike other tools, thrulay not
22only reports goodput, but round-trip delay time as well. The output of
23thrulay is easy to parse by machine (in fact, it's ready to be used as
24a data file for gnuplot).
25
26Starting from version 0.5, thrulay supports UDP tests. Unique feature
27of thrulay is that it can send a Poisson stream of very precisely
28positioned packets; the TSC register is used for timing rather than
29very coarse (20ms on most systems) system sleep functionality.
30
31%files
32
33
34%package client
35Summary: thrulay client
36Group: Applications/Network
37Requires: libthrulay
38%description client
39thrulay command line tool for opening client thrulay connections to a
40thrulay server.
41
42
43%package server
44Summary: thrulay server
45Group: Applications/Network
46Requires: libthrulay
47%description server
48thrulayd command line tool.
49
50
51%package -n libthrulay
52Summary: thrulay API implementation
53Group: Development/Libraries
54%description -n libthrulay
55thrulay client and server API implementation.
56
57
58%package devel
59Requires: libthrulay
60Group: Development/Libraries
61Summary: thrulay library headers.
62%description
63This package includes documentation, header files, and static link
64libraries for building applications that use the thrulay library.
65
66%prep
67%setup -n thrulay-%{PACKAGE_VERSION}
68./configure --prefix=%{_prefix}
69
70%build
71uname -a | grep SMP && make -j 2 || make
72
73%install
74make prefix=$RPM_BUILD_ROOT/%{_prefix} \
75	mandir=$RPM_BUILD_ROOT/%{_mandir} \
76	infodir=$RPM_BUILD_ROOT/%{_infodir} install
77
78
79%files client
80%defattr(-,root,root,0755)
81%doc LICENSE README doc/thrulay-protocol.txt doc/RELEASE-0.7 doc/RELEASE-0.8
82%{_prefix}/bin/thrulay
83
84%files server
85%defattr(-,root,root,0755)
86%doc LICENSE README doc/thrulay-protocol.txt doc/RELEASE-0.7 doc/RELEASE-0.8
87%{_prefix}/sbin/thrulayd
88
89%files libthrulay
90%defattr(-,root,root,0755)
91%{_prefix}/lib/libthrulay.so*
92
93%files devel
94%defattr(-,root,root,0755)
95#%doc ChangeLog doc/refman/
96%{_prefix}/lib/libthrulay*.a
97%{_prefix}/include/thrulay/client.h
98%{_prefix}/include/thrulay/server.h
99
100%clean
101
102%post
103/sbin/ldconfig -n @libdir@
104
105%postun
106/sbin/ldconfig -n @libdir@
107
108%changelog
109*  Wed Jul 05 2006 Federico Montesino Pouzols <fedemp@altern.org> 0.8.0
110- Initial version.
111