1# Specification file to create an RPM package for sswf (Script to SWF)
2# Written by Alexis Wilke for Made to Order Software Corp. (c) 2002-2009
3#
4# Copyright (c) 2002-2009 Made to Order Software Corp.
5#
6# Permission is hereby granted, free of charge, to any
7# person obtaining a copy of this software and
8# associated documentation files (the "Software"), to
9# deal in the Software without restriction, including
10# without limitation the rights to use, copy, modify,
11# merge, publish, distribute, sublicense, and/or sell
12# copies of the Software, and to permit persons to whom
13# the Software is furnished to do so, subject to the
14# following conditions:
15#
16# The above copyright notice and this permission notice
17# shall be included in all copies or substantial
18# portions of the Software.
19#
20# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
21# ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT
22# LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
23# FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO
24# EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
25# LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
26# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
27# ARISING FROM, OUT OF OR IN CONNECTION WITH THE
28# SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
29# SOFTWARE.
30#
31
32
33Summary: SSWF library and compiler to create Flash movies
34Name: sswf
35Version: <VERSION>
36Release: 3
37License: MIT License
38# Somehow, RPM views License & Copyright as the same thing!
39#Copyright: Made to Order Software Corp.
40Group: WebDevelopment/Tools
41Vendor: Made to Order Software Corp.
42Source0: sswf-<VERSION>-src.tar.gz
43Source1: sswf-<VERSION>-doc.tar.gz
44BuildRoot: %{_topdir}/%{name}-root
45URL: http://sswf.sourceforge.net
46Packager: Alexis Wilke (alexis_wilke@users.sourceforge.net)
47Requires: zlib libjpeg <FREETYPE>
48Provides: sswf swf_dump ft2sswf jpg2swf asc libsswf libsswf-<VERSION>.so libsswf.so libsswf.a libsswf_as.so libsswf_as.a libsswf_asas.so libsswf_asas.a
49Distribution: SSWF RPM
50BuildRequires: bison libjpeg-devel <FREETYPE>-devel zlib-devel
51
52%description
53The SSWF tool is a compiler which generates Flash movies
54from a list of .sswf script files. It uses the SSWF library
55which comes along.
56
57This package includes all the binaries available in the SSWF
58project, the SSWF library, the documentations and some script
59samples to get you started.
60
61The binaries are: sswf, swf_dump, ft2sswf, jpg2swf and asc.
62The libraries are: libsswf, libsswf_as, libsswf_asas
63
64# This does not seem to have an effect...
65# and I could not find a correct document about it.
66#%debug_package
67%prep
68%setup -b 1
69
70%build
71
72# The <percent>configure doesn't use the correct parameters to create
73# the Makefile in the source location (weird); this maybe because
74# I have an older version of rpmbuild too...
75#<percent>configure
76# results in:
77#configure --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu
78#	--target=i486-redhat-linux --program-prefix=
79#	--prefix=/usr --exec-prefix=/usr --bindir=/usr/bin
80#	--sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share
81#	--includedir=/usr/include --libdir=/usr/lib
82#	--libexecdir=/usr/libexec --localstatedir=/var
83#	--sharedstatedir=/usr/com --mandir=/usr/share/man
84#	--infodir=/usr/share/info
85
86# We now avoid installing the HTML documentation with the make
87# command line because the %doc will take care of that for us.
88./configure --prefix=%{buildroot}%{_prefix} --mandir=%{buildroot}%{_mandir} --enable-rpm-docs
89make
90
91%install
92if test ! "%{buildroot}" = "/"; then
93	rm -rf %{buildroot}
94fi
95
96make install
97
98#	prefix=%{buildroot}%{_prefix} \
99#	exec_prefix=%{buildroot}%{_exec_prefix} \
100#	bindir=%{buildroot}%{_bindir} \
101#	sbindir=%{buildroot}%{_sbindir} \
102#	sysconfdir=%{buildroot}%{_sysconfdir} \
103#	datadir=%{buildroot}%{_datadir} \
104#	includedir=%{buildroot}%{_includedir} \
105#	libdir=%{buildroot}%{_libdir} \
106#	libexecdir=%{buildroot}%{_libexecdir} \
107#	localstatedir=%{buildroot}%{_localstatedir} \
108#	sharedstatedir=%{buildroot}%{_sharedstatedir} \
109#	docdir=%{buildroot}%{_docdir} \
110#	mandir=%{buildroot}%{_mandir} \
111#	infodir=%{buildroot}%{_infodir} \
112#	rpminstall
113
114%clean
115if test ! "%{buildroot}" = "/"; then
116	rm -rf %{buildroot}
117fi
118
119make clean
120
121%files
122%defattr(-, root, root)
123%doc README.txt doc/*.txt
124
125
126# Binaries
127%{_bindir}/*
128
129# Libraries & includes
130%{_libdir}/*
131%{_includedir}/sswf/*
132
133# Manual pages
134%{_mandir}/man1/*
135
136# Scripts to include
137%{_datadir}/sswf/scripts/*
138
139# Documentation
140%{_datadir}/sswf/*.txt
141%{_datadir}/sswf/html/*
142
143# Samples
144%{_datadir}/sswf/samples/*
145
146# Miscellaneous
147%{_datadir}/sswf/misc/*
148
149%changelog
150* Sun May 28 2006 Alexis Wilke <alexis@m2osw.com> 1.7.4-3
151- Moved the HTML documentation to /usr/share/doc/sswf-<version>
152
153* Thu Oct 25 2004 Alexis Wilke <alexis@m2osw.com> 1.7.0-2
154- Changes to the .spec file so the configure script is being used
155
156* Mon Nov 04 2002 Alexis Wilke <alexis@m2osw.com> 1.4.3-1
157- Initial RMP
158
159