1Summary: The GLE Tubing and Extrusion Library for OpenGL
2Name: gle
3Version: 3.1.0
4Release: 1
5Epoch: 1
6Copyright: Mix+match open source
7Group: System Environment/Libraries
8URL: http://www.linas.org/gle/
9Packager: Rob Knop <rknop@pobox.com>
10Source: http://www.linas.org/gle/pub/gle-%{version}.tar.gz
11BuildPrereq: Mesa
12Requires: Mesa
13Provides: GLE-%{version}
14AutoReqProv: yes
15#Obsoletes:
16Buildroot: /var/tmp/gle-root
17Prefix: /usr
18
19%description
20The GLE Tubing and Extrusion Library consists of a number of "C"
21language subroutines for drawing tubing and extrusions. It is a very
22fast implementation of these shapes, outperforming all other
23implementations, most by orders of magnitude. It uses the
24OpenGL (TM) programming API to perform the actual drawing of the tubing
25and extrusions.
26
27%package devel
28Requires: Mesa-devel GLE-%{version}
29Summary: GLE includes and development libraries
30Group: Development/Libraries
31
32%description devel
33Includes, man pages, and development libraries for the GLE Tubing and
34Extrusion Library.
35
36%prep
37%setup -q
38
39%build
40./configure --prefix=${prefix}
41make
42
43%install
44rm -rf $RPM_BUILD_ROOT
45mkdir -p $RPM_BUILD_ROOT%{prefix}/lib
46mkdir -p $RPM_BUILD_ROOT%{prefix}/include
47mkdir -p $RPM_BUILD_ROOT%{prefix}/include/GL
48mkdir -p $RPM_BUILD_ROOT%{prefix}/man
49mkdir -p $RPM_BUILD_ROOT%{prefix}/man/man3
50mkdir -p $RPM_BUILD_ROOT%{prefix}/share
51mkdir -p $RPM_BUILD_ROOT%{prefix}/share/doc
52mkdir -p $RPM_BUILD_ROOT%{prefix}/share/doc/examples
53mkdir -p $RPM_BUILD_ROOT%{prefix}/share/doc/html
54make prefix=$RPM_BUILD_ROOT%{prefix} install
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%files
60%defattr(-,root,root)
61%{prefix}/lib/*.so*
62%{prefix}/share/doc/gle/AUTHORS
63%{prefix}/share/doc/gle/COPYING*
64%{prefix}/share/doc/gle/README
65
66%files devel
67%{prefix}/include/GL/*
68%{prefix}/lib/*a
69%{prefix}/man/man3/*
70%{prefix}/share/doc/gle/examples/*
71%{prefix}/share/doc/gle/html/*
72
73
74%changelog
75* Tue Mar 05 2002 Linas Vepstas <linas@linas.org>
76- changes since June 2001 include:
77- configure fixes
78- ms windows related fixes
79- python binding fixes
80* Thu Jul 20 2001 Linas Vepstas <linas@linas.org>
81- Added doc subdirectory
82* Thu Jul 05 2001 Rob Knop <rknop@pobox.com>
83- Created the spec file
84