1Summary:	@PACKAGE_NAME@
2Name:		@PACKAGE_NAME@
3Version:	@PACKAGE_VERSION@
4Release:	1
5License:	LGPL
6Packager:	LessTif Releasemeister <lesstif-discuss@lists.sourceforge.net>
7Group:		System Environment/Libraries
8Prefixes:	/usr/X11R6 /usr/doc
9Source:		ftp://ftp.hungry.com/pub/hungry/lesstif/lesstif-@PACKAGE_VERSION@.tar.gz
10BuildRoot:	/tmp/@PACKAGE_NAME@-@PACKAGE_VERSION@-root
11
12%description
13Lesstif is an API compatible clone of the Motif toolkit.
14Most of the Motif API is in place,
15we're working on improving it.
16Many Motif applications compile and run out-of-the-box with LessTif,
17and we want to hear about those that don't.
18
19%package mwm
20Summary: Lesstif Motif window manager clone based on fvwm
21Group: User Interface/Desktops
22Prefixes:  /usr/X11R6 /usr/doc /etc
23%description mwm
24MWM is a window manager that adheres largely to the Motif mwm specification.
25
26%package clients
27Summary: lesstif clients
28Group: Development/Tools
29Prefixes:  /usr/X11R6 /usr/doc
30%description clients
31Uil and xmbind.
32
33%package devel
34Group: Development/Libraries
35Prefixes:  /usr/X11R6 /usr/doc
36Summary: header files for Lesstif/Motif development
37Requires: lesstif
38%description devel
39This package contains the lesstif header files
40required to develop motif-based applications.
41Package also contains development documentation in html (Lessdox), and
42mxmkmf for Lesstif.
43
44# %package static
45# Group: Development/Libraries
46# Prefixes:  /usr/X11R6
47# Summary: static libraries for Lesstif/Motif development
48# Requires: lesstif
49# %description static
50# This package contains the lesstif static libraries
51# required to develop motif-based applications.
52
53%prep
54%setup -n @PACKAGE_NAME@-@PACKAGE_VERSION@
55
56LESSTIFTOP=$PWD
57
58CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 --enable-production
59
60%build
61make -j4
62
63%install
64# chmod a-x [A-Z]*
65make install DESTDIR=$RPM_BUILD_ROOT
66
67strip $RPM_BUILD_ROOT/usr/X11R6/bin/mwm
68strip $RPM_BUILD_ROOT/usr/X11R6/bin/uil
69strip $RPM_BUILD_ROOT/usr/X11R6/bin/xmbind
70strip $RPM_BUILD_ROOT/usr/X11R6/lib/libXm.so*
71strip $RPM_BUILD_ROOT/usr/X11R6/lib/libMrm.so*
72strip $RPM_BUILD_ROOT/usr/X11R6/lib/libDtPrint.so*
73
74install -d $RPM_BUILD_ROOT/etc/X11
75ln -sf ../../usr/X11R6/lib/X11/mwm $RPM_BUILD_ROOT/etc/X11/mwm
76
77install -d $RPM_BUILD_ROOT/usr/X11R6/man
78install -d $RPM_BUILD_ROOT/usr/X11R6/man/man1
79install -d $RPM_BUILD_ROOT/usr/X11R6/man/man3
80install -d $RPM_BUILD_ROOT/usr/X11R6/man/man5
81# install -c -m 644 doc/lessdox/clients/mwmrc.5   $RPM_BUILD_ROOT/usr/X11R6/man/man5
82# install -c -m 644 doc/lessdox/clients/mwm.1     $RPM_BUILD_ROOT/usr/X11R6/man/man1
83# install -c -m 644 doc/lessdox/clients/lesstif.1 $RPM_BUILD_ROOT/usr/X11R6/man/man1
84# install -c -m 644 doc/lessdox/clients/xmbind.1  $RPM_BUILD_ROOT/usr/X11R6/man/man1
85install -c -m 644 doc/lessdox/*/*.html $RPM_BUILD_ROOT/usr/X11R6/LessTif/doc/Lessdox || :
86
87# generate config files
88# cd $RPM_BUILD_ROOT/usr/X11R6/lib/X11/config;
89#
90# mv Motif.rules Motif-lesstif.rules
91# mv Motif.tmpl  Motif-lesstif.tmpl
92
93# cleanup in a preparation for an installation - unify layout
94
95%post -p /sbin/ldconfig
96%postun -p /sbin/ldconfig
97
98%clean
99#do this manually; it's a better idea
100#rm -rf $RPM_BUILD_ROOT
101
102%files
103#%attr(755, root, root) %doc
104%multiarch %attr(644, root, root) /usr/X11R6/LessTif/AUTHORS
105%multiarch %attr(644, root, root) /usr/X11R6/LessTif/BUG-REPORTING
106%multiarch %attr(644, root, root) /usr/X11R6/LessTif/COPYING
107%multiarch %attr(644, root, root) /usr/X11R6/LessTif/COPYING.LIB
108%multiarch %attr(644, root, root) /usr/X11R6/LessTif/CREDITS
109%multiarch %attr(644, root, root) /usr/X11R6/LessTif/FAQ
110%multiarch %attr(644, root, root) /usr/X11R6/LessTif/INSTALL.txt
111%multiarch %attr(644, root, root) /usr/X11R6/LessTif/README
112%multiarch %attr(644, root, root) /usr/X11R6/LessTif/ReleaseNotes.txt
113%multiarch %attr(644, root, root) /usr/X11R6/LessTif/ReleaseNotes.html
114%attr(755, root, root) %dir /usr/X11R6/lib
115%attr(755, root, root) /usr/X11R6/lib/libXm.so*
116%attr(755, root, root) /usr/X11R6/lib/libXm.la
117%attr(755, root, root) /usr/X11R6/lib/libMrm.so*
118%attr(755, root, root) /usr/X11R6/lib/libMrm.la
119%attr(755, root, root) /usr/X11R6/lib/libUil.so*
120%attr(755, root, root) /usr/X11R6/lib/libUil.la
121%attr(755, root, root) /usr/X11R6/lib/libDtPrint.so*
122%attr(755, root, root) /usr/X11R6/lib/libDtPrint.la
123%multiarch %attr(755, root, root) %dir /usr/X11R6/LessTif/doc
124%multiarch %attr(-, root, root) /usr/X11R6/LessTif/doc/*
125%multiarch %attr(644, root, root) /usr/X11R6/man/man1/lesstif.1*
126%multiarch %attr(644, root, root) /usr/X11R6/man/man1/ltversion.1*
127%multiarch %attr(644, root, root) /usr/X11R6/man/man5/VirtualBindings.5*
128
129%files mwm
130%multiarch %attr(644, root, root) %doc clients/Motif-2.1/mwm/COPYING
131%multiarch %attr(644, root, root) %doc clients/Motif-2.1/mwm/README
132%multiarch %attr(755, root, root) %dir /etc/X11/mwm
133%multiarch %attr(755, root, root) %dir /usr/X11R6/lib/X11/mwm
134%multiarch %attr(755, root, root) /usr/X11R6/bin/mwm
135%multiarch %attr(644, root, root) %config /usr/X11R6/lib/X11/mwm/*
136%multiarch %attr(644, root, root) %config /usr/X11R6/lib/X11/app-defaults/Mwm
137%multiarch %attr(644, root, root) /usr/X11R6/man/man1/mwm.1*
138%multiarch %attr(644, root, root) /usr/X11R6/man/man5/mwmrc.5*
139
140%files clients
141%multiarch %attr(644, root, root) %doc doc/UIL.txt
142%attr(755, root, root) /usr/X11R6/bin/uil
143%attr(755, root, root) /usr/X11R6/bin/xmbind
144%multiarch %attr(644, root, root) /usr/X11R6/man/man1/xmbind.1*
145%multiarch %attr(644, root, root) /usr/X11R6/man/man1/uil.1*
146
147%files devel
148# %doc doc/lessdox/*
149%attr(755, root, root) %dir /usr/X11R6/include/Mrm
150%attr(755, root, root) %dir /usr/X11R6/include/Xm
151%attr(755, root, root) %dir /usr/X11R6/include/Dt
152%attr(755, root, root) %dir /usr/X11R6/include/uil
153%attr(644, root, root) /usr/X11R6/include/Mrm/*
154%attr(644, root, root) /usr/X11R6/include/Xm/*
155%attr(644, root, root) /usr/X11R6/include/Dt/*
156%attr(644, root, root) /usr/X11R6/include/uil/*
157%multiarch %attr(755, root, root) /usr/X11R6/bin/mxmkmf
158%multiarch %attr(755, root, root) /usr/X11R6/bin/motif-config
159%multiarch %attr(644, root, root) /usr/X11R6/man/man3/*.3*
160%multiarch %attr(644, root, root) @ACLOCALDIR@/ac_find_motif.m4
161%multiarch %attr(644, root, root) /usr/X11R6/lib/LessTif/config/LessTif.rules
162%multiarch %attr(644, root, root) /usr/X11R6/lib/LessTif/config/LessTif.tmpl
163%multiarch %attr(644, root, root) /usr/X11R6/lib/LessTif/config/host.def
164
165%changelog
166* Fri May  6 2005 Danny Backx <dannybackx@users.sourceforge.net>
167- Flag the motif-config script as %multiarch.
168
169* Sun Jan 16 2005 Danny Backx <dannybackx@users.sourceforge.net>
170- Add the motif-config script.
171
172* Sun Oct 17 2004 Danny Backx <dannybackx@users.sourceforge.net>
173- Get installation directory for AC macro file from the build.
174
175* Tue Sep 28 2004 Danny Backx <dannybackx@users.sourceforge.net>
176- Configure should be launched with fewer parameters to approximate
177  its default behaviour.
178
179* Sat Aug 28 2004 Danny Backx <dannybackx@users.sourceforge.net>
180- Make it all 2.1.
181
182* Fri Aug 6 2004 Danny Backx <dannybackx@users.sourceforge.net>
183- Remove the references to 1.2 in this file.
184- Fixes for changes with the auto tools.
185- Packager is the new name of the mailing list.
186- Add lots of files that were not previously correctly packages.
187
188* Wed Sep 19 2001 Danny Backx <danny.backx@skynet.be>
189- Adapt to new directory structure without the MotifX.Y in it.
190
191* Tue Aug 28 2001 Danny Backx <danny.backx@skynet.be>
192- Changes w.r.t. renamed and removed documentation files.
193
194* Wed Jul 18 2001 Danny Backx <danny.backx@skynet.be>
195- Remove Xbae, Xlt
196
197* Fri Mar 30 2001 Danny Backx <danny.backx@skynet.be>
198- Rename Dt library to DtPrint
199- Fix the toplevel documentation ownership.
200  This is a solution for bug 410578.
201- Comment out the static RPM definition.
202  Static libs are not something we should promote, they're also *big*.
203- Use "make -j2" to speed up compilation a bit if you have enough RAM.
204- Add --disable-debug flag to avoid compile with -g, we strip the
205  libraries anyway.
206- Remove the %doc doc/lessdox/* line because it causes unnecessary
207  file inclusion, and a problem during the rpm build process.
208- Add %attr to all %doc lines.
209
210* Thu Dec 21 2000 John Gotts <jgotts@linuxsavvy.com>
211- Wildcard on manual pages because some versions of RPM compress them.
212- Include the 2.* clients (uil, mwm, xmbind).
213
214* Sat Dec  9 2000 Danny Backx <danny.backx@skynet.be>
215- Add Dt and uil, both include files and libraries.
216
217* Tue Nov 14 2000 Danny Backx <danny.backx@skynet.be>
218- Replace 2.0 version by 2.1.
219
220* Mon Oct 23 2000 John Gotts <jgotts@linuxsavvy.com>
221- Removed %attr for %doc because the documentation directories were getting
222  created without the execute bit set.
223- Synched the current state of the documentation.
224- Fixed the categories to be consistent with Red Hat Linux.
225
226* Sat Oct  7 2000 Danny Backx <danny.backx@skynet.be>
227- Remove Imake.tmpl handling, it was removed from lib/config a while ago.
228
229* Sun Sep 10 2000 Danny Backx <danny.backx@skynet.be>
230- Change the default so 2.0 library and include files get used, but
231  1.2 is also still built and installed.
232
233* Tue Jul 11 2000 Danny Backx <danny.backx@skynet.be>
234- BuildRoot was wrong, changed it so it now works with what autoconf
235  provides (PACKAGE and VERSION macros).
236
237* Wed Jun 14 2000 Danny Backx <danny.backx@skynet.be>
238- Make sure that links for libXm, libMrm are in /usr/X11R6/lib too,
239  not only in /usr/X11R6/LessTif/Motif2.0/lib .
240
241* Tue Apr 25 2000 Danny Backx <danny.backx@skynet.be>
242- add CFLAGS="$RPM_OPT_FLAGS" in front of ./configure to be able to
243  pass parameters when building.
244  Fix for linuxppc by howarth@bromo.med.uc.edu (Jack Howarth).
245
246* Sat Apr 8 2000 Danny Backx <danny.backx@skynet.be>
247- Add the "static" file
248
249* Wed Apr 5 2000 Danny Backx <danny.backx@skynet.be>
250- Make sure to include both directories and files for Xlt, Xbae in "devel"
251
252* Wed Feb 23 2000 Jon Christopher <jon@hungry.com>
253- Don't use brace expansion because not all distributions have a full
254- featured bash as /bin/sh
255
256* Wed Jan 19 2000 Danny Backx <danny@hungry.com>
257- Remove static libs from the regular file, they should be in "devel" only.
258- Change path for DESTDIR as indicated by Pavel Roskin.
259
260* Fri Dec 10 1999 Danny Backx <danny@hungry.com>
261- Changed "make install prefix=..." to use DESTDIR. Prefix is not properly
262  forwarded in the directory tree, DESTDIR is.
263
264* Wed Dec 8 1999 Danny Backx <danny@hungry.com>
265- be sure to include Xbae and Xlt in packaging (%files sections)
266- include 2.0 libraries and includes in the standard rpm
267
268* Sat Oct 23 1999 Danny Backx <danny@hungry.com>
269- try to integrate Michal's stuff in lesstif.spec.in
270- don't treat Xbae, Xlt separately
271- compile for 2.0 as well as for 1.2
272- compile Xbae, Xlt by default
273
274* Tue Oct 19 1999 Michal Jaegermann <michal@harddata.com>              (0.89)
275- Updated to version 0.89
276- Reorganized spec file to follow closer its own descriptions
277- Xlt does not require special make anymore.
278
279* Thu Apr 30 1998 C. Scott Ananian <cananian@alumni.princeton.edu>      (0.83+)
280- Updated to lessdoc-current.
281- Removes Lessdox package (integrated into lesstif)
282
283* Tue Mar 31 1998 C. Scott Ananian <cananian@alumni.princeton.edu>      (0.83+)
284- Removed pedantic.patch
285- Removed lesstif-M12 (Motif 1.2 wrapper)
286- Reviewed installation and fixed %files sections.
287- Added patch to fix a bug which causes mozilla to crash.
288- Added patch to fix the include prefix on install.
289
290* Sun Jul 20 1997 Tomasz K�oczko <kloczek@rudy.mif.pg.gda.pl>        (0.80-2)
291- added to all %doc %attr macros (this allow build package from normal user
292  account),
293- some simplification in %files (%doc).
294
295* Wed Jul 9 1997 Tomasz K�oczko <kloczek@rudy.mif.pg.gda.pl>
296- added using %%{PACKAGE_VERSION} macro in "Source:" and %files,
297- added additional parameter "--enable-build-12" to runing configure,
298- added %posun and %clear,
299- in %post and %postun ldconfig is called as parameter with "-p"
300  (this feature is avalable in rpm >= 2.4.3 and you must have this
301  version and if you want recompile package from src.rpm you must have new
302  version rpm),
303- added package lesstif-M12 simpe Motif 1.2 wrapper,
304- simplified %_install section,
305- added %attr macros in %files sections,
306- added striping shared libraries,
307- added URL field,
308- added Lessdox - a html development documentation to lesstif-devel,
309- added lesstif-0.80public-nopedantic.patch, this allow compile lesstif on
310  sparc by removing "-pedantic" from CFLAGS.
311
312
313
314
315