1Summary:   A remote display system.
2Name:      tightvnc
3Version:   1.3.10
4Release:   1
5URL:       http://www.tightvnc.com/
6Source0:   tightvnc-%{version}_unixsrc.tar.bz2
7License:   GPL
8Group:     User Interface/Desktops
9Packager:  Constantin Kaplinsky <const@tightvnc.com>
10Obsoletes: vnc
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildPrereq: /usr/bin/perl tcp_wrappers
13BuildRequires: zlib-devel libjpeg-devel
14ExclusiveArch: i386 alpha sparc ppc s390 s390x
15
16%description
17Virtual Network Computing (VNC) is a remote display system which
18allows you to view a computing 'desktop' environment not only on the
19machine where it is running, but from anywhere on the Internet and
20from a wide variety of machine architectures. TightVNC is an enhanced
21VNC distribution. This package contains a client which will allow you
22to connect to other desktops running a VNC or a TightVNC server.
23
24%package server
25Summary: TightVNC server
26Obsoletes: vnc-server
27Requires: bash >= 2.0
28Group: User Interface/X
29Prereq: /sbin/chkconfig /sbin/service /etc/init.d
30
31%description server
32The VNC system allows you to access the same desktop from a wide
33variety of platforms. TightVNC is an enhanced VNC distribution. This
34package is a TightVNC server, allowing others to access the desktop on
35your machine.
36
37%prep
38%setup -q -n vnc_unixsrc
39
40perl -pi -e "s|/usr/local/vnc/classes|%{_datadir}/vnc/classes|" vncserver
41
42%build
43# Use xinit's Xclients script to start the session (bug #52711)
44patch < vnc-xclients.patch
45
46xmkmf -a
47make CDEBUGFLAGS="$RPM_OPT_FLAGS" World
48cd Xvnc
49./configure
50make EXTRA_LIBRARIES="-lwrap -lnss_nis" CDEBUGFLAGS="$RPM_OPT_FLAGS" \
51     EXTRA_DEFINES="-DUSE_LIBWRAP=1"
52
53%install
54rm -rf %{buildroot}
55
56mkdir -p %{buildroot}%{_bindir}
57mkdir -p %{buildroot}%{_mandir}/man1
58./vncinstall %{buildroot}%{_bindir} %{buildroot}%{_mandir}
59
60mkdir -p %{buildroot}%{_datadir}/vnc
61cp -aR classes %{buildroot}%{_datadir}/vnc
62
63strip %{buildroot}%{_bindir}/* || :
64
65mkdir -p %{buildroot}/etc/rc.d/init.d
66install -m755 vncserver.init %{buildroot}/etc/rc.d/init.d/vncserver
67
68mkdir -p %{buildroot}/etc/sysconfig
69cat > %{buildroot}/etc/sysconfig/vncservers << EOF
70# The VNCSERVERS variable is a list of display:user pairs.
71#
72# Uncomment the line below to start a VNC server on display :1
73# as my 'myusername' (adjust this to your own).  You will also
74# need to set a VNC password; run 'man vncpasswd' to see how
75# to do that.  
76#
77# DO NOT RUN THIS SERVICE if your local area network is
78# untrusted!  For a secure way of using VNC, see
79# <URL:http://www.uk.research.att.com/vnc/sshvnc.html>.
80
81# VNCSERVERS="1:myusername"
82EOF
83chmod 644 %{buildroot}/etc/sysconfig/vncservers
84
85mkdir -p %{buildroot}/etc/X11/applnk/Applications
86cat > %{buildroot}/etc/X11/applnk/Applications/vncviewer.desktop << EOF
87[Desktop Entry]
88Name=VNC Viewer
89Comment=VNC client application
90Exec=/usr/bin/vncviewer
91Terminal=0
92Type=Application
93EOF
94
95%clean
96rm -rf %{buildroot}
97
98%post server
99if [ "$1" = 1 ]; then
100  /sbin/chkconfig --add vncserver
101fi
102
103%preun server
104if [ "$1" = 0 ]; then
105  /sbin/service vncserver stop >/dev/null 2>&1
106  /sbin/chkconfig --del vncserver
107fi
108
109%postun server
110if [ "$1" -ge "1" ]; then
111  /sbin/service vncserver condrestart >/dev/null 2>&1
112fi
113
114%files
115%defattr(-,root,root)
116%doc LICENCE.TXT README WhatsNew ChangeLog
117%{_bindir}/vncviewer
118%config(noreplace) /etc/X11/applnk/Applications/vncviewer.desktop
119%{_mandir}/man1/vncviewer.1*
120
121%files server
122%defattr(-,root,root)
123%doc LICENCE.TXT README WhatsNew ChangeLog
124%attr(0755,root,root) %config /etc/rc.d/init.d/vncserver
125%config(noreplace) /etc/sysconfig/vncservers
126%{_bindir}/Xvnc
127%{_bindir}/vncserver
128%{_bindir}/vncpasswd
129%{_bindir}/vncconnect
130%{_datadir}/vnc
131%{_mandir}/man1/Xvnc.1*
132%{_mandir}/man1/vncserver.1*
133%{_mandir}/man1/vncconnect.1*
134%{_mandir}/man1/vncpasswd.1*
135
136%changelog
137* Thu Feb  5 2009 Constantin Kaplinsky <const@tightvnc.com>
138- Version 1.3.10.
139
140* Thu Apr 26 2007 Constantin Kaplinsky <const@tightvnc.com>
141- Version 1.3.9.
142
143* Fri Aug 11 2006 Constantin Kaplinsky <const@tightvnc.com>
144- Version 1.3.8.
145
146* Sun Jul 03 2005 Constantin Kaplinsky <const@tightvnc.com>
147- Removed vnc-server's dependence on XFree86, changed maintainer's
148  e-mail address, TightVNC updated to 1.3dev7.
149
150* Sun May 30 2004 Constantin Kaplinsky <const@ce.cctpu.edu.ru>
151- TightVNC 1.3dev5 update.
152
153* Thu Mar 04 2004 Constantin Kaplinsky <const@ce.cctpu.edu.ru>
154- TightVNC 1.3dev4 update.
155
156* Fri Feb 27 2004 Constantin Kaplinsky <const@ce.cctpu.edu.ru>
157- TightVNC 1.3dev3 update.
158
159* Wed Jan 29 2003 Constantin Kaplinsky <const@ce.cctpu.edu.ru>
160- TightVNC 1.2.8 update.
161- Dependencies on /sbin/chkconfig and /sbin/service has been removed
162  for the viewer part.
163
164* Thu Nov 14 2002 Constantin Kaplinsky <const@ce.cctpu.edu.ru>
165- TightVNC 1.2.7 update.
166
167* Sat Aug 10 2002 Constantin Kaplinsky <const@ce.cctpu.edu.ru>
168- TightVNC 1.2.5 update.
169
170* Tue May 21 2002 Constantin Kaplinsky <const@ce.cctpu.edu.ru>
171- TightVNC 1.2.4 update.
172
173* Fri Mar 22 2002 Constantin Kaplinsky <const@ce.cctpu.edu.ru>
174- TightVNC 1.2.3 update.
175
176* Tue Mar 12 2002 Tim Waugh <twaugh@redhat.com> 3.3.3r2-27
177- Don't block on partial HTTP requests (bug #58066).
178- Use the system-provided zlib instead of the bundled one in Xvnc.
179- Link to libz and libjpeg dynamically instead of statically in
180  vncviewer.
181- Fix docs permissions (bug #60783).
182
183* Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 3.3.3r2-26
184- Updated vncserver fp patch (see bug #58990):
185  - Check that Xvnc actually started.
186  - Try omitting font path specification if not.
187
188* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 3.3.3r2-25
189- automated rebuild
190
191* Wed Dec 05 2001 David Sainty <dsainty@redhat.com> 3.3.3r2-24
192- Added support for s390 and s390x architectures.
193
194* Thu Nov 29 2001 Tim Waugh <twaugh@redhat.com> 3.3.3r2-23
195- TightVNC 1.2.2.
196
197* Mon Nov  5 2001 Tim Waugh <twaugh@redhat.com> 3.3.3r2-22
198- Don't use bash redirections except in bash (bug #55686).
199
200* Fri Oct 26 2001 Tim Waugh <twaugh@redhat.com> 3.3.3r2-21
201- Run /etc/X11/xinit/xinitrc in xstartup, not Xclients (bug #52711).
202- Don't segfault when disconnecting from font server (bug #55135).
203
204* Wed Sep 26 2001 Tim Waugh <twaugh@redhat.com> 3.3.3r2-20
205- TightVNC 1.2.1, which incorporates several patches we had.
206
207* Mon Sep  3 2001 Tim Waugh <twaugh@redhat.com> 3.3.3r2-19
208- Use xinit's Xclients script to start the session (bug #52711).
209- Make vncpasswd create ~/.vnc if it doesn't exist (bug #52547).
210- Mention the eight character password limit in vncpasswd.1.
211
212* Tue Jul 24 2001 Tim Waugh <twaugh@redhat.com> 3.3.3r2-18
213- Build requires zlib-devel, libjpeg-devel (bug #49731).
214
215* Fri Jul 13 2001 Tim Waugh <twaugh@redhat.com> 3.3.3r2-17
216- Rebuild to fix file ownership problems.
217
218* Tue Jun  5 2001 Tim Waugh <twaugh@redhat.com> 3.3.3r2-16
219- Really fix bug #28318.
220- Use tcp_wrappers (bug #41052).
221- Fix build error when using XFree86 4.1.0's imakefile config.
222
223* Fri May  4 2001 Tim Waugh <twaugh@redhat.com> 3.3.3r2-15
224- Add tight encoding patch (includes corre and typo patches).
225- Const's Java viewer with tight encoding.
226- Update man pages.
227- Use the font server (bug #35913).
228
229* Mon Feb 19 2001 Tim Waugh <twaugh@redhat.com> 3.3.3r2-14
230- Make initscript change to user's home directory before starting
231  vncserver (bug #28318).
232- Make initscript stop properly.
233
234* Thu Feb  8 2001 Tim Waugh <twaugh@redhat.com>
235- Change initscript usage string.
236- Resync descriptions and summaries to match those from specspo.
237
238* Tue Jan 23 2001 Tim Waugh <twaugh@redhat.com>
239- Redo initscript internationalisation.
240- Initscript uses bash not sh.
241
242* Fri Jan 19 2001 Tim Waugh <twaugh@redhat.com>
243- Xvnc man page: put a pointer to tunnelling through ssh.
244
245* Thu Jan 18 2001 Tim Waugh <twaugh@redhat.com>
246- Warn about VNC being insecure in /etc/sysconfig/vncservers.
247- CoRRE fix from Const Kaplinsky (bug #24285).
248
249* Mon Jan 15 2001 Tim Waugh <twaugh@redhat.com>
250- Initscript internationalisation.
251
252* Tue Dec 12 2000 Tim Waugh <twaugh@redhat.com>
253- Service is off by default (bug #22076).
254- Don't start VNC server in initscript if user has not set passwd yet
255  (bug #22076).
256
257* Thu Dec 07 2000 Tim Waugh <twaugh@redhat.com>
258- Mark vncviewer.desktop noreplace.
259- Mark vncservers and /etc/rc.d/init.d/vncserver config.
260- Add reload to vncserver initscript.
261- chkconfig in post.
262
263* Fri Dec 01 2000 Tim Waugh <twaugh@redhat.com>
264- Rebuilt because of fileutils bug.
265
266* Mon Nov 06 2000 Tim Waugh <twaugh@redhat.com>
267- Include vncpasswd man page in manifest.
268
269* Mon Nov 06 2000 Tim Waugh <twaugh@redhat.com>
270- Add vncviewer.desktop.
271- Correct typo in vncconnect.c.
272- Add man pages.
273
274* Mon Oct 30 2000 Tim Waugh <twaugh@redhat.com>
275- set XAUTHORITY before running xstartup.  Fixes vncserver in ssh
276  sessions.
277- revamp initscript so that it allows for non-root users.
278
279* Thu Oct 26 2000 Tim Waugh <twaugh@redhat.com>
280- update to 3.3.3r2.  Patch from bug #19146 no longer needed.
281- include new vncconnect program in file list
282
283* Thu Oct 26 2000 Tim Waugh <twaugh@redhat.com>
284- fix initscript (bug #19698)
285
286* Tue Oct 17 2000 Than Ngo <than@redhat.com>
287- fixed VNC crashes, patch from Shinji Hattori (Bug #10528)
288
289* Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
290- Fix authentication, Bug #19146, Patch from Tim Waugh <twaugh@redhat.com>
291
292* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
293- Remove ,v file from vnc-doc, Bug #12443
294
295* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
296- move initscript back
297
298* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
299- automatic rebuild
300
301* Mon Jul 10 2000 Preston Brown <pbrown@redhat.com>
302- move initscript
303
304* Thu Jun 15 2000 Preston Brown <pbrown@redhat.com>
305- move post/postun scripts from main package to server subpackage
306
307* Mon Jun 12 2000 Preston Brown <pbrown@redhat.com>
308- preun and postun sections
309
310* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
311- initial package, from Sean P. Kane package and Mandrake package
312- rewrote init script, added condrestart mode
313