1Name:           qt5-kdsoap
2Version:        1.9.0
3Release:        1
4Summary:        A Qt5-based client-side and server-side SOAP component
5Source0:        %{name}-%{version}.tar.gz
6Source1:        %{name}-%{version}.tar.gz.asc
7Url:            https://github.com/KDAB/KDSoap
8Group:          System/Libraries
9License:        GPL-2.0+
10BuildRoot:      %{_tmppath}/%{name}-%{version}-build
11Vendor:         Klaralvdalens Datakonsult AB (KDAB)
12Packager:       Klaralvdalens Datakonsult AB (KDAB) <info@kdab.com>
13
14BuildRequires: cmake
15%if %{defined suse_version}
16BuildRequires:  libqt5-qtbase-devel
17%endif
18
19%if %{defined fedora}
20BuildRequires:  gcc-c++ qt5-qtbase-devel desktop-file-utils
21%endif
22
23%if %{defined rhel}
24BuildRequires:  gcc-c++ qt5-qtbase-devel desktop-file-utils
25%endif
26
27%description
28KDSoap can be used to create client applications for web services
29and also provides the means to create web services without the need
30for any further component such as a dedicated web server.
31
32Authors:
33--------
34      Klaralvdalens Datakonsult AB (KDAB) <info@kdab.com>
35
36%define debug_package %{nil}
37%global __debug_install_post %{nil}
38
39%package devel
40Summary:        Development files for %{name}
41Group:          Development/Libraries/C and C++
42Requires:       %{name} = %{version}
43
44%description devel
45This package contains header files and associated tools and libraries to
46develop programs which need to access web services using the SOAP protocol.
47
48%prep
49%autosetup
50
51%build
52touch .license.accepted
53cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_SKIP_RPATH=True -DCMAKE_BUILD_TYPE=Release
54%__make %{?_smp_mflags}
55
56%post -p /sbin/ldconfig
57%postun -p /sbin/ldconfig
58
59%install
60%make_install
61
62%clean
63%__rm -rf "%{buildroot}"
64
65%files
66%defattr(-,root,root)
67%{_prefix}/share/doc/KDSoap
68%{_libdir}/libkdsoap.so.*
69%{_libdir}/libkdsoap-server.so.*
70
71%files devel
72%defattr(-,root,root)
73%{_bindir}/kdwsdl2cpp
74%{_prefix}/share/mkspecs
75%{_includedir}/KDSoapClient
76%{_includedir}/KDSoapServer
77%dir %{_libdir}/cmake/KDSoap
78%{_libdir}/cmake/KDSoap/*
79%{_libdir}/libkdsoap.so
80%{_libdir}/libkdsoap-server.so
81
82%changelog
83* Mon Feb 17 2020 Allen Winter <allen.winter@kdab.com> 1.9.0
84  1.9.0
85* Fri May 17 2019 Allen Winter <allen.winter@kdab.com> 1.8.0-1
86  1.8.0
87* Thu Mar 01 2018 Allen Winter <allen.winter@kdab.com> 1.7.0
88  1.7.0
89* Mon May 01 2017 Allen Winter <allen.winter@kdab.com> 1.6.0
90  1.6.0
91* Tue Jun 07 2016 Allen Winter <allen.winter@kdab.com> 1.5.1
92  1.5.1 bug fix
93* Mon Feb 29 2016 Allen Winter <allen.winter@kdab.com> 1.4.99
94  1.5.0 RC1
95* Thu Jun 25 2015 Allen Winter <allen.winter@kdab.com> 1.4.0
96  1.4.0 with the autogen buildsystem
97* Sun Aug 24 2014 Allen Winter <allen.winter@kdab.com> 1.4.0
98  1.4.0 Final
99* Tue Aug 12 2014 Allen Winter <allen.winter@kdab.com> 1.3.98
100  1.4.0 RC1
101* Thu Aug 07 2014 Allen Winter <allen.winter@kdab.com> 1.3.1
102  1.3.1 final
103* Mon Aug 04 2014 Allen Winter <allen.winter@kdab.com> 1.3.0
104  1.3.0 final
105