1Summary: public domain Berkeley LALR Yacc parser generator
2
3%global AppVersion 2.0
4%global AppPatched 20230201
5
6%global UseProgram yacc
7
8# $Id: mingw-byacc.spec,v 1.47 2023/02/02 00:12:06 tom Exp $
9Name: byacc
10Version: %{AppVersion}.%{AppPatched}
11Release: 1
12License: Public Domain, MIT
13URL: https://invisible-island.net/%{name}/
14Source0: https://invisible-mirror.net/archives/%{name}/%{name}-%{AppPatched}.tgz
15
16%description
17This package provides a parser generator utility that reads a grammar
18specification from a file and generates an LR(1) parser for it.  The
19parsers consist of a set of LALR(1) parsing tables and a driver
20routine written in the C programming language.  It has a public domain
21license which includes the generated C.
22
23%prep
24
25%global debug_package %{nil}
26
27%setup -q -n %{name}-%{AppPatched}
28
29%build
30%configure --verbose \
31		--program-prefix=b \
32		--target %{_target_platform} \
33		--prefix=%{_prefix} \
34		--bindir=%{_bindir} \
35		--libdir=%{_libdir} \
36		--mandir=%{_mandir}
37
38make
39
40%install
41[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
42
43make install DESTDIR=$RPM_BUILD_ROOT
44( cd $RPM_BUILD_ROOT%{_bindir} && ln -s %{name} %{UseProgram} )
45
46strip $RPM_BUILD_ROOT%{_bindir}/%{name}
47
48%clean
49[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
50
51%files
52%doc ACKNOWLEDGEMENTS CHANGES NEW_FEATURES NOTES NO_WARRANTY README
53%license LICENSE
54%{_bindir}/%{name}
55%{_bindir}/%{UseProgram}
56%{_mandir}/man1/%{name}.*
57
58%changelog
59# each patch should add its ChangeLog entries here
60
61* Sun Jan 09 2022 Thomas Dickey
62- rpmlint
63
64* Sun Jul 09 2017 Thomas Dickey
65- use predefined "configure"
66
67* Wed Sep 25 2013 Thomas Dickey
68- cloned from byacc.spec
69