1%{?!with_python:      %global with_python      1}
2
3%if %{with_python}
4%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6%endif
7
8Summary: Lowlevel DNS(SEC) library with API
9Name: ldns
10Version: 1.6.13
11Release: 1%{?dist}
12License: BSD
13Url: http://www.nlnetlabs.nl/%{name}/
14Source: http://www.nlnetlabs.nl/downloads/%{%name}/%{name}-%{version}.tar.gz
15Group: System Environment/Libraries
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17BuildRequires: perl, libpcap-devel, openssl-devel , gcc-c++, doxygen,
18# Only needed for builds from svn snapshot
19# BuildRequires: libtool, autoconf, automake
20
21%if %{with_python}
22BuildRequires:  python-devel, swig
23%endif
24
25%description
26ldns is a library with the aim to simplify DNS programming in C. All
27lowlevel DNS/DNSSEC operations are supported. We also define a higher
28level API which allows a programmer to (for instance) create or sign
29packets.
30
31%package devel
32Summary: Development package that includes the ldns header files
33Group: Development/Libraries
34Requires: %{name} = %{version}-%{release}
35
36%description devel
37The devel package contains the ldns library and the include files
38
39%if %{with_python}
40%package python
41Summary: Python extensions for ldns
42Group: Applications/System
43Requires: %{name} = %{version}-%{release}
44
45%description python
46Python extensions for ldns
47%endif
48
49%prep
50%setup -q
51# To built svn snapshots
52# rm config.guess config.sub ltmain.sh
53# aclocal
54# libtoolize -c
55# autoreconf
56
57%build
58%configure --disable-rpath --disable-static --with-sha2 --disable-gost \
59%if %{with_python}
60 --with-pyldns
61%endif
62
63(cd drill ; %configure --disable-rpath --disable-static --with-sha2 --disable-gost --with-ldns=%{buildroot}/lib/ )
64(cd examples ; %configure --disable-rpath --disable-static --with-sha2 --disable-gost --with-ldns=%{buildroot}/lib/ )
65
66make %{?_smp_mflags}
67( cd drill ; make %{?_smp_mflags} )
68( cd examples ; make %{?_smp_mflags} )
69make %{?_smp_mflags} doc
70
71%install
72rm -rf %{buildroot}
73
74make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
75make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
76
77# don't install another set of man pages from doc/
78rm -rf doc/man/
79
80# don't package building script for install-doc in doc section
81rm doc/doxyparse.pl
82
83# remove .la files
84rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
85(cd drill ; make DESTDIR=%{buildroot} install)
86(cd examples; make DESTDIR=%{buildroot} install)
87
88%clean
89rm -rf %{buildroot}
90
91%files
92%defattr(-,root,root)
93%{_libdir}/libldns*so.*
94%{_bindir}/drill
95%{_bindir}/ldnsd
96%{_bindir}/ldns-chaos
97%{_bindir}/ldns-compare-zones
98%{_bindir}/ldns-[d-z]*
99%doc README LICENSE
100%{_mandir}/*/*
101
102%files devel
103%defattr(-,root,root,-)
104%{_libdir}/libldns*so
105%{_bindir}/ldns-config
106%dir %{_includedir}/ldns
107%{_includedir}/ldns/*.h
108%doc doc Changelog README
109
110%if %{with_python}
111%files python
112%defattr(-,root,root)
113%{python_sitearch}/*
114%endif
115
116%post -p /sbin/ldconfig
117
118%postun -p /sbin/ldconfig
119
120%changelog
121* Thu Sep 22 2011 Paul Wouters <paul@xelerance.com> - 1.6.11-1
122- Updated to 1.6.11
123- Cleanup spec for
124- Python goes into sitearch, not sitelib
125
126* Wed Jun 08 2011 Paul Wouters <paul@xelerance.com> - 1.6.10-1
127- Updated to 1.6.10
128- commented out build dependencies for svn snapshots
129
130* Sun Mar 27 2011 Paul Wouters <paul@xelerance.com> - 1.6.9-1
131- Updated to 1.6.9
132
133* Mon Jan 24 2011 Paul Wouters <paul@xelerance.com> - 1.6.8-1
134- Updated to 1.6.8
135
136* Thu Aug 26 2010 Paul Wouters <paul@xelerance.com> - 1.6.6-1
137- Upgraded to 1.6.6
138
139* Mon Apr 26 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-4
140- Disable a debug line that was added to find the LOC issue that causes
141  unexpected output for automated tools using ldns-read-zone
142
143* Thu Feb 11 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-3
144- Applied fix svn 3186 for LOC record parsing
145
146* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
147- libtool on EL-5 does not take --install as argument
148
149* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
150- Upgraded to 1.6.4
151- Added ldns-python sub package
152- Patch for installing ldns-python files
153- Patch for rpath in ldns-python
154
155* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
156- Bump version, sources file was not updated.
157
158* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
159-Updated to 1.6.1
160
161* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
162- Updated to 1.6.0
163
164* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-2
165- Memory management bug when generating a sha256 key, see:
166  https://bugzilla.redhat.com/show_bug.cgi?id=493953
167
168* Fri Feb 13 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
169- Upgrade to 1.5.1 (1.5.0 was a dud release)
170
171* Sun Nov  9 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-2
172- libldns.so was missing in files section.
173
174* Sun Nov  9 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
175- Updated to 1.4.0
176- enable SHA2 functionality
177
178* Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
179- Updated to latest release
180
181* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
182- Upgraded to 1.2.2.
183
184* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
185- Commented out 1.1.0 make targets, put make 1.0.1 targets.
186
187* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
188- Fixed changelog typo in date
189- Rebuild requested for PT_GNU_HASH support from gcc
190- Did not upgrade to 1.1.0 due to compile issues on x86_64
191
192* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
193- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
194
195* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
196- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
197
198* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
199- Patched 'make clean' target to get rid of object files shipped with 1.0.0
200
201* Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
202- added a make clean for 2.3.3 since .o files were left behind upstream,
203  causing failure on ppc platform
204
205* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
206- minor cleanups
207
208* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
209- reworked for svn version
210
211* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
212- Initial version
213