1%global ver 8.7p1
2%global rel 1%{?dist}
3
4# OpenSSH privilege separation requires a user & group ID
5%global sshd_uid    74
6%global sshd_gid    74
7
8# Version of ssh-askpass
9%global aversion 1.2.4.1
10
11# Do we want to disable building of x11-askpass? (1=yes 0=no)
12%global no_x11_askpass 0
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%global no_gnome_askpass 0
16
17# Do we want to link against a static libcrypto? (1=yes 0=no)
18%global static_libcrypto 0
19
20# Do we want smartcard support (1=yes 0=no)
21%global scard 0
22
23# Use GTK2 instead of GNOME in gnome-ssh-askpass
24%global gtk2 1
25
26# Use build6x options for older RHEL builds
27# RHEL 7 not yet supported
28%if 0%{?rhel} > 6
29%global build6x 0
30%else
31%global build6x 1
32%endif
33
34%if 0%{?fedora} >= 26
35%global compat_openssl 1
36%else
37%global compat_openssl 0
38%endif
39
40# Do we want kerberos5 support (1=yes 0=no)
41%global kerberos5 1
42
43# Reserve options to override askpass settings with:
44# rpm -ba|--rebuild --define 'skip_xxx 1'
45%{?skip_x11_askpass:%global no_x11_askpass 1}
46%{?skip_gnome_askpass:%global no_gnome_askpass 1}
47
48# Add option to build without GTK2 for older platforms with only GTK+.
49# RedHat <= 7.2 and Red Hat Advanced Server 2.1 are examples.
50# rpm -ba|--rebuild --define 'no_gtk2 1'
51%{?no_gtk2:%global gtk2 0}
52
53# Is this a build for RHL 6.x or earlier?
54%{?build_6x:%global build6x 1}
55
56# If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
57%if %{build6x}
58%global _sysconfdir /etc
59%endif
60
61# Options for static OpenSSL link:
62# rpm -ba|--rebuild --define "static_openssl 1"
63%{?static_openssl:%global static_libcrypto 1}
64
65# Options for Smartcard support: (needs libsectok and openssl-engine)
66# rpm -ba|--rebuild --define "smartcard 1"
67%{?smartcard:%global scard 1}
68
69# Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
70%global rescue 0
71%{?build_rescue:%global rescue 1}
72
73# Turn off some stuff for resuce builds
74%if %{rescue}
75%global kerberos5 0
76%endif
77
78Summary: The OpenSSH implementation of SSH protocol version 2.
79Name: openssh
80Version: %{ver}
81%if %{rescue}
82Release: %{rel}rescue
83%else
84Release: %{rel}
85%endif
86URL: https://www.openssh.com/portable.html
87Source0: https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
88Source1: http://www.jmknoble.net/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
89License: BSD
90Group: Applications/Internet
91BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
92Obsoletes: ssh
93%if %{build6x}
94PreReq: initscripts >= 5.00
95%else
96Requires: initscripts >= 5.20
97%endif
98BuildRequires: perl
99%if %{compat_openssl}
100BuildRequires: compat-openssl10-devel
101%else
102BuildRequires: openssl-devel >= 1.0.1
103BuildRequires: openssl-devel < 1.1
104%endif
105BuildRequires: /bin/login
106%if ! %{build6x}
107BuildRequires: glibc-devel, pam
108%else
109BuildRequires: /usr/include/security/pam_appl.h
110%endif
111%if ! %{no_x11_askpass}
112BuildRequires: /usr/include/X11/Xlib.h
113# Xt development tools
114BuildRequires: libXt-devel
115# Provides xmkmf
116BuildRequires: imake
117# Rely on relatively recent gtk
118BuildRequires: gtk2-devel
119%endif
120%if ! %{no_gnome_askpass}
121BuildRequires: pkgconfig
122%endif
123%if %{kerberos5}
124BuildRequires: krb5-devel
125BuildRequires: krb5-libs
126%endif
127
128%package clients
129Summary: OpenSSH clients.
130Requires: openssh = %{version}-%{release}
131Group: Applications/Internet
132Obsoletes: ssh-clients
133
134%package server
135Summary: The OpenSSH server daemon.
136Group: System Environment/Daemons
137Obsoletes: ssh-server
138Requires: openssh = %{version}-%{release}, chkconfig >= 0.9
139%if ! %{build6x}
140Requires: /etc/pam.d/system-auth
141%endif
142
143%package askpass
144Summary: A passphrase dialog for OpenSSH and X.
145Group: Applications/Internet
146Requires: openssh = %{version}-%{release}
147Obsoletes: ssh-extras
148
149%package askpass-gnome
150Summary: A passphrase dialog for OpenSSH, X, and GNOME.
151Group: Applications/Internet
152Requires: openssh = %{version}-%{release}
153Obsoletes: ssh-extras
154
155%description
156SSH (Secure SHell) is a program for logging into and executing
157commands on a remote machine. SSH is intended to replace rlogin and
158rsh, and to provide secure encrypted communications between two
159untrusted hosts over an insecure network. X11 connections and
160arbitrary TCP/IP ports can also be forwarded over the secure channel.
161
162OpenSSH is OpenBSD's version of the last free version of SSH, bringing
163it up to date in terms of security and features, as well as removing
164all patented algorithms to separate libraries.
165
166This package includes the core files necessary for both the OpenSSH
167client and server. To make this package useful, you should also
168install openssh-clients, openssh-server, or both.
169
170%description clients
171OpenSSH is a free version of SSH (Secure SHell), a program for logging
172into and executing commands on a remote machine. This package includes
173the clients necessary to make encrypted connections to SSH servers.
174You'll also need to install the openssh package on OpenSSH clients.
175
176%description server
177OpenSSH is a free version of SSH (Secure SHell), a program for logging
178into and executing commands on a remote machine. This package contains
179the secure shell daemon (sshd). The sshd daemon allows SSH clients to
180securely connect to your SSH server. You also need to have the openssh
181package installed.
182
183%description askpass
184OpenSSH is a free version of SSH (Secure SHell), a program for logging
185into and executing commands on a remote machine. This package contains
186an X11 passphrase dialog for OpenSSH.
187
188%description askpass-gnome
189OpenSSH is a free version of SSH (Secure SHell), a program for logging
190into and executing commands on a remote machine. This package contains
191an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
192environment.
193
194%prep
195
196%if ! %{no_x11_askpass}
197%setup -q -a 1
198%else
199%setup -q
200%endif
201
202%build
203%if %{rescue}
204CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
205%endif
206
207%configure \
208	--sysconfdir=%{_sysconfdir}/ssh \
209	--libexecdir=%{_libexecdir}/openssh \
210	--datadir=%{_datadir}/openssh \
211	--with-default-path=/usr/local/bin:/bin:/usr/bin \
212	--with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
213	--with-privsep-path=%{_var}/empty/sshd \
214	--with-md5-passwords \
215	--mandir=%{_mandir} \
216	--with-mantype=man \
217	--disable-strip \
218%if %{scard}
219	--with-smartcard \
220%endif
221%if %{rescue}
222	--without-pam \
223%else
224	--with-pam \
225%endif
226%if %{kerberos5}
227	 --with-kerberos5=$K5DIR \
228%endif
229
230
231%if %{static_libcrypto}
232perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
233%endif
234
235make
236
237%if ! %{no_x11_askpass}
238pushd x11-ssh-askpass-%{aversion}
239%configure --libexecdir=%{_libexecdir}/openssh
240xmkmf -a
241make
242popd
243%endif
244
245# Define a variable to toggle gnome1/gtk2 building.  This is necessary
246# because RPM doesn't handle nested %if statements.
247%if %{gtk2}
248	gtk2=yes
249%else
250	gtk2=no
251%endif
252
253%if ! %{no_gnome_askpass}
254pushd contrib
255if [ $gtk2 = yes ] ; then
256	make gnome-ssh-askpass2
257	mv gnome-ssh-askpass2 gnome-ssh-askpass
258else
259	make gnome-ssh-askpass1
260	mv gnome-ssh-askpass1 gnome-ssh-askpass
261fi
262popd
263%endif
264
265%install
266rm -rf $RPM_BUILD_ROOT
267mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
268mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
269mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
270
271make install DESTDIR=$RPM_BUILD_ROOT
272
273install -d $RPM_BUILD_ROOT/etc/pam.d/
274install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
275install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
276%if %{build6x}
277install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
278%else
279install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
280%endif
281install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
282
283%if ! %{no_x11_askpass}
284install x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
285ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
286%endif
287
288%if ! %{no_gnome_askpass}
289install contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
290%endif
291
292%if ! %{scard}
293	 rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
294%endif
295
296%if ! %{no_gnome_askpass}
297install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
298install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
299install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
300%endif
301
302perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
303
304%clean
305rm -rf $RPM_BUILD_ROOT
306
307%triggerun server -- ssh-server
308if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
309	touch /var/run/sshd.restart
310fi
311
312%triggerun server -- openssh-server < 2.5.0p1
313# Count the number of HostKey and HostDsaKey statements we have.
314gawk	'BEGIN {IGNORECASE=1}
315	 /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
316	 END {exit sawhostkey}' /etc/ssh/sshd_config
317# And if we only found one, we know the client was relying on the old default
318# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
319# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
320# one nullifies the default, which would have loaded both.
321if [ $? -eq 1 ] ; then
322	echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
323	echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
324fi
325
326%triggerpostun server -- ssh-server
327if [ "$1" != 0 ] ; then
328	/sbin/chkconfig --add sshd
329	if test -f /var/run/sshd.restart ; then
330		rm -f /var/run/sshd.restart
331		/sbin/service sshd start > /dev/null 2>&1 || :
332	fi
333fi
334
335%pre server
336%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
337%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
338	-g sshd -M -r sshd 2>/dev/null || :
339
340%post server
341/sbin/chkconfig --add sshd
342
343%postun server
344/sbin/service sshd condrestart > /dev/null 2>&1 || :
345
346%preun server
347if [ "$1" = 0 ]
348then
349	/sbin/service sshd stop > /dev/null 2>&1 || :
350	/sbin/chkconfig --del sshd
351fi
352
353%files
354%defattr(-,root,root)
355%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* PROTOCOL* TODO
356%attr(0755,root,root) %{_bindir}/scp
357%attr(0644,root,root) %{_mandir}/man1/scp.1*
358%attr(0755,root,root) %dir %{_sysconfdir}/ssh
359%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
360%if ! %{rescue}
361%attr(0755,root,root) %{_bindir}/ssh-keygen
362%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
363%attr(0755,root,root) %dir %{_libexecdir}/openssh
364%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
365%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
366%attr(0755,root,root) %{_libexecdir}/openssh/ssh-sk-helper
367%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
368%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
369%attr(0644,root,root) %{_mandir}/man8/ssh-sk-helper.8*
370%endif
371%if %{scard}
372%attr(0755,root,root) %dir %{_datadir}/openssh
373%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
374%endif
375
376%files clients
377%defattr(-,root,root)
378%attr(0755,root,root) %{_bindir}/ssh
379%attr(0644,root,root) %{_mandir}/man1/ssh.1*
380%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
381%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
382%if ! %{rescue}
383%attr(2755,root,nobody) %{_bindir}/ssh-agent
384%attr(0755,root,root) %{_bindir}/ssh-add
385%attr(0755,root,root) %{_bindir}/ssh-keyscan
386%attr(0755,root,root) %{_bindir}/sftp
387%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
388%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
389%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
390%attr(0644,root,root) %{_mandir}/man1/sftp.1*
391%endif
392
393%if ! %{rescue}
394%files server
395%defattr(-,root,root)
396%dir %attr(0111,root,root) %{_var}/empty/sshd
397%attr(0755,root,root) %{_sbindir}/sshd
398%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
399%attr(0644,root,root) %{_mandir}/man8/sshd.8*
400%attr(0644,root,root) %{_mandir}/man5/moduli.5*
401%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
402%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
403%attr(0755,root,root) %dir %{_sysconfdir}/ssh
404%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
405%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
406%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
407%endif
408
409%if ! %{no_x11_askpass}
410%files askpass
411%defattr(-,root,root)
412%doc x11-ssh-askpass-%{aversion}/README
413%doc x11-ssh-askpass-%{aversion}/ChangeLog
414%doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
415%{_libexecdir}/openssh/ssh-askpass
416%attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
417%endif
418
419%if ! %{no_gnome_askpass}
420%files askpass-gnome
421%defattr(-,root,root)
422%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
423%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
424%endif
425
426%changelog
427* Mon Jul 20 2020 Damien Miller <djm@mindrto.org>
428- Add ssh-sk-helper and corresponding manual page.
429
430* Sat Feb 10 2018 Darren Tucker <dtucker@dtucker.net>
431- Update openssl-devel dependency to match current requirements.
432- Handle Fedora >=6 openssl 1.0 compat libs.
433- Remove SSH1 from description.
434- Don't strip binaries at build time so that debuginfo package can be
435  created.
436
437* Sun Nov 16 2014 Nico Kadel-Garcia <nakdel@gmail.com>
438- Add '--mandir' and '--with-mantype' for RHEL 5 compatibility
439- Add 'dist' option to 'ver' so package names reflect OS at build time
440- Always include x11-ssh-askpass tarball in SRPM
441- Add openssh-x11-aspass BuildRequires for libXT-devel, imake, gtk2-devel
442- Discard 'K5DIR' reporting, not usable inside 'mock' for RHEL 5 compatibility
443- Discard obsolete '--with-rsh' configure option
444- Update openssl-devel dependency to 0.9.8f, as found in autoconf
445
446* Wed Jul 14 2010 Tim Rice <tim@multitalents.net>
447- test for skip_x11_askpass (line 77) should have been for no_x11_askpass
448
449* Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
450- Remove noip6 option. This may be controlled at run-time in client config
451  file using new AddressFamily directive
452
453* Mon May 12 2003 Damien Miller <djm@mindrot.org>
454- Don't install profile.d scripts when not building with GNOME/GTK askpass
455  (patch from bet@rahul.net)
456
457* Tue Oct 01 2002 Damien Miller <djm@mindrot.org>
458- Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
459
460* Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
461- Use contrib/ Makefile for building askpass programs
462
463* Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
464- Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
465- Add new {ssh,sshd}_config.5 manpages
466- Add new ssh-keysign program and remove setuid from ssh client
467
468* Fri May 10 2002 Damien Miller <djm@mindrot.org>
469- Merge in spec changes from RedHat, reorgansie a little
470- Add Privsep user, group and directory
471
472* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
473- bump and grind (through the build system)
474
475* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
476- require sharutils for building (mindrot #137)
477- require db1-devel only when building for 6.x (#55105), which probably won't
478  work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
479- require pam-devel by file (not by package name) again
480- add Markus's patch to compile with OpenSSL 0.9.5a (from
481  http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
482  building for 6.x
483
484* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
485- update to 3.1p1
486
487* Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
488- update to SNAP-20020305
489- drop debug patch, fixed upstream
490
491* Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
492- update to SNAP-20020220 for testing purposes (you've been warned, if there's
493  anything to be warned about, gss patches won't apply, I don't mind)
494
495* Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
496- add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
497  exchange, authentication, and named key support
498
499* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
500- remove dependency on db1-devel, which has just been swallowed up whole
501  by gnome-libs-devel
502
503* Sat Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
504- adjust build dependencies so that build6x actually works right (fix
505  from Hugo van der Kooij)
506
507* Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
508- update to 3.0.2p1
509
510* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
511- update to 3.0.1p1
512
513* Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
514- update to current CVS (not for use in distribution)
515
516* Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
517- merge some of Damien Miller <djm@mindrot.org> changes from the upstream
518  3.0p1 spec file and init script
519
520* Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
521- update to 3.0p1
522- update to x11-ssh-askpass 1.2.4.1
523- change build dependency on a file from pam-devel to the pam-devel package
524- replace primes with moduli
525
526* Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
527- incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
528
529* Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
530- Merge changes to rescue build from current sysadmin survival cd
531
532* Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
533- fix scp's server's reporting of file sizes, and build with the proper
534  preprocessor define to get large-file capable open(), stat(), etc.
535  (sftp has been doing this correctly all along) (#51827)
536- configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
537- pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
538- mark profile.d scriptlets as config files (#42337)
539- refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
540- change a couple of log() statements to debug() statements (#50751)
541- pull cvs patch to add -t flag to sshd (#28611)
542- clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
543
544* Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
545- add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
546
547* Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
548- pull cvs patch to fix remote port forwarding with protocol 2
549
550* Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
551- pull cvs patch to add session initialization to no-pty sessions
552- pull cvs patch to not cut off challengeresponse auth needlessly
553- refuse to do X11 forwarding if xauth isn't there, handy if you enable
554  it by default on a system that doesn't have X installed (#49263)
555
556* Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
557- don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
558
559* Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
560- pass OPTIONS correctly to initlog (#50151)
561
562* Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
563- switch to x11-ssh-askpass 1.2.2
564
565* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
566- rebuild in new environment
567
568* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
569- disable the gssapi patch
570
571* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
572- update to 2.9p2
573- refresh to a new version of the gssapi patch
574
575* Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
576- change Copyright: BSD to License: BSD
577- add Markus Friedl's unverified patch for the cookie file deletion problem
578  so that we can verify it
579- drop patch to check if xauth is present (was folded into cookie patch)
580- don't apply gssapi patches for the errata candidate
581- clear supplemental groups list at startup
582
583* Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
584- fix an error parsing the new default sshd_config
585- add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
586  dealing with comments right
587
588* Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
589- add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
590  to be removed before the next beta cycle because it's a big departure
591  from the upstream version
592
593* Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
594- finish marking strings in the init script for translation
595- modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
596  at startup (change merged from openssh.com init script, originally by
597  Pekka Savola)
598- refuse to do X11 forwarding if xauth isn't there, handy if you enable
599  it by default on a system that doesn't have X installed
600
601* Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
602- update to 2.9
603- drop various patches that came from or went upstream or to or from CVS
604
605* Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
606- only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
607
608* Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
609- remove explicit openssl requirement, fixes builddistro issue
610- make initscript stop() function wait until sshd really dead to avoid
611  races in condrestart
612
613* Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
614- mention that challengereponse supports PAM, so disabling password doesn't
615  limit users to pubkey and rsa auth (#34378)
616- bypass the daemon() function in the init script and call initlog directly,
617  because daemon() won't start a daemon it detects is already running (like
618  open connections)
619- require the version of openssl we had when we were built
620
621* Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
622- make do_pam_setcred() smart enough to know when to establish creds and
623  when to reinitialize them
624- add in a couple of other fixes from Damien for inclusion in the errata
625
626* Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
627- update to 2.5.2p2
628- call setcred() again after initgroups, because the "creds" could actually
629  be group memberships
630
631* Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
632- update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
633- don't enable challenge-response by default until we find a way to not
634  have too many userauth requests (we may make up to six pubkey and up to
635  three password attempts as it is)
636- remove build dependency on rsh to match openssh.com's packages more closely
637
638* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
639- remove dependency on openssl -- would need to be too precise
640
641* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
642- rebuild in new environment
643
644* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
645- Revert the patch to move pam_open_session.
646- Init script and spec file changes from Pekka Savola. (#28750)
647- Patch sftp to recognize '-o protocol' arguments. (#29540)
648
649* Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
650- Chuck the closing patch.
651- Add a trigger to add host keys for protocol 2 to the config file, now that
652  configuration file syntax requires us to specify it with HostKey if we
653  specify any other HostKey values, which we do.
654
655* Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
656- Redo patch to move pam_open_session after the server setuid()s to the user.
657- Rework the nopam patch to use be picked up by autoconf.
658
659* Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
660- Update for 2.5.1p1.
661- Add init script mods from Pekka Savola.
662- Tweak the init script to match the CVS contrib script more closely.
663- Redo patch to ssh-add to try to adding both identity and id_dsa to also try
664  adding id_rsa.
665
666* Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
667- Update for 2.5.0p1.
668- Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
669- Resync with parts of Damien Miller's openssh.spec from CVS, including
670  update of x11 askpass to 1.2.0.
671- Only require openssl (don't prereq) because we generate keys in the init
672  script now.
673
674* Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
675- Don't open a PAM session until we've forked and become the user (#25690).
676- Apply Andrew Bartlett's patch for letting pam_authenticate() know which
677  host the user is attempting a login from.
678- Resync with parts of Damien Miller's openssh.spec from CVS.
679- Don't expose KbdInt responses in debug messages (from CVS).
680- Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
681
682* Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
683- i18n-tweak to initscript.
684
685* Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
686- More gettextizing.
687- Close all files after going into daemon mode (needs more testing).
688- Extract patch from CVS to handle auth banners (in the client).
689- Extract patch from CVS to handle compat weirdness.
690
691* Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
692- Finish with the gettextizing.
693
694* Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
695- Fix a bug in auth2-pam.c (#23877)
696- Gettextize the init script.
697
698* Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
699- Incorporate a switch for using PAM configs for 6.x, just in case.
700
701* Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
702- Incorporate Bero's changes for a build specifically for rescue CDs.
703
704* Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
705- Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
706  succeeded, to allow public-key authentication after a failure with "none"
707  authentication.  (#21268)
708
709* Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
710- Update to x11-askpass 1.1.1. (#21301)
711- Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
712
713* Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
714- Merge multiple PAM text messages into subsequent prompts when possible when
715  doing keyboard-interactive authentication.
716
717* Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
718- Disable the built-in MD5 password support.  We're using PAM.
719- Take a crack at doing keyboard-interactive authentication with PAM, and
720  enable use of it in the default client configuration so that the client
721  will try it when the server disallows password authentication.
722- Build with debugging flags.  Build root policies strip all binaries anyway.
723
724* Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
725- Use DESTDIR instead of %%makeinstall.
726- Remove /usr/X11R6/bin from the path-fixing patch.
727
728* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
729- Add the primes file from the latest snapshot to the main package (#20884).
730- Add the dev package to the prereq list (#19984).
731- Remove the default path and mimic login's behavior in the server itself.
732
733* Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
734- Resync with conditional options in Damien Miller's .spec file for an errata.
735- Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
736
737* Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
738- Update to OpenSSH 2.3.0p1.
739- Update to x11-askpass 1.1.0.
740- Enable keyboard-interactive authentication.
741
742* Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
743- Update to ssh-askpass-x11 1.0.3.
744- Change authentication related messages to be private (#19966).
745
746* Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
747- Patch ssh-keygen to be able to list signatures for DSA public key files
748  it generates.
749
750* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
751- Add BuildRequires on /usr/include/security/pam_appl.h to be sure we always
752  build PAM authentication in.
753- Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
754- Clean out no-longer-used patches.
755- Patch ssh-add to try to add both identity and id_dsa, and to error only
756  when neither exists.
757
758* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
759- Update x11-askpass to 1.0.2. (#17835)
760- Add BuildRequiress for /bin/login and /usr/bin/rsh so that configure will
761  always find them in the right place. (#17909)
762- Set the default path to be the same as the one supplied by /bin/login, but
763  add /usr/X11R6/bin. (#17909)
764- Try to handle obsoletion of ssh-server more cleanly.  Package names
765  are different, but init script name isn't. (#17865)
766
767* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
768- Update to 2.2.0p1. (#17835)
769- Tweak the init script to allow proper restarting. (#18023)
770
771* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
772- Update to 20000823 snapshot.
773- Change subpackage requirements from %%{version} to %%{version}-%%{release}
774- Back out the pipe patch.
775
776* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
777- Update to 2.1.1p4, which includes fixes for config file parsing problems.
778- Move the init script back.
779- Add Damien's quick fix for wackiness.
780
781* Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
782- Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
783
784* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
785- Move condrestart to server postun.
786- Move key generation to init script.
787- Actually use the right patch for moving the key generation to the init script.
788- Clean up the init script a bit.
789
790* Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
791- Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
792
793* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
794- Update to 2.1.1p2.
795- Use of strtok() considered harmful.
796
797* Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
798- Get the build root out of the man pages.
799
800* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
801- Add and use condrestart support in the init script.
802- Add newer initscripts as a prereq.
803
804* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
805- Build in new environment (release 2)
806- Move -clients subpackage to Applications/Internet group
807
808* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
809- Update to 2.2.1p1
810
811* Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
812- Patch to build with neither RSA nor RSAref.
813- Miscellaneous FHS-compliance tweaks.
814- Fix for possibly-compressed man pages.
815
816* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
817- Updated for new location
818- Updated for new gnome-ssh-askpass build
819
820* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
821- Added Jim Knoble's <jmknoble@pobox.com> askpass
822
823* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
824- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
825
826* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
827- Added 'Obsoletes' directives
828
829* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
830- Use make install
831- Subpackages
832
833* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
834- Added links for slogin
835- Fixed perms on manpages
836
837* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
838- Renamed init script
839
840* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
841- Back to old binary names
842
843* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
844- Use autoconf
845- New binary names
846
847* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
848- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
849