1 // RUN: %clang_cc1 %s -triple=x86_64-apple-darwin10 -emit-llvm -o - -fcxx-exceptions -fexceptions | FileCheck %s
2 
3 void external();
4 
5 void target() throw(int)
6 {
7   // CHECK: invoke void @_Z8externalv()
8   external();
9 }
10 // CHECK:      landingpad { i8*, i32 } personality i8* bitcast (i32 (...)* @__gxx_personality_v0 to i8*)
11 // CHECK-NEXT:   filter [1 x i8*] [i8* bitcast (i8** @_ZTIi to i8*)]
12 // CHECK:      call void @__cxa_call_unexpected
13