1 // RUN: %clang_cc1 -fsyntax-only -verify -Wc++11-compat %s
2 
3 namespace N {
4   template<class T> class Y { // expected-note{{explicit instantiation refers here}}
5     void mf() { }
6   };
7 }
8 
9 template class Z<int>; // expected-error{{explicit instantiation of non-template class 'Z'}}
10 
11 // FIXME: This example from the standard is wrong; note posted to CWG reflector
12 // on 10/27/2009
13 using N::Y;
14 template class Y<int>; // expected-warning{{must occur in}}
15 
16 template class N::Y<char*>;
17 template void N::Y<double>::mf();
18