xref: /reactos/dll/win32/mpr/mpr.spec (revision 40462c92)
1# ordinal exports
2 1 stub MPR_1
3 2 stub MPR_2
4 3 stub MPR_3
5 4 stub MPR_4
6 5 stub MPR_5
7 6 stub MPR_6
8 7 stub MPR_7
9 8 stub MPR_8
10 9 stub MPR_9
1112 stub MPR_12
1213 stub MPR_13
1314 stub MPR_14
1415 stub MPR_15
1516 stub MPR_16
1617 stub MPR_17
1718 stub MPR_18
1819 stub MPR_19
1920 stub MPR_20
2021 stub MPR_21
2122 stdcall @(long) MPR_Alloc
2223 stdcall @(ptr long) MPR_ReAlloc
2324 stdcall @(ptr) MPR_Free
2425 stdcall @(ptr long) _MPR_25
25
26@ stdcall MultinetGetConnectionPerformanceA(ptr ptr)
27@ stdcall MultinetGetConnectionPerformanceW(ptr ptr)
28@ stdcall MultinetGetErrorTextA(long long long)
29@ stdcall MultinetGetErrorTextW(long long long)
30@ stdcall NPSAuthenticationDialogA(ptr)
31@ stdcall NPSCopyStringA(str ptr ptr)
32@ stdcall NPSDeviceGetNumberA(str ptr ptr)
33@ stdcall NPSDeviceGetStringA(long long ptr ptr)
34@ stdcall NPSGetProviderHandleA(ptr)
35@ stdcall NPSGetProviderNameA(ptr ptr)
36@ stdcall NPSGetSectionNameA(ptr ptr)
37@ stdcall NPSNotifyGetContextA(ptr)
38@ stdcall NPSNotifyRegisterA(long ptr)
39@ stdcall NPSSetCustomTextA(str)
40@ stdcall NPSSetExtendedErrorA(long str)
41@ stdcall PwdChangePasswordA(str ptr long ptr)
42@ stdcall PwdChangePasswordW(wstr ptr long ptr)
43@ stdcall PwdGetPasswordStatusA(str long ptr)
44@ stdcall PwdGetPasswordStatusW(wstr long ptr)
45@ stdcall PwdSetPasswordStatusA(str long long)
46@ stdcall PwdSetPasswordStatusW(wstr long long)
47@ stdcall WNetAddConnection2A(ptr str str long)
48@ stdcall WNetAddConnection2W(ptr wstr wstr long)
49@ stdcall WNetAddConnection3A(long ptr str str long)
50@ stdcall WNetAddConnection3W(long ptr wstr wstr long)
51@ stdcall WNetAddConnectionA(str str str)
52@ stdcall WNetAddConnectionW(wstr wstr wstr)
53@ stdcall WNetCachePassword(str long str long long long)
54@ stdcall WNetCancelConnection2A(str long long)
55@ stdcall WNetCancelConnection2W(wstr long long)
56@ stdcall WNetCancelConnectionA(str long)
57@ stdcall WNetCancelConnectionW(wstr long)
58@ stdcall WNetClearConnections(long)
59@ stdcall WNetCloseEnum(long)
60@ stdcall WNetConnectionDialog1A(ptr)
61@ stdcall WNetConnectionDialog1W(ptr)
62@ stdcall WNetConnectionDialog(long long)
63@ stdcall WNetDisconnectDialog1A(ptr)
64@ stdcall WNetDisconnectDialog1W(ptr)
65@ stdcall WNetDisconnectDialog(long long)
66@ stdcall WNetEnumCachedPasswords(str long long ptr long)
67@ stdcall WNetEnumResourceA(long ptr ptr ptr)
68@ stdcall WNetEnumResourceW(long ptr ptr ptr)
69@ stub WNetFMXEditPerm
70@ stub WNetFMXGetPermCaps
71@ stub WNetFMXGetPermHelp
72@ stub WNetFormatNetworkNameA
73@ stub WNetFormatNetworkNameW
74@ stdcall WNetGetCachedPassword(ptr long ptr ptr long)
75@ stdcall WNetGetConnectionA(str ptr ptr)
76@ stdcall WNetGetConnectionW(wstr ptr ptr)
77@ stub WNetGetDirectoryTypeA
78@ stub WNetGetHomeDirectoryA
79@ stub WNetGetHomeDirectoryW
80@ stdcall WNetGetLastErrorA(ptr ptr long ptr long)
81@ stdcall WNetGetLastErrorW(ptr ptr long ptr long)
82@ stdcall WNetGetNetworkInformationA(str ptr)
83@ stdcall WNetGetNetworkInformationW(wstr ptr)
84@ stub WNetGetPropertyTextA
85@ stdcall WNetGetProviderNameA(long ptr ptr)
86@ stdcall WNetGetProviderNameW(long ptr ptr)
87@ stdcall WNetGetResourceInformationA(ptr ptr ptr ptr)
88@ stdcall WNetGetResourceInformationW(ptr ptr ptr ptr)
89@ stdcall WNetGetResourceParentA(ptr ptr ptr)
90@ stdcall WNetGetResourceParentW(ptr ptr ptr)
91@ stdcall WNetGetUniversalNameA (str long ptr ptr)
92@ stdcall WNetGetUniversalNameW (wstr long ptr ptr)
93@ stdcall WNetGetUserA(str ptr ptr)
94@ stdcall WNetGetUserW(wstr wstr ptr)
95@ stdcall WNetLogoffA(str long)
96@ stdcall WNetLogoffW(wstr long)
97@ stdcall WNetLogonA(str long)
98@ stub WNetLogonNotify
99@ stdcall WNetLogonW(wstr long)
100@ stdcall WNetOpenEnumA(long long long ptr ptr)
101@ stdcall WNetOpenEnumW(long long long ptr ptr)
102@ stub WNetPasswordChangeNotify
103@ stub WNetPropertyDialogA
104@ stdcall WNetRemoveCachedPassword(ptr long long)
105@ stub WNetRestoreConnection
106@ stdcall WNetRestoreConnectionA(long str)
107@ stdcall WNetRestoreConnectionW(long wstr)
108@ stdcall WNetSetConnectionA(str long ptr)
109@ stdcall WNetSetConnectionW(wstr long ptr)
110@ stdcall WNetUseConnectionA(long ptr str str long str ptr ptr)
111@ stdcall WNetUseConnectionW(long ptr wstr wstr long wstr ptr ptr)
112@ stdcall WNetVerifyPasswordA(str ptr)
113@ stdcall WNetVerifyPasswordW(wstr ptr)
114