xref: /reactos/dll/win32/mscoree/mscoree.spec (revision 8a978a17)
117 stub InitErrors
218 stub PostError
319 stub InitSSAutoEnterThread
420 stub UpdateError
522 stdcall LoadStringRC(long ptr long long)
623 stub ReOpenMetaDataWithMemory
7
8@ stub CallFunctionShim
9@ stub CloseCtrs
10@ stdcall CLRCreateInstance(ptr ptr ptr)
11@ stdcall ClrCreateManagedInstance(wstr ptr ptr)
12@ stdcall CoEEShutDownCOM()
13@ stdcall CoInitializeCor(long)
14@ stub CoInitializeEE
15@ stub CoUninitializeCor
16@ stub CoUninitializeEE
17@ stub CollectCtrs
18@ stdcall CorBindToCurrentRuntime(wstr ptr ptr ptr)
19@ stub CorBindToRuntime
20@ stub CorBindToRuntimeByCfg
21@ stub CorBindToRuntimeByPath
22@ stub CorBindToRuntimeByPathEx
23@ stdcall CorBindToRuntimeEx(wstr wstr long ptr ptr ptr)
24@ stdcall CorBindToRuntimeHost(wstr wstr wstr ptr long ptr ptr ptr)
25@ stub CorDllMainWorker
26@ stdcall CorExitProcess(long)
27@ stub CorGetSvc
28@ stub CorIsLatestSvc
29@ stub CorMarkThreadInThreadPool
30@ stub CorTickleSvc
31@ stdcall CreateConfigStream(wstr ptr)
32@ stdcall CreateDebuggingInterfaceFromVersion(long wstr ptr)
33@ stdcall -private DllCanUnloadNow()
34@ stdcall -private DllGetClassObject(ptr ptr ptr)
35@ stdcall -private DllRegisterServer()
36@ stdcall -private DllUnregisterServer()
37@ stub EEDllGetClassObjectFromClass
38@ stub EEDllRegisterServer
39@ stub EEDllUnregisterServer
40@ stdcall GetAssemblyMDImport(ptr ptr ptr)
41@ stub GetCORRequiredVersion
42@ stub GetCORRootDirectory
43@ stdcall GetCORSystemDirectory(ptr long ptr)
44@ stdcall GetCORVersion(ptr long ptr)
45@ stub GetCompileInfo
46@ stdcall GetFileVersion(wstr ptr long ptr)
47@ stub GetHashFromAssemblyFile
48@ stub GetHashFromAssemblyFileW
49@ stub GetHashFromBlob
50@ stub GetHashFromFile
51@ stub GetHashFromFileW
52@ stub GetHashFromHandle
53@ stub GetHostConfigurationFile
54@ stub GetMetaDataInternalInterface
55@ stub GetMetaDataInternalInterfaceFromPublic
56@ stub GetMetaDataPublicInterfaceFromInternal
57@ stub GetPermissionRequests
58@ stub GetPrivateContextsPerfCounters
59@ stub GetProcessExecutableHeap
60@ stdcall GetRealProcAddress(str ptr)
61@ stdcall GetRequestedRuntimeInfo(wstr wstr wstr long long ptr long ptr ptr long ptr)
62@ stdcall GetRequestedRuntimeVersion(wstr ptr long ptr)
63@ stub GetRequestedRuntimeVersionForCLSID
64@ stub GetStartupFlags
65@ stub GetTargetForVTableEntry
66@ stub GetTokenForVTableEntry
67@ stdcall GetVersionFromProcess(ptr ptr long ptr)
68@ stub GetXMLElement
69@ stub GetXMLElementAttribute
70@ stub GetXMLObject
71@ stdcall LoadLibraryShim(ptr ptr ptr ptr)
72@ stub LoadLibraryWithPolicyShim
73@ stdcall LoadStringRCEx(long long ptr long long ptr)
74@ stdcall LockClrVersion(ptr ptr ptr)
75@ stub MetaDataGetDispenser
76@ stdcall ND_CopyObjDst(ptr ptr long long)
77@ stdcall ND_CopyObjSrc(ptr long ptr long)
78@ stdcall ND_RI2(ptr long)
79@ stdcall ND_RI4(ptr long)
80@ stdcall -ret64 ND_RI8(ptr long)
81@ stdcall ND_RU1(ptr long)
82@ stdcall ND_WI2(ptr long long)
83@ stdcall ND_WI4(ptr long long)
84@ stdcall ND_WI8(ptr long double)
85@ stdcall ND_WU1(ptr long long)
86@ stub OpenCtrs
87@ stub ReOpenMetaDataWithMemoryEx
88@ stub RunDll@ShimW
89@ stub RuntimeOSHandle
90@ stub RuntimeOpenImage
91@ stub RuntimeReleaseHandle
92@ stub SetTargetForVTableEntry
93@ stub StrongNameCompareAssemblies
94@ stub StrongNameErrorInfo
95@ stub StrongNameFreeBuffer
96@ stub StrongNameGetBlob
97@ stub StrongNameGetBlobFromImage
98@ stub StrongNameGetPublicKey
99@ stub StrongNameHashSize
100@ stub StrongNameKeyDelete
101@ stub StrongNameKeyGen
102@ stub StrongNameKeyGenEx
103@ stub StrongNameKeyInstall
104@ stub StrongNameSignatureGeneration
105@ stub StrongNameSignatureGenerationEx
106@ stub StrongNameSignatureSize
107@ stdcall StrongNameSignatureVerification(wstr long ptr)
108@ stdcall StrongNameSignatureVerificationEx(wstr long ptr)
109@ stub StrongNameSignatureVerificationFromImage
110@ stub StrongNameTokenFromAssembly
111@ stub StrongNameTokenFromAssemblyEx
112@ stub StrongNameTokenFromPublicKey
113@ stub TranslateSecurityAttributes
114@ stdcall _CorDllMain(long long ptr)
115@ stdcall _CorExeMain2(ptr long ptr ptr ptr)
116@ stdcall _CorExeMain()
117@ stdcall _CorImageUnloading(ptr)
118@ stdcall _CorValidateImage(ptr ptr)
119