1Source: dpkg
2Section: admin
3Priority: required
4Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
5Uploaders: Guillem Jover <guillem@debian.org>
6Homepage: https://wiki.debian.org/Teams/Dpkg
7Vcs-Browser: https://git.dpkg.org/cgit/dpkg/dpkg.git
8Vcs-Git: https://git.dpkg.org/git/dpkg/dpkg.git
9Standards-Version: 4.3.0
10Rules-Requires-Root: no
11Build-Depends:
12 debhelper (>= 11),
13 pkg-config,
14# Needed for ITS support.
15 gettext (>= 0.19.7),
16# Needed for --porefs.
17 po4a (>= 0.43),
18 zlib1g-dev,
19 libbz2-dev,
20 liblzma-dev,
21 libselinux1-dev [linux-any],
22 libncurses-dev (>= 6.1+20180210) | libncursesw5-dev,
23# Needed for the functional test.
24 bzip2 <!nocheck>,
25 xz-utils <!nocheck>,
26
27Package: dpkg
28Architecture: any
29Multi-Arch: foreign
30Essential: yes
31Pre-Depends:
32 ${shlibs:Depends},
33Depends:
34 ${misc:Depends},
35# Needed for --clamp-mtime in dpkg-deb -b.
36 tar (>= 1.28-1),
37Suggests:
38 apt,
39 debsig-verify,
40Breaks:
41# Due to --status-fd not duplicating output.
42 libapt-pkg5.0 (<< 1.7~b),
43# Due to removal of dpkg-divert compat symlink.
44 amule (<< 2.3.1+git1a369e47-3),
45# Due to removal of dpkg-statoverride compat symlink.
46 acidbase (<= 1.4.5-4),
47 beep (<< 1.3-4),
48 im (<< 1:151-4),
49 netselect (<< 0.3.ds1-27),
50 pconsole (<< 1.0-12),
51 phpgacl (<< 3.3.7-7.3),
52 pure-ftpd (<< 1.0.43-1),
53 systemtap (<< 2.8-1),
54 terminatorx (<< 4.0.1-1),
55 xvt (<= 2.1-20.1),
56# Due to renaming of triplettable to tupletable.
57 libdpkg-perl (<< 1.18.11),
58# Due to s-s-d requiring secure usage of --pidfile.
59 lsb-base (<< 10.2019031300),
60Description: Debian package management system
61 This package provides the low-level infrastructure for handling the
62 installation and removal of Debian software packages.
63 .
64 For Debian package development tools, install dpkg-dev.
65
66Package: libdpkg-dev
67Section: libdevel
68Priority: optional
69Architecture: any
70Multi-Arch: same
71Depends:
72 ${misc:Depends},
73 zlib1g-dev,
74 liblzma-dev,
75 libbz2-dev,
76Description: Debian package management static library
77 This package provides the header files and static library necessary to
78 develop software using libdpkg, the same library used internally by dpkg.
79 .
80 Note though, that the API is to be considered volatile, and might change
81 at any time, use at your own risk.
82
83Package: dpkg-dev
84Section: utils
85Priority: optional
86Architecture: all
87Multi-Arch: foreign
88Depends:
89 ${misc:Depends},
90 ${perl:Depends},
91 libdpkg-perl (= ${source:Version}),
92# Needed for --clamp-mtime.
93 tar (>= 1.28-1),
94 bzip2,
95 xz-utils,
96# Needed for git-style diff support.
97 patch (>= 2.7),
98 make,
99 binutils,
100Recommends:
101 build-essential,
102 gcc | c-compiler,
103 fakeroot,
104 gnupg | gnupg2,
105 gpgv | gpgv2,
106# Used by dpkg-mergechangelogs.
107 libalgorithm-merge-perl,
108Suggests:
109 debian-keyring,
110Breaks:
111# Force R³ support, w/o requiring debhelper users to depend on dpkg-dev.
112 debhelper (<< 10.10.1~),
113Description: Debian package development tools
114 This package provides the development tools (including dpkg-source)
115 required to unpack, build and upload Debian source packages.
116 .
117 Most Debian source packages will require additional tools to build;
118 for example, most packages need make and the C compiler gcc.
119
120Package: libdpkg-perl
121Section: perl
122Priority: optional
123Architecture: all
124Multi-Arch: foreign
125Depends:
126 ${misc:Depends},
127 perl:any,
128# Needed for arch tuples.
129 dpkg (>= 1.18.11),
130Recommends:
131# Used by Dpkg::File.
132 libfile-fcntllock-perl,
133# Used by Dpkg::Gettext.
134 liblocale-gettext-perl,
135 bzip2,
136 xz-utils,
137Suggests:
138 debian-keyring,
139 gnupg | gnupg2,
140 gpgv | gpgv2,
141 gcc | c-compiler,
142 binutils,
143 patch,
144# Used (if available) by Dpkg::Source::Package::V2.
145 sensible-utils,
146# Needed by Dpkg::Source::Package::V3::Git
147 git,
148# Needed by Dpkg::Source::Package::V3::Bzr
149 bzr,
150Breaks:
151# Needed for git-style diffs.
152 patch (<< 2.7),
153# Uses the private Dpkg::Shlibs::SymbolFile module with no API stability
154# guarantees! Which obviously broke with 1.19.0.
155 pkg-kde-tools (<< 0.15.28~),
156# Uses Dpkg::Compression::Process imported from Dpkg::Source::Package in
157# versions prior to 1.19.0.
158 dgit (<< 3.13~),
159Description: Dpkg perl modules
160 This package provides the perl modules used by the scripts
161 in dpkg-dev. They cover a wide range of functionality. Among them
162 there are the following public modules:
163 .
164  - Dpkg: core variables
165  - Dpkg::Arch: architecture handling functions
166  - Dpkg::Build::Info: build information functions
167  - Dpkg::BuildFlags: set, modify and query compilation build flags
168  - Dpkg::BuildOptions: parse and manipulate DEB_BUILD_OPTIONS
169  - Dpkg::BuildProfiles: parse and manipulate build profiles
170  - Dpkg::Changelog: parse changelogs
171  - Dpkg::Changelog::Entry: represents a changelog entry
172  - Dpkg::Changelog::Parse: generic changelog parser for dpkg-parsechangelog
173  - Dpkg::Checksums: generate and parse checksums
174  - Dpkg::Compression: simple database of available compression methods
175  - Dpkg::Compression::FileHandle: transparently (de)compress files
176  - Dpkg::Compression::Process: wrapper around compression tools
177  - Dpkg::Conf: parse dpkg configuration files
178  - Dpkg::Control: parse and manipulate Debian control information
179    (.dsc, .changes, Packages/Sources entries, etc.)
180  - Dpkg::Control::Changelog: represent fields output by dpkg-parsechangelog
181  - Dpkg::Control::Fields: manage (list of known) control fields
182  - Dpkg::Control::Hash: parse and manipulate a block of RFC822-like fields
183  - Dpkg::Control::Info: parse files like debian/control
184  - Dpkg::Control::Tests: parse files like debian/tests/control
185  - Dpkg::Control::Tests::Entry: represents a debian/tests/control stanza
186  - Dpkg::Deps: parse and manipulate dependencies
187  - Dpkg::Deps::Simple: represents a single dependency statement
188  - Dpkg::Deps::Multiple: base module to represent multiple dependencies
189  - Dpkg::Deps::Union: list of unrelated dependencies
190  - Dpkg::Deps::AND: list of AND dependencies
191  - Dpkg::Deps::OR: list of OR dependencies
192  - Dpkg::Deps::KnownFacts: list of installed and virtual packages
193  - Dpkg::Exit: push, pop and run exit handlers
194  - Dpkg::Gettext: wrapper around Locale::gettext
195  - Dpkg::IPC: spawn sub-processes and feed/retrieve data
196  - Dpkg::Index: collections of Dpkg::Control (Packages/Sources files for
197    example)
198  - Dpkg::Interface::Storable: base object serializer
199  - Dpkg::Path: common path handling functions
200  - Dpkg::Source::Format: manipulate debian/source/format files
201  - Dpkg::Source::Package: extract Debian source packages
202  - Dpkg::Substvars: substitute variables in strings
203  - Dpkg::Vendor: identify current distribution vendor
204  - Dpkg::Version: parse and manipulate Debian package versions
205 .
206 All the packages listed in Suggests or Recommends are used by some of the
207 modules.
208
209Package: dselect
210Priority: optional
211Architecture: any
212Multi-Arch: foreign
213Depends:
214 ${shlibs:Depends},
215 ${misc:Depends},
216Suggests:
217 perl,
218Description: Debian package management front-end
219 dselect is a high-level interface for managing the installation and
220 removal of Debian software packages.
221 .
222 Many users find dselect intimidating and new users may prefer to use
223 apt-based user interfaces.
224