1%define  ver     0.3.6
2%define  RELEASE 1
3%define  rel     %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE}
4%define  prefix  /usr
5
6Summary: A library to handle various audio file formats.
7Name: audiofile
8Version: %ver
9Release: %rel
10Copyright: LGPL
11Group: Libraries/Sound
12Source: ftp://ftp.gnome.org/pub/GNOME/sources/audiofile/audiofile-%{PACKAGE_VERSION}.tar.gz
13URL: http://www.68k.org/~michael/audiofile/
14BuildRoot:/var/tmp/audiofile-%{PACKAGE_VERSION}-root
15Docdir: %{prefix}/doc
16Obsoletes: libaudiofile
17
18%description
19The Audio File Library provides an elegant API for accessing a variety
20of audio file formats, such as AIFF/AIFF-C, WAVE, and NeXT/Sun
21.snd/.au, in a manner independent of file and data formats.
22
23%package devel
24Summary: Library, headers, etc. to develop with the Audio File Library.
25Group: Libraries
26
27%description devel
28Library, header files, etc. for developing applications with the Audio
29File Library.
30
31%prep
32%setup
33
34%build
35CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix
36make $MAKE_FLAGS
37
38%install
39
40rm -rf $RPM_BUILD_ROOT
41mkdir -p $RPM_BUILD_ROOT
42
43#
44# makefile is broken, sets exec_prefix explicitely.
45#
46make exec_prefix=$RPM_BUILD_ROOT/%{prefix} prefix=$RPM_BUILD_ROOT/%{prefix} install
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%changelog
52
53* Fri Nov 20 1998 Michael Fulbright <drmike@redhat.com>
54- First try at a spec file
55
56%files
57%defattr(-, root, root)
58%doc COPYING TODO README ChangeLog docs
59%{prefix}/bin/*
60%{prefix}/lib/lib*.so.*
61
62%files devel
63%defattr(-, root, root)
64%{prefix}/lib/lib*.so
65%{prefix}/lib/*.a
66%{prefix}/lib/*.la
67%{prefix}/lib/pkgconfig/*.pc
68%{prefix}/include/*
69%{prefix}/share/aclocal/*
70