1%define name mp3info
2%define version 0.8.5a
3%define release 1
4
5Summary: An MP3 technical info viewer and ID3 v1.x tag editor
6Name: %{name}
7Version: %{version}
8Release: %{release}
9Packager: %{packager}
10Vendor: %{vendor}
11License: GPL
12Group: Utilities/file
13Source: ftp://ftp.ibiblio.org/pub/linux/apps/sound/mp3-utils/mp3info/%{name}-%{version}.tgz
14BuildRoot: /tmp/%{name}
15
16%description
17MP3Info is an MP3 technical info viewer and ID3 1.x tag editor.
18MP3Info has an interactive mode (using curses) and a command line mode.
19A separate executable includes a GTK-based GUI version.  MP3Info can
20display ID3 tag information as well as various techincal aspects of
21an MP3 file including playing time, bit-rate, sampling frequency
22and other attributes in a pre-defined or user-specifiable output format.
23
24%prep
25
26%setup -q
27mkdir -p $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}
28mkdir -p $RPM_BUILD_ROOT/usr/bin
29mkdir -p $RPM_BUILD_ROOT/usr/X11R6/bin
30mkdir -p $RPM_BUILD_ROOT/usr/man/man1
31
32%build
33make
34strip mp3info
35strip gmp3info
36
37%install
38mv mp3info $RPM_BUILD_ROOT/usr/bin/mp3info
39mv gmp3info $RPM_BUILD_ROOT/usr/X11R6/bin/gmp3info
40mv ChangeLog README INSTALL LICENSE mp3info.txt mp3info.html $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}
41mv mp3info.1 $RPM_BUILD_ROOT/usr/man/man1
42
43%post
44
45%postun
46
47%clean
48rm -rf ${RPM_BUILD_ROOT}
49
50%files
51%defattr(-,root,root)
52/usr/bin/mp3info
53/usr/X11R6/bin/gmp3info
54/usr/man/man1/mp3info.1.gz
55%doc /usr/share/doc/%{name}-%{version}
56
57%changelog
58* Mon Nov 6 2006 Cedric Tefft <cedric@phreaker.net>
59- Added 'make install-mp3info' and 'make install-gmp3info' options to
60  Makefile (Felix Kronlage)
61- Fixed a bug in the windows version that caused it to blow up or give
62  erroneous output on certain MP3 files
63- Added handling of 'free form' bitrate frames, the lack of which was
64  causing segfaults on AMD 64-bit sytems
65- Tweaked code to eliminate various gcc warnings and errors
66- Improved detection of invalid MP3 frames (Ben Bennett)
67- Updated gmp3info for GTK 2 (Eric Lassauge)
68- Miscellaneous documentation updates and corrections
69
70* Mon Jul 16 2001 Cedric Tefft <cedric@phreaker.net>
71- Added %k format specifier to allow printing of the file size
72  in formatted text output (-p option)
73- Rearranged some items in the man page and quick help (-h)
74  to make them more readable.
75- Fixed minor logic bug in mp3tech
76- Now compiles under CYGWIN32
77- Manual page typos fixed
78- Now correctly recognizes and reports MPEG version 2.5 files
79- Clearing individual ID3 fields can now be accomplished
80  by passing a blank argument ("") to any tag setting
81  switch (-t, -a, etc.)
82