1#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# GNU copyright 1997 to 1999 by Joey Hess.
5
6# Uncomment this to turn on verbose mode.
7#export DH_VERBOSE=1
8
9builddir=$(CURDIR)/debian/mp3lint/
10
11CFLAGS = -Wall -g
12
13ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
14	CFLAGS += -O0
15else
16	CFLAGS += -O2
17endif
18ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
19	INSTALL_PROGRAM += -s
20endif
21
22configure: configure-stamp
23configure-stamp:
24	dh_testdir
25	# Add here commands to configure the package.
26	perl Makefile.PL INSTALLDIRS=vendor
27	touch configure-stamp
28
29
30build: build-stamp
31
32build-stamp: configure-stamp
33	dh_testdir
34
35	# Add here commands to compile the package.
36	$(MAKE) DESTDIR=$(builddir)  INSTALLVENDORMAN1DIR=/usr/share/man/man1 INSTALLVENDORMAN3DIR=/usr/share/man/man3 INSTALLVENDORMAN5DIR=/usr/share/man/man5
37
38	touch build-stamp
39
40clean:
41	dh_testdir
42	dh_testroot
43	rm -f build-stamp configure-stamp
44
45	# Add here commands to clean up after the build process.
46	-$(MAKE) clean
47
48	dh_clean
49
50install: build
51	dh_testdir
52	dh_testroot
53	dh_clean -k
54	dh_installdirs
55
56	# Add here commands to install the package into debian/mp3lint.
57	$(MAKE) pure_install DESTDIR=$(builddir)  INSTALLVENDORMAN1DIR=/usr/share/man/man1 INSTALLVENDORMAN3DIR=/usr/share/man/man3 INSTALLVENDORMAN5DIR=/usr/share/man/man5
58	# get rid of .packlist and associated dirs
59	rm -fr $(builddir)usr/lib
60
61
62# Build architecture-independent files here.
63binary-indep: build install
64# We have nothing to do by default.
65
66# Build architecture-dependent files here.
67binary-arch: build install
68	dh_testdir
69	dh_testroot
70	dh_installchangelogs
71	dh_installdocs README
72#	dh_installexamples
73#	dh_install
74#	dh_installmenu
75#	dh_installdebconf
76#	dh_installlogrotate
77#	dh_installemacsen
78#	dh_installpam
79#	dh_installmime
80#	dh_installinit
81#	dh_installcron
82#	dh_installinfo
83	dh_installman
84	dh_link
85#	dh_strip
86	dh_compress
87	dh_fixperms
88	dh_perl
89#	dh_python
90#	dh_makeshlibs
91	dh_installdeb
92	dh_shlibdeps
93	dh_gencontrol
94	dh_md5sums
95	dh_builddeb
96
97binary: binary-indep binary-arch
98.PHONY: build clean binary-indep binary-arch binary install configure
99