1Source: libre
2Section: comm
3Priority: optional
4Maintainer: Alfred E. Heggestad <aeh@db.org>
5Standards-Version: 3.9.5
6Build-Depends: debhelper (>= 9.20120311)
7Homepage: http://www.creytiv.com/
8
9Package: libre
10Architecture: any
11Section: libs
12Depends: ${shlibs:Depends}, ${misc:Depends}
13Description: Generic library for real-time communications with async IO support
14 Libre is a portable and generic library for real-time communications
15 with async IO support and a complete SIP stack with support for protocols
16 such as SDP, RTP/RTCP, STUN/TURN/ICE, BFCP, HTTP and DNS Client.
17 .
18 The current features are:
19 .
20  SIP Stack (RFC 3261)
21  SDP parser
22  RTP and RTCP stack
23  DNS-Client
24  STUN/TURN/ICE stack
25  BFCP
26  Jitter-buffer
27  Async I/O (poll, epoll, select)
28  UDP/TCP/TLS/DTLS transport
29  HTTP Client and Server
30  Websocket Client and Server
31  JSON parser
32  SRTP and SRTCP (Secure RTP)
33 .
34 Design goals:
35 .
36  Portable POSIX source code (ANSI C89 and ISO C99 standard)
37  Robust, fast, low memory footprint
38  RFC compliance
39  IPv4 and IPv6 support
40
41Package: libre-dev
42Architecture: any
43Section: libdevel
44Depends: libre (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
45Description: Generic library for real-time communications (development files)
46 Libre is a portable and generic library for real-time communications
47 with async IO support and a complete SIP stack with support for protocols
48 such as SDP, RTP/RTCP, STUN/TURN/ICE, BFCP, HTTP and DNS Client.
49 .
50 The current features are:
51 .
52  SIP Stack (RFC 3261)
53  SDP parser
54  RTP and RTCP stack
55  DNS-Client
56  STUN/TURN/ICE stack
57  BFCP
58  Jitter-buffer
59  Async I/O (poll, epoll, select)
60  UDP/TCP/TLS/DTLS transport
61  HTTP Client and Server
62  Websocket Client and Server
63  JSON parser
64  SRTP and SRTCP (Secure RTP)
65 .
66 Design goals:
67 .
68  Portable POSIX source code (ANSI C89 and ISO C99 standard)
69  Robust, fast, low memory footprint
70  RFC compliance
71  IPv4 and IPv6 support
72 .
73 This package is only the library development files.
74