1#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10#export DH_VERBOSE=1
11
12
13EXTRA_CFLAGS:="$(shell dpkg-buildflags --get CFLAGS | sed -e 's/-O2//')"
14EXTRA_LFLAGS:="$(shell dpkg-buildflags --get LDFLAGS) -Wl,-soname,librem.so"
15
16
17configure: configure-stamp
18configure-stamp:
19	dh_testdir
20	# Add here commands to configure the package.
21
22	touch configure-stamp
23
24
25build: build-stamp
26build-stamp: configure-stamp
27	dh_testdir
28
29	# Add here commands to compile the package.
30	$(MAKE) RELEASE=1 \
31		EXTRA_CFLAGS=$(EXTRA_CFLAGS) \
32		EXTRA_LFLAGS=$(EXTRA_LFLAGS)
33
34	touch $@
35
36clean:
37	dh_testdir
38	dh_testroot
39	rm -f build-stamp configure-stamp
40
41	# Add here commands to clean up after the build process.
42	$(MAKE) clean
43
44	dh_clean
45
46install: build
47	dh_testdir
48	dh_testroot
49	dh_prep
50	dh_installdirs
51
52        # Add here commands to install the package into debian/tmp
53	mkdir $(CURDIR)/debian/tmp
54	$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
55
56	dh_movefiles
57
58# Build architecture-independent files here.
59binary-indep: build install
60# We have nothing to do by default.
61
62# Build architecture-dependent files here.
63binary-arch: build install
64	dh_testdir
65	dh_testroot
66	dh_installchangelogs
67	dh_installdocs
68	dh_installexamples
69#	dh_install
70#	dh_installmenu
71#	dh_installdebconf
72#	dh_installlogrotate
73#	dh_installemacsen
74#	dh_installpam
75#	dh_installmime
76#	dh_installinit
77#	dh_installcron
78#	dh_installinfo
79	dh_installman
80	dh_link
81	dh_strip
82	dh_compress
83	dh_fixperms
84#	dh_perl
85#	dh_python
86#	dh_makeshlibs
87	dh_installdeb
88	dh_shlibdeps
89	dh_gencontrol
90	dh_md5sums
91	dh_builddeb
92
93build-arch: build
94
95build-indep: build
96
97binary: binary-indep binary-arch
98.PHONY: build clean binary-indep binary-arch binary install configure
99