1/* -*- c -*- */
2
3  #include "spec.h"
4
5  FIELD_BL (num_reactors, 0); // max 15
6#ifdef IS_DECODER
7  if (FIELD_VALUE (num_reactors) * dwg_bits_size[BITS_HANDLE] > AVAIL_BITS (hdl_dat))
8    {
9      LOG_ERROR ("num_reactors: " FORMAT_BL " > AVAIL_BITS(hdl_dat): %lld\n",
10                 FIELD_VALUE (num_reactors), AVAIL_BITS (hdl_dat))
11      FIELD_VALUE (num_reactors) = 0;
12      return DWG_ERR_VALUEOUTOFBOUNDS;
13    }
14#endif
15  SINCE (R_2004) { FIELD_B (is_xdic_missing, 0); }
16  SINCE (R_2013) { FIELD_B (has_ds_data, 0); }
17
18#ifdef IS_DXF
19  // unused. see out_dxf.c
20  SINCE (R_13) {
21    XDICOBJHANDLE (3);
22    REACTORS (4);
23  }
24#endif
25
26#if !defined(IS_FREE) && !defined(IS_JSON)
27  // done later in the dwg.spec, because of num_entries
28  if (!dwg_obj_is_control (obj))
29#endif
30    {
31      SINCE (R_13) {
32        FIELD_HANDLE (ownerhandle, 4, 330);
33      }
34
35#ifndef IS_DXF
36      SINCE (R_13) {
37        REACTORS (4)
38        XDICOBJHANDLE (3)
39      }
40#endif
41    }
42