1Name: boost-jam
2Version: 3.1.19
3Summary: Build tool
4Release: 1
5Source: %{name}-%{version}.tgz
6
7License: Boost Software License, Version 1.0
8Group: Development/Tools
9URL: http://www.boost.org
10Packager: Rene Rivera <grafik@redshift-software.com>
11BuildRoot: /var/tmp/%{name}-%{version}.root
12
13%description
14Boost Jam is a build tool based on FTJam, which in turn is based on
15Perforce Jam. It contains significant improvements made to facilitate
16its use in the Boost Build System, but should be backward compatible
17with Perforce Jam.
18
19Authors:
20    Perforce Jam : Cristopher Seiwald
21    FT Jam : David Turner
22    Boost Jam : David Abrahams
23
24Copyright:
25    /+\
26    +\  Copyright 1993-2002 Christopher Seiwald and Perforce Software, Inc.
27    \+/
28    License is hereby granted to use this software and distribute it
29    freely, as long as this copyright notice is retained and modifications
30    are clearly marked.
31    ALL WARRANTIES ARE HEREBY DISCLAIMED.
32
33Also:
34    Copyright 2001-2006 David Abrahams.
35    Copyright 2002-2006 Rene Rivera.
36    Copyright 2003-2006 Vladimir Prus.
37
38    Distributed under the Boost Software License, Version 1.0.
39    (See accompanying file LICENSE_1_0.txt or http://www.boost.org/LICENSE_1_0.txt)
40
41%prep
42%setup -n %{name}-%{version}
43
44%build
45LOCATE_TARGET=bin ./build.sh $BOOST_JAM_TOOLSET
46
47%install
48rm -rf $RPM_BUILD_ROOT
49mkdir -p $RPM_BUILD_ROOT%{_bindir}
50mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
51install -m 755 bin/bjam $RPM_BUILD_ROOT%{_bindir}/bjam-%{version}
52ln -sf bjam-%{version} $RPM_BUILD_ROOT%{_bindir}/bjam
53cp -R *.html *.png *.css LICENSE*.txt images jam $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
54
55find $RPM_BUILD_ROOT -name CVS -type d -exec rm -r {} \;
56
57%files
58%defattr(-,root,root)
59%attr(755,root,root) /usr/bin/*
60%doc %{_docdir}/%{name}-%{version}
61
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65