1# -*- mode: python -*-
2#-----------------------------------------------------------------------------
3# Copyright (c) 2013-2019, PyInstaller Development Team.
4#
5# Distributed under the terms of the GNU General Public License with exception
6# for distributing bootloader.
7#
8# The full license is in the file COPYING.txt, distributed with this software.
9#-----------------------------------------------------------------------------
10
11
12__testname__ = 'test_matplotlib'
13
14if sys.platform == 'win32' and sys.version_info[:2] >= (2, 6):
15    manifest = '''<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
16  <dependency>
17    <dependentAssembly>
18      <assemblyIdentity type="win32" name="Microsoft.VC90.CRT" version="9.0.21022.8" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b"></assemblyIdentity>
19    </dependentAssembly>
20  </dependency>
21</assembly>'''
22else:
23    manifest = None
24
25a = Analysis([__testname__ + '.py'])
26pyz = PYZ(a.pure)
27exe = EXE(pyz,
28          a.scripts,
29          exclude_binaries=1,
30          name=__testname__ + '.exe',
31          debug=False,
32          strip=False,
33          upx=False,
34          console=True,
35          manifest=manifest )
36coll = COLLECT(exe,
37               a.binaries,
38               a.zipfiles,
39               a.datas,
40               strip=False,
41               upx=False,
42               name=__testname__)
43