1# Copyright 1999-2003 Gentoo Technologies, Inc.
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit games
6
7DESCRIPTION="Avanor is a fantasy rogue-like role-playing game"
8HOMEPAGE="http://avanor.sourceforge.net/"
9SRC_URI="mirror://sourceforge/avanor/${P}-src.tar.bz2"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="~x86 ~amd64"
14
15DEPEND=">=sys-libs/ncurses-5"
16
17src_compile() {
18	make DATA_DIR="${GAMES_DATADIR}/${PN}/" OPTFLAGS="${CXXFLAGS}" || die "make failed"
19}
20
21src_install() {
22	exeinto ${GAMES_BINDIR}
23	doexe avanor
24	dodir ${GAMES_DATADIR}/${PN}
25	dodir ${GAMES_DATADIR}/${PN}/manual
26	cp manual/* ${D}/${GAMES_DATADIR}/${PN}/manual
27	dodoc changes.txt
28	dohtml manual/*
29	echo "hiscore table is empty" > ${D}/${GAMES_DATADIR}/${PN}/avanor.hsc
30	prepgamesdirs
31	chmod -R g+w ${D}/${GAMES_DATADIR}/${PN}/avanor.hsc
32}
33