1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit eutils games
6
7
8DESCRIPTION="Dune Legacy is an open source clone of Dune 2."
9HOMEPAGE="http://dunelegacy.sourceforge.net"
10SRC_URI="http://www.myway.de/richieland/${PN}-0.96.4-src.tar.bz2"
11
12LICENSE="GPL-2 or later"
13SLOT="0"
14KEYWORDS="amd64 x86 ppc"
15IUSE=""
16
17RDEPEND="media-libs/libsdl2
18	media-libs/sdl2-mixer"
19
20DEPEND="${RDEPEND}"
21
22S=${WORKDIR}/${PN}-0.96.4
23
24src_install() {
25        cd "${S}/src"
26
27	dogamesbin ${PN} || die "dogamesbin failed"
28
29	cd "${S}"
30
31	insinto "${GAMES_DATADIR}"/${PN}
32	doins -r data/* || die "doins failed"
33
34	doicon dunelegacy.png
35	make_desktop_entry ${PN} "Dune Legacy" dunelegacy.png "Game;StrategyGame;"
36
37	prepgamesdirs
38}
39
40pkg_postinst() {
41    elog "You will need to copy all Dune 2 PAK files to ${GAMES_DATADIR}/${PN} !"
42    elog ""
43    elog "At least the following files are needed:"
44    elog " - ATRE.PAK"
45    elog " - DUNE.PAK"
46    elog " - ENGLISH.PAK"
47    elog " - FINALE.PAK"
48    elog " - HARK.PAK"
49    elog " - INTRO.PAK"
50    elog " - INTROVOC.PAK"
51    elog " - MENTAT.PAK"
52    elog " - MERC.PAK"
53    elog " - ORDOS.PAK"
54    elog " - SCENARIO.PAK"
55    elog " - SOUND.PAK"
56    elog " - VOC.PAK"
57    elog ""
58    elog "For playing in german or french you need additionally GERMAN.PAK"
59    elog "or FRENCH.PAK."
60}
61
62