1%define name gl-117
2%define version 0.8.8
3
4Summary: An OpenGL and SDL based action flight simulator
5Summary(de): Ein OpenGL- und SDL-basierter Flugsimulator
6Summary(pl): Zrcznociowy symulator lotu uywajcy OpenGL i SDL
7Name: %{name}
8Version: %{version}
9Release: 1
10Copyright: GPL
11Vendor: Thomas A. Drexl <tom.drexl@gmx.de>
12Url: http://home.t-online.de/home/Primetime./
13Packager: Dominik Seichter <domseichter@web.de>
14Group: x11/games
15Source: %{name}-%{version}.tar.gz
16BuildRoot: /var/tmp/%{name}-%{version}
17
18%description
19GL-117 is an OpenGL and SDL-based action flight simulator written in
20C++. It provides a random terrain generator, lighting effects, sounds,
21and joystick support. Predefined levels of video quality and an amount
22of viewing ranges let you perfectly adjust the game to the performance
23of your system.
24
25%description -l de
26GL-117 ist ein in C++ entwickelter, OpenGL- und SDL-basierter
27Action-Flugsimulator. Neben per Zufall erzeugten Landschaften besticht
28das Spiel durch Lichteffekte, Sound und Joystickuntersttzung. Anhand
29vordefinierter Qualittsstufen lsst sich die Grafik optimal an die
30Leistung des eigenen Systems anpassen.
31
32%description -l pl
33GL-117 jest zrcznociowym symulatorem lotu napisanym w C++,
34wykorzystujcym biblioteki OpenGL i SDL. Posiada obsugjoysticka,
35dwik, losowo generowany teren, efektywietlne. Predefiniowane
36poziomy jakoci obrazu oraz szeroki zakres ustawiewidocznoci
37pozwalajidealnie dopasowagrdo wydajnoci systemu.
38
39%prep
40%setup
41./configure
42
43%build
44
45# Setup for parallel builds
46numprocs=`egrep -c ^cpu[0-9]+ /proc/stat || :`
47if [ "$numprocs" = "0" ]; then
48numprocs=1
49fi
50
51make -j$numprocs
52
53%install
54make install-strip DESTDIR=$RPM_BUILD_ROOT
55
56cd $RPM_BUILD_ROOT
57find . -type d | sed '1,2d;s,^\.,\%attr(-\,root\,root) \%dir ,' > $RPM_BUILD_DIR/file.list.gl-117
58find . -type f | sed 's,^\.,\%attr(-\,root\,root) ,' >>  $RPM_BUILD_DIR/file.list.gl-117
59find . -type l | sed 's,^\.,\%attr(-\,root\,root) ,' >>  $RPM_BUILD_DIR/file.list.gl-117
60
61%clean
62rm -rf $RPM_BUILD_ROOT/*
63rm -rf $RPM_BUILD_DIR/gl-117
64rm -rf ../file.list.gl-117
65
66%files -f ../file.list.gl-117
67
68
69
70