1Name:         fbida
2License:      GPLv2+
3Version:      2.14
4Release:      1%{?dist}
5Summary:      fbida
6Group:        Applications/Multimedia
7URL:          http://www.kraxel.org/blog/linux/%{name}/
8Source:       http://www.kraxel.org/releases/%{name}/%{name}-%{version}.tar.gz
9
10# meson
11BuildRequires: meson ninja-build
12
13# image format libs
14BuildRequires: libjpeg-devel
15BuildRequires: libpcd-devel
16BuildRequires: pkgconfig(libexif)
17BuildRequires: pkgconfig(libpng)
18BuildRequires: pkgconfig(libtiff-4)
19BuildRequires: pkgconfig(libwebp)
20BuildRequires: pkgconfig(pixman-1)
21
22# ida
23BuildRequires: motif-devel
24BuildRequires: libXpm-devel
25BuildRequires: libXt-devel
26BuildRequires: libX11-devel
27
28# fbi + fbpdf
29BuildRequires: pkgconfig(freetype2)
30BuildRequires: pkgconfig(fontconfig)
31BuildRequires: pkgconfig(libdrm)
32BuildRequires: pkgconfig(poppler-glib)
33BuildRequires: pkgconfig(gbm)
34BuildRequires: pkgconfig(egl)
35BuildRequires: pkgconfig(epoxy)
36BuildRequires: pkgconfig(cairo-gl)
37
38%description
39fbida
40
41%package -n fbi
42Summary: Framebuffer image viewer
43%description -n fbi
44fbi displays images on the linux console using fbdev or drm.
45
46%package -n fbpdf
47Summary: Framebuffer pdf viewer
48Group: Applications/Productivity
49%description -n fbpdf
50fbpdf displays pdf files on the linux console using fbdev or drm.
51
52%package -n ida
53Summary: Motif image viewer
54%description -n ida
55ida is a motif-based image viewer for X11.
56
57%package -n exiftran
58Summary: exiftran
59%description -n exiftran
60Exiftran is a command line utility to transform digital camera jpeg
61images.  It can do lossless rotations like jpegtran, but unlike
62jpegtran it also handles the exif metadata.
63
64%prep
65%setup -q
66
67%build
68export CFLAGS="%{optflags}"
69meson --prefix=%{_prefix} build-rpm
70ninja-build -C build-rpm
71
72%install
73export DESTDIR=%{buildroot}
74ninja-build -C build-rpm install
75# add fbgs
76cp fbgs %{buildroot}%{_bindir}
77cp man/fbgs.1 %{buildroot}%{_mandir}/man1
78
79%files -n fbi
80%doc COPYING
81%{_bindir}/fbi
82%{_bindir}/fbgs
83%{_mandir}/man1/fbi.1*
84%{_mandir}/man1/fbgs.1*
85
86%files -n fbpdf
87%doc COPYING
88%{_bindir}/fbpdf
89
90%files -n ida
91%doc COPYING
92%{_bindir}/ida
93%{_mandir}/man1/ida.1*
94/usr/share/X11/app-defaults/Ida
95
96%files -n exiftran
97%doc COPYING
98%{_bindir}/exiftran
99%{_mandir}/man1/exiftran.1*
100
101%changelog
102* Wed Aug 30 2017 Gerd Hoffmann <kraxel@redhat.com> 2.14-1
103- meson. fix app defaults install (kraxel@redhat.com)
104- spec: install fbgs (kraxel@redhat.com)
105- switch specfile to meson (kraxel@redhat.com)
106- fix ps writer gcc7 warning (kraxel@redhat.com)
107- meson: conditionally build ida (kraxel@redhat.com)
108- meson: install app defaults file (kraxel@redhat.com)
109- jpeg-version: add cflags to cpp cmd line (kraxel@redhat.com)
110- meson: initial install support (kraxel@redhat.com)
111- move & rename manpages (kraxel@redhat.com)
112- deprecate curl, sane and lirc support (kraxel@redhat.com)
113- meson: tag as python for emacs (kraxel@redhat.com)
114- meson: add ida (kraxel@redhat.com)
115- meson: minor reordering (kraxel@redhat.com)
116- move blob hexifxing to script (kraxel@redhat.com)
117- pass filenames as args to fallback.pl (kraxel@redhat.com)
118- move fallback.pl to scripts (kraxel@redhat.com)
119- meson: add thumbnail.cgi (kraxel@redhat.com)
120- meson: add exiftran (kraxel@redhat.com)
121- meson: fix cairo deps (kraxel@redhat.com)
122- meson: add cairo-gl detection (kraxel@redhat.com)
123- meson: add jpeg version detection (kraxel@redhat.com)
124- move libjpeg version detect to script (kraxel@redhat.com)
125- meson: add pcd + gif (kraxel@redhat.com)
126- meson: add webp (kraxel@redhat.com)
127- meson: add kbdtest (kraxel@redhat.com)
128- meson: add fbpdf (kraxel@redhat.com)
129- meson: start build file (kraxel@redhat.com)
130- drop strsignal detection (kraxel@redhat.com)
131- invert partial fix (kraxel@redhat.com)
132- fix flip & rotate (kraxel@redhat.com)
133- fix exiftran build (kraxel@redhat.com)
134- update buildreq in specfile (kraxel@redhat.com)
135- use pixman images for storage (kraxel@redhat.com)
136- add egl pkg-config (kraxel@redhat.com)
137- make cairo-gl a compile time option (kraxel@redhat.com)
138- zap HAVE_LIBTIFF, tiff is a hard dependency now (kraxel@redhat.com)
139- zap HAVE_LIBPNG, png is a hard dependency now (kraxel@redhat.com)
140- zap HAVE_NEW_EXIF (kraxel@redhat.com)
141- zap HAVE_ENDIAN_H (kraxel@redhat.com)
142- use eglGetPlatformDisplayEXT if available (kraxel@redhat.com)
143- add 'make apt-get' (kraxel@redhat.com)
144- fix debian/ubuntu build issue (kraxel@redhat.com)
145- sync maintainer makefiles (kraxel@redhat.com)
146- tito: add VERSION.template (kraxel@redhat.com)
147
148* Wed Feb 22 2017 Gerd Hoffmann <kraxel@redhat.com> 2.13-1
149- new package built with tito
150
151