1 /* $Id: DSAPublicKeySpec.java,v 1.1 2000/07/26 22:02:39 gelderen Exp $
2  *
3  * Copyright (C) 1995-1999 The Cryptix Foundation Limited.
4  * All rights reserved.
5  *
6  * Use, modification, copying and distribution of this software is subject
7  * the terms and conditions of the Cryptix General Licence. You should have
8  * received a copy of the Cryptix General Licence along with this library;
9  * if not, you can download a copy from http://www.cryptix.org/ .
10  */
11 package java.security.spec;
12 
13 
14 import java.math.BigInteger;
15 
16 
17 /**
18  * DSA public key + parameters (y and g, p, q).
19  *
20  * <p>Immutable.</p>
21  *
22  * @author  Jeroen C. van Gelderen (gelderen@cryptix.org)
23  * @version $Revision: 1.1 $
24  */
25 public class DSAPublicKeySpec implements KeySpec {
26 
27     private final BigInteger y, p, q, g;
28 
29 
DSAPublicKeySpec(BigInteger y, BigInteger p, BigInteger q, BigInteger g)30     public DSAPublicKeySpec(BigInteger y,
31                             BigInteger p, BigInteger q, BigInteger g)
32     {
33         this.y = y;
34         this.p = p;
35         this.q = q;
36         this.g = g;
37     }
38 
39 
getG()40     public BigInteger getG() {
41         return this.g;
42     }
43 
44 
getP()45     public BigInteger getP() {
46         return this.p;
47     }
48 
49 
getQ()50     public BigInteger getQ() {
51         return this.q;
52     }
53 
54 
getY()55     public BigInteger getY() {
56         return this.y;
57     }
58 }
59