1# $Id: dymo-cups-drivers.spec 4913 2008-07-10 22:17:43Z vbuzuev $
2
3#    DYMO LabelWriter Drivers
4#    Copyright (C) 2008 Sanford L.P.
5
6#    This program is free software; you can redistribute it and/or
7#    modify it under the terms of the GNU General Public License
8#    as published by the Free Software Foundation; either version 2
9#    of the License, or (at your option) any later version.
10
11#    This program is distributed in the hope that it will be useful,
12#    but WITHOUT ANY WARRANTY; without even the implied warranty of
13#    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14#    GNU General Public License for more details.
15
16#    You should have received a copy of the GNU General Public License
17#    along with this program; if not, write to the Free Software
18#    Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
19
20Summary: DYMO LabelWriter Drivers for CUPS
21Name: dymo-cups-drivers
22Version: 1.0.1
23Release: 0
24License: GPL
25Group: System Environment/Libraries
26Source: dymo-cups-drivers-%{version}.tar.gz
27Url: http://www.dymo.com
28Packager: Anonymous <anonymous@foo.com>
29Vendor: DYMO
30
31# Use buildroot so as not to disturb the version already installed
32BuildRoot: /var/tmp/%{name}-root
33
34# Dependencies...
35#Requires: cups, cups-devel
36
37
38%description
39DYMO LabelWriter and DYMO LabelMANAGER series drivers for CUPS
40
41%prep
42%setup
43
44%build
45CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_OPT_FLAGS" BUILDROOT=$RPM_BUILD_ROOT ./configure
46
47# If we got this far, all prerequisite libraries must be here.
48make
49
50%install
51# Make sure the RPM_BUILD_ROOT directory exists.
52rm -rf $RPM_BUILD_ROOT
53
54make BUILDROOT=$RPM_BUILD_ROOT install
55
56%post
57
58%preun
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%files
64%defattr(-,root,root)
65
66%dir /usr/lib/cups
67/usr/lib/cups/*
68%dir /usr/share/cups
69/usr/share/cups/*
70
71
72#
73# End of "$Id: dymo-cups-drivers.spec 4913 2008-07-10 22:17:43Z vbuzuev $".
74#
75