1{ pkgs ? import ./nix {} }:
2with pkgs;
3mkShell {
4  buildInputs = [
5    # Build
6    gitAndTools.git
7    gitAndTools.git-extras # for git-changelog
8    gnumake
9    go
10    go-md2man
11    gox
12
13    # Shells
14    bashInteractive
15    elvish
16    fish
17    tcsh
18    zsh
19
20    # Test dependencies
21    golangci-lint
22    ruby
23    shellcheck
24    shfmt
25  ];
26
27  shellHook = ''
28    unset GOPATH GOROOT
29    export GO111MODULE=on
30    export SSL_CERT_FILE=${cacert}/etc/ssl/certs/ca-bundle.crt
31  '';
32}
33