1Name: monit
2Summary: Process monitor and restart utility
3Version: 5.29.0
4Release: 1
5URL: http://mmonit.com/monit/
6Source: http://mmonit.com/monit/dist/%{name}-%{version}.tar.gz
7Group: Utilities/Console
8BuildRoot: %{_tmppath}/%{name}-buildroot
9License: AGPL
10
11%{!?_with_ssl: %{!?_without_ssl: %define _with_ssl --with-ssl}}
12%{?_with_ssl:BuildRequires: openssl-devel}
13
14%{!?_with_pam: %{!?_without_pam: %define _with_pam --with-pam}}
15%{?_with_pam:BuildRequires: pam-devel}
16
17%description
18Monit is a utility for managing and monitoring processes,
19files, directories and filesystems on a Unix system. Monit conducts
20automatic maintenance and repair and can execute meaningful causal
21actions in error situations.
22
23%prep
24%setup
25
26%build
27%configure \
28        %{?_with_ssl} \
29        %{?_without_ssl} \
30        %{?_with_pam} \
31        %{?_without_pam}
32make %{?_smp_mflags}
33
34%install
35if [ -d %{buildroot} ] ; then
36  rm -rf %{buildroot}
37fi
38
39mkdir -p %{buildroot}%{_bindir}
40mkdir -p %{buildroot}%{_mandir}/man1
41mkdir -p %{buildroot}/etc/init.d
42install -m 755 monit %{buildroot}%{_bindir}/monit
43install -m 644 monit.1 %{buildroot}%{_mandir}/man1/monit.1
44install -m 600 monitrc %{buildroot}/etc/monitrc
45install -m 755 system/startup/rc.monit %{buildroot}/etc/init.d/%{name}
46
47%post
48/sbin/chkconfig --add %{name}
49
50%preun
51if [ $1 = 0 ]; then
52   /etc/init.d/%{name} stop >/dev/null 2>&1
53   /sbin/chkconfig --del %{name}
54fi
55
56%clean
57if [ -d %{buildroot} ] ; then
58  rm -rf %{buildroot}
59fi
60
61%files
62%defattr(-,root,root)
63%doc COPYING CHANGES
64%config(noreplace) /etc/monitrc
65%config /etc/init.d/%{name}
66%{_bindir}/%{name}
67%{_mandir}/man1/%{name}.1.gz
68
69%changelog
70* Tue Aug 24 2021 Monit team <support@mmonit.com>
71- Upgraded to monit-5.29.0
72
73* Wed Jul 28 2021 Monit team <support@mmonit.com>
74- Upgraded to monit-5.28.1
75
76* Mon Mar 29 2021 Monit team <support@mmonit.com>
77- Upgraded to monit-5.28.0
78
79* Tue Oct 27 2020 Martin Pala <martinp@tildeslash.com>
80- Upgraded to monit-5.27.2
81
82* Sun Aug 30 2020 Martin Pala <martinp@tildeslash.com>
83- Upgraded to monit-5.27.1
84
85* Thu Jan 16 2020 Martin Pala <martinp@tildeslash.com>
86- Upgraded to monit-5.27.0
87
88* Sat Jul 06 2019 Martin Pala <martinp@tildeslash.com>
89- Upgraded to monit-5.26.0
90
91* Tue Mar 05 2019 Martin Pala <martinp@tildeslash.com>
92- Upgraded to monit-5.25.3
93
94* Tue May 29 2018 Martin Pala <martinp@tildeslash.com>
95- Upgraded to monit-5.25.2
96
97* Fri Nov 17 2017 Martin Pala <martinp@tildeslash.com>
98- Upgraded to monit-5.25.1
99
100* Mon Sep 25 2017 Martin Pala <martinp@tildeslash.com>
101- Upgraded to monit-5.25.0
102
103* Thu Jun 08 2017 Martin Pala <martinp@tildeslash.com>
104- Upgraded to monit-5.24.0
105
106* Wed Apr 19 2017 Martin Pala <martinp@tildeslash.com>
107- Upgraded to monit-5.23.0
108
109* Tue Mar 07 2017 Martin Pala <martinp@tildeslash.com>
110- Upgraded to monit-5.22.0
111
112* Sat Oct 22 2016 Martin Pala <martinp@tildeslash.com>
113- Upgraded to monit-5.21.0
114
115* Tue Sep 06 2016 Martin Pala <martinp@tildeslash.com>
116- Upgraded to monit-5.20.0
117
118* Wed Jul 27 2016 Martin Pala <martinp@tildeslash.com>
119- Upgraded to monit-5.19.0
120
121* Fri Apr 01 2016 Martin Pala <martinp@tildeslash.com>
122- Upgraded to monit-5.18
123
124* Fri Mar 04 2016 Martin Pala <martinp@tildeslash.com>
125- Upgraded to monit-5.17.1
126
127* Thu Feb 04 2016 Martin Pala <martinp@tildeslash.com>
128- Upgraded to monit-5.17
129
130* Thu Nov 05 2015 Martin Pala <martinp@tildeslash.com>
131- Upgraded to monit-5.16
132
133* Mon Oct 12 2015 Martin Pala <martinp@tildeslash.com>
134- Upgraded to monit-5.15
135- Added rpmbuild options for building without PAM (--without pam)
136- Added rpmbuild options for building without SSL (--without ssl)
137- Dropped build dependency on flex and bison
138
139* Mon Jun 08 2015 Martin Pala <martinp@tildeslash.com>
140- Upgraded to monit-5.14
141
142* Mon Mar 23 2015 Martin Pala <martinp@tildeslash.com>
143- Upgraded to monit-5.13
144
145* Tue Mar 10 2015 Martin Pala <martinp@tildeslash.com>
146- Upgraded to monit-5.12.2
147
148* Fri Mar 6 2015 Martin Pala <martinp@tildeslash.com>
149- Upgraded to monit-5.12.1
150
151* Tue Feb 24 2015 Martin Pala <martinp@tildeslash.com>
152- Upgraded to monit-5.12
153
154* Wed Dec 17 2014 Martin Pala <martinp@tildeslash.com>
155- Upgraded to monit-5.11
156
157* Mon Oct 06 2014 Martin Pala <martinp@tildeslash.com>
158- Upgraded to monit-5.10
159
160* Sat Aug 23 2014 Martin Pala <martinp@tildeslash.com>
161- Upgraded to monit-5.9
162
163* Fri Aug 22 2014 Martin Pala <martinp@tildeslash.com>
164- Upgraded to monit-5.8.2
165
166* Sun Mar 30 2014 Martin Pala <martinp@tildeslash.com>
167- Upgraded to monit-5.8.1
168
169* Sat Mar 08 2014 Martin Pala <martinp@tildeslash.com>
170- Upgraded to monit-5.8
171
172* Thu Feb 20 2014 Martin Pala <martinp@tildeslash.com>
173- Upgraded to monit-5.7
174
175* Thu Jun 06 2013 Martin Pala <martinp@tildeslash.com>
176- Upgraded to monit-5.6
177
178* Tue Jun 04 2013 Martin Pala <martinp@tildeslash.com>
179- Upgraded to monit-5.5.1
180
181* Wed May 09 2012 Martin Pala <martinp@tildeslash.com>
182- Upgraded to monit-5.5
183
184* Sun May 06 2012 Martin Pala <martinp@tildeslash.com>
185- Upgraded to monit-5.4
186
187* Sat Oct 22 2011 Martin Pala <martinp@tildeslash.com>
188- Upgraded to monit-5.3.1
189
190* Thu Aug 25 2011 Martin Pala <martinp@tildeslash.com>
191- Upgraded to monit-5.3
192
193* Mon Mar 28 2011 Martin Pala <martinp@tildeslash.com>
194- Upgraded to monit-5.2.5
195
196* Wed Feb 23 2011 Martin Pala <martinp@tildeslash.com>
197- Upgraded to monit-5.2.4
198
199* Thu Sep 16 2010 Martin Pala <martinp@tildeslash.com>
200- Upgraded to monit-5.2
201
202* Thu Feb 18 2010 Martin Pala <martinp@tildeslash.com>
203- Upgraded to monit-5.1.1
204
205* Sat Jan 09 2010 Martin Pala <martinp@tildeslash.com>
206- Upgraded to monit-5.1
207
208* Thu May 28 2009 Martin Pala <martinp@tildeslash.com>
209- Upgraded to monit-5.0.3
210
211* Thu May 7 2009 Martin Pala <martinp@tildeslash.com>
212- Upgraded to monit-5.0.2
213
214* Wed Apr 22 2009 Martin Pala <martinp@tildeslash.com>
215- Upgraded to monit-5.0.1
216
217* Sun Apr 13 2008 Martin Pala <martinp@tildeslash.com>
218- Upgraded to monit-5.0
219
220* Tue Nov 06 2007 Martin Pala <martinp@tildeslash.com>
221- Upgraded to monit-4.10.1
222
223* Mon Nov 05 2007 Martin Pala <martinp@tildeslash.com>
224- Upgraded to monit-4.10
225
226* Mon Feb 19 2007 Martin Pala <martinp@tildeslash.com>
227- Upgraded to monit-4.9
228
229* Sun Mar 05 2006 Martin Pala <martinp@tildeslash.com>
230- Upgraded to monit-4.7
231
232* Mon Sep 19 2005 Martin Pala <martinp@tildeslash.com>
233- Upgraded to monit-4.6
234
235* Tue Oct 19 2004 Martin Pala <martinp@tildeslash.com>
236- Upgraded to monit-4.4
237
238* Tue Nov 04 2003 Martin Pala <martinp@tildeslash.com>
239- Fixed the bad path to monit binary in startup script. Thanks to Ben Ciceron
240  for report of the problem.
241
242* Mon Oct 27 2003 Martin Pala <martinp@tildeslash.com>
243- Upgraded to monit-4.1
244
245* Tue Sep 23 2003 Martin Pala <martinp@tildeslash.com>
246- change the description
247
248* Fri Mar 07 2003 Martin Pala <martinp@tildeslash.com>
249- Upgraded to monit-4.0
250- Updated documentation list
251- Changed use of monit.conf file to default monitrc ( => monit could find it )
252- Use monitrc and rc.monit from default monit distribution
253
254* Wed Jul 10 2002 Rory Toma <rory@digeo.com>
255- Upgraded to monit-2.4.3
256
257* Mon Feb 05 2001 Clinton Work <work@scripty.com>
258- Upgraded to monit 1.2
259- Use chkconfig to add monit to the rc.d startup scripts
260- Use the example monitrc instead of my custom monit.conf
261- Fixed the monit homepage URL
262
263* Thu Feb 01 2001 Clinton Work <work@scripty.com>
264- Create the initial spec file
265- Created a sample config file and a rc startup script
266
267