1%if ! (0%{?rhel} >= 6 || 0%{?fedora} > 12)
2%global with_python26 1
3%define pybasever 2.6
4%define __python_ver 26
5%define __python %{_bindir}/python%{?pybasever}
6%endif
7
8%global include_tests 1
9
10%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
11%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
12%{!?pythonpath: %global pythonpath %(%{__python} -c "import os, sys; print(os.pathsep.join(x for x in sys.path if x))")}
13
14%define _salttesting SaltTesting
15%define _salttesting_ver 2015.2.16
16
17Name: salt
18Version: 2014.7.2
19Release: 2%{?dist}
20Summary: A parallel remote execution system
21
22Group:   System Environment/Daemons
23License: ASL 2.0
24URL:     http://saltstack.org/
25Source0: http://pypi.python.org/packages/source/s/%{name}/%{name}-%{version}.tar.gz
26Source1: https://pypi.python.org/packages/source/S/%{_salttesting}/%{_salttesting}-%{_salttesting_ver}.tar.gz
27Source2: %{name}-master
28Source3: %{name}-syndic
29Source4: %{name}-minion
30Source5: %{name}-api
31Source6: %{name}-master.service
32Source7: %{name}-syndic.service
33Source8: %{name}-minion.service
34Source9: %{name}-api.service
35Source10: README.fedora
36Source11: logrotate.salt
37Patch0:  skip_tests_%{version}.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
40BuildArch: noarch
41
42%ifarch %{ix86} x86_64
43Requires: dmidecode
44%endif
45
46Requires: pciutils
47Requires: yum-utils
48
49%if 0%{?with_python26}
50
51BuildRequires: python26-devel
52Requires: python26-crypto
53Requires: python26-jinja2
54Requires: python26-m2crypto
55Requires: python26-msgpack
56Requires: python26-PyYAML
57Requires: python26-requests
58Requires: python26-zmq
59
60%else
61
62%if ((0%{?rhel} >= 6 || 0%{?fedora} > 12) && 0%{?include_tests})
63BuildRequires: m2crypto
64BuildRequires: python-crypto
65BuildRequires: python-jinja2
66BuildRequires: python-msgpack
67BuildRequires: python-pip
68BuildRequires: python-zmq
69BuildRequires: PyYAML
70BuildRequires: python-requests
71BuildRequires: python-unittest2
72# this BR causes windows tests to happen
73# clearly, that's not desired
74# https://github.com/saltstack/salt/issues/3749
75BuildRequires: python-mock
76BuildRequires: git
77BuildRequires: python-libcloud
78
79%if ((0%{?rhel} == 6) && 0%{?include_tests})
80# argparse now a salt-testing requirement
81BuildRequires: python-argparse
82%endif
83
84%endif
85
86BuildRequires: python-devel
87Requires: m2crypto
88Requires: python-crypto
89Requires: python-jinja2
90Requires: python-msgpack
91Requires: PyYAML
92Requires: python-requests
93Requires: python-zmq
94
95%endif
96
97%if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
98
99Requires(post): chkconfig
100Requires(preun): chkconfig
101Requires(preun): initscripts
102Requires(postun): initscripts
103
104%else
105
106%if 0%{?systemd_preun:1}
107
108Requires(post): systemd-units
109Requires(preun): systemd-units
110Requires(postun): systemd-units
111
112%endif
113
114BuildRequires: systemd-units
115Requires:      systemd-python
116
117%endif
118
119%description
120Salt is a distributed remote execution system used to execute commands and
121query data. It was developed in order to bring the best solutions found in
122the world of remote execution together and make them better, faster and more
123malleable. Salt accomplishes this via its ability to handle larger loads of
124information, and not just dozens, but hundreds or even thousands of individual
125servers, handle them quickly and through a simple and manageable interface.
126
127%package master
128Summary: Management component for salt, a parallel remote execution system
129Group:   System Environment/Daemons
130Requires: %{name} = %{version}-%{release}
131%if (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
132Requires: systemd-python
133%endif
134
135%description master
136The Salt master is the central server to which all minions connect.
137
138%package minion
139Summary: Client component for Salt, a parallel remote execution system
140Group:   System Environment/Daemons
141Requires: %{name} = %{version}-%{release}
142
143%description minion
144The Salt minion is the agent component of Salt. It listens for instructions
145from the master, runs jobs, and returns results back to the master.
146
147%package syndic
148Summary: Master-of-master component for Salt, a parallel remote execution system
149Group:   System Environment/Daemons
150Requires: %{name} = %{version}-%{release}
151
152%description syndic
153The Salt syndic is a master daemon which can receive instruction from a
154higher-level master, allowing for tiered organization of your Salt
155infrastructure.
156
157%package api
158Summary: REST API for Salt, a parallel remote execution system
159Group:   System administration tools
160Requires: %{name}-master = %{version}-%{release}
161
162%description api
163salt-api provides a REST interface to the Salt master.
164
165%package cloud
166Summary: Cloud provisioner for Salt, a parallel remote execution system
167Group:   System administration tools
168Requires: %{name}-master = %{version}-%{release}
169
170%description cloud
171The salt-cloud tool provisions new cloud VMs, installs salt-minion on them, and
172adds them to the master's collection of controllable minions.
173
174%package ssh
175Summary: Agentless SSH-based version of Salt, a parallel remote execution system
176Group:   System administration tools
177Requires: %{name} = %{version}-%{release}
178
179%description ssh
180The salt-ssh tool can run remote execution functions and states without the use
181of an agent (salt-minion) service.
182
183%prep
184%setup -c
185%setup -T -D -a 1
186
187cd %{name}-%{version}
188%patch0 -p1
189
190%build
191
192
193%install
194rm -rf %{buildroot}
195cd $RPM_BUILD_DIR/%{name}-%{version}/%{name}-%{version}
196%{__python} setup.py install -O1 --root %{buildroot}
197
198# Add some directories
199install -d -m 0755 %{buildroot}%{_var}/cache/salt
200install -d -m 0755 %{buildroot}%{_sysconfdir}/salt
201install -d -m 0755 %{buildroot}%{_sysconfdir}/salt/cloud.conf.d
202install -d -m 0755 %{buildroot}%{_sysconfdir}/salt/cloud.deploy.d
203install -d -m 0755 %{buildroot}%{_sysconfdir}/salt/cloud.maps.d
204install -d -m 0755 %{buildroot}%{_sysconfdir}/salt/cloud.profiles.d
205install -d -m 0755 %{buildroot}%{_sysconfdir}/salt/cloud.providers.d
206
207# Add the config files
208install -p -m 0640 conf/minion %{buildroot}%{_sysconfdir}/salt/minion
209install -p -m 0640 conf/master %{buildroot}%{_sysconfdir}/salt/master
210install -p -m 0640 conf/cloud %{buildroot}%{_sysconfdir}/salt/cloud
211install -p -m 0640 conf/roster %{buildroot}%{_sysconfdir}/salt/roster
212
213%if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
214mkdir -p %{buildroot}%{_initrddir}
215install -p %{SOURCE2} %{buildroot}%{_initrddir}/
216install -p %{SOURCE3} %{buildroot}%{_initrddir}/
217install -p %{SOURCE4} %{buildroot}%{_initrddir}/
218install -p %{SOURCE5} %{buildroot}%{_initrddir}/
219%else
220mkdir -p %{buildroot}%{_unitdir}
221install -p -m 0644 %{SOURCE6} %{buildroot}%{_unitdir}/
222install -p -m 0644 %{SOURCE7} %{buildroot}%{_unitdir}/
223install -p -m 0644 %{SOURCE8} %{buildroot}%{_unitdir}/
224install -p -m 0644 %{SOURCE9} %{buildroot}%{_unitdir}/
225%endif
226
227install -p %{SOURCE10} .
228mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d/
229install -p -m 0644 %{SOURCE11} %{buildroot}%{_sysconfdir}/logrotate.d/salt
230
231%if ((0%{?rhel} >= 6 || 0%{?fedora} > 12) && 0%{?include_tests})
232%check
233cd $RPM_BUILD_DIR/%{name}-%{version}/%{name}-%{version}
234mkdir %{_tmppath}/salt-test-cache
235PYTHONPATH=%{pythonpath}:$RPM_BUILD_DIR/%{name}-%{version}/%{_salttesting}-%{_salttesting_ver} %{__python} setup.py test --runtests-opts=-u
236%endif
237
238%clean
239rm -rf %{buildroot}
240
241%files
242%defattr(-,root,root,-)
243%doc $RPM_BUILD_DIR/%{name}-%{version}/%{name}-%{version}/LICENSE
244%{python_sitelib}/%{name}/*
245#%{python_sitelib}/%{name}-%{version}-py?.?.egg-info
246%{python_sitelib}/%{name}-*-py?.?.egg-info
247%{_sysconfdir}/logrotate.d/salt
248%{_var}/cache/salt
249%doc $RPM_BUILD_DIR/%{name}-%{version}/%{name}-%{version}/README.fedora
250
251%files master
252%defattr(-,root,root)
253%doc %{_mandir}/man7/salt.7.*
254%doc %{_mandir}/man1/salt-cp.1.*
255%doc %{_mandir}/man1/salt-key.1.*
256%doc %{_mandir}/man1/salt-master.1.*
257%doc %{_mandir}/man1/salt-run.1.*
258%doc %{_mandir}/man1/salt-unity.1.*
259%{_bindir}/salt
260%{_bindir}/salt-cp
261%{_bindir}/salt-key
262%{_bindir}/salt-master
263%{_bindir}/salt-run
264%{_bindir}/salt-unity
265%if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
266%attr(0755, root, root) %{_initrddir}/salt-master
267%else
268%config(noreplace) %{_unitdir}/salt-master.service
269%endif
270%config(noreplace) %{_sysconfdir}/salt/master
271
272%files minion
273%defattr(-,root,root)
274%doc %{_mandir}/man1/salt-call.1.*
275%doc %{_mandir}/man1/salt-minion.1.*
276%{_bindir}/salt-minion
277%{_bindir}/salt-call
278%if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
279%attr(0755, root, root) %{_initrddir}/salt-minion
280%else
281%config(noreplace) %{_unitdir}/salt-minion.service
282%endif
283%config(noreplace) %{_sysconfdir}/salt/minion
284
285%files syndic
286%doc %{_mandir}/man1/salt-syndic.1.*
287%{_bindir}/salt-syndic
288%if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
289%attr(0755, root, root) %{_initrddir}/salt-syndic
290%else
291%config(noreplace) %{_unitdir}/salt-syndic.service
292%endif
293
294%files api
295%defattr(-,root,root)
296%doc %{_mandir}/man1/salt-api.1.*
297%{_bindir}/salt-api
298%if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
299%attr(0755, root, root) %{_initrddir}/salt-api
300%else
301%config(noreplace) %{_unitdir}/salt-api.service
302%endif
303
304%files cloud
305%doc %{_mandir}/man1/salt-cloud.1.*
306%{_bindir}/salt-cloud
307%{_sysconfdir}/salt/cloud.conf.d
308%{_sysconfdir}/salt/cloud.deploy.d
309%{_sysconfdir}/salt/cloud.maps.d
310%{_sysconfdir}/salt/cloud.profiles.d
311%{_sysconfdir}/salt/cloud.providers.d
312%config(noreplace) %{_sysconfdir}/salt/cloud
313
314%files ssh
315%doc %{_mandir}/man1/salt-ssh.1.*
316%{_bindir}/salt-ssh
317%{_sysconfdir}/salt/roster
318
319
320# less than RHEL 8 / Fedora 16
321# not sure if RHEL 7 will use systemd yet
322%if ! (0%{?rhel} >= 7 || 0%{?fedora} >= 15)
323
324%preun master
325  if [ $1 -eq 0 ] ; then
326      /sbin/service salt-master stop >/dev/null 2>&1
327      /sbin/chkconfig --del salt-master
328  fi
329
330%preun syndic
331  if [ $1 -eq 0 ] ; then
332      /sbin/service salt-syndic stop >/dev/null 2>&1
333      /sbin/chkconfig --del salt-syndic
334  fi
335
336%preun minion
337  if [ $1 -eq 0 ] ; then
338      /sbin/service salt-minion stop >/dev/null 2>&1
339      /sbin/chkconfig --del salt-minion
340  fi
341
342%post master
343  /sbin/chkconfig --add salt-master
344
345%post minion
346  /sbin/chkconfig --add salt-minion
347
348%postun master
349  if [ "$1" -ge "1" ] ; then
350      /sbin/service salt-master condrestart >/dev/null 2>&1 || :
351  fi
352
353#%postun syndic
354#  if [ "$1" -ge "1" ] ; then
355#      /sbin/service salt-syndic condrestart >/dev/null 2>&1 || :
356#  fi
357
358%postun minion
359  if [ "$1" -ge "1" ] ; then
360      /sbin/service salt-minion condrestart >/dev/null 2>&1 || :
361  fi
362
363%else
364
365%preun master
366%if 0%{?systemd_preun:1}
367  %systemd_preun salt-master.service
368%else
369  if [ $1 -eq 0 ] ; then
370    # Package removal, not upgrade
371    /bin/systemctl --no-reload disable salt-master.service > /dev/null 2>&1 || :
372    /bin/systemctl stop salt-master.service > /dev/null 2>&1 || :
373  fi
374%endif
375
376%preun syndic
377%if 0%{?systemd_preun:1}
378  %systemd_preun salt-syndic.service
379%else
380  if [ $1 -eq 0 ] ; then
381    # Package removal, not upgrade
382    /bin/systemctl --no-reload disable salt-syndic.service > /dev/null 2>&1 || :
383    /bin/systemctl stop salt-syndic.service > /dev/null 2>&1 || :
384  fi
385%endif
386
387%preun minion
388%if 0%{?systemd_preun:1}
389  %systemd_preun salt-minion.service
390%else
391  if [ $1 -eq 0 ] ; then
392    # Package removal, not upgrade
393    /bin/systemctl --no-reload disable salt-minion.service > /dev/null 2>&1 || :
394    /bin/systemctl stop salt-minion.service > /dev/null 2>&1 || :
395  fi
396%endif
397
398%post master
399%if 0%{?systemd_post:1}
400  %systemd_post salt-master.service
401%else
402  /bin/systemctl daemon-reload &>/dev/null || :
403%endif
404
405%post minion
406%if 0%{?systemd_post:1}
407  %systemd_post salt-minion.service
408%else
409  /bin/systemctl daemon-reload &>/dev/null || :
410%endif
411
412%postun master
413%if 0%{?systemd_post:1}
414  %systemd_postun salt-master.service
415%else
416  /bin/systemctl daemon-reload &>/dev/null
417  [ $1 -gt 0 ] && /bin/systemctl try-restart salt-master.service &>/dev/null || :
418%endif
419
420%postun syndic
421%if 0%{?systemd_post:1}
422  %systemd_postun salt-syndic.service
423%else
424  /bin/systemctl daemon-reload &>/dev/null
425  [ $1 -gt 0 ] && /bin/systemctl try-restart salt-syndic.service &>/dev/null || :
426%endif
427
428%postun minion
429%if 0%{?systemd_post:1}
430  %systemd_postun salt-minion.service
431%else
432  /bin/systemctl daemon-reload &>/dev/null
433  [ $1 -gt 0 ] && /bin/systemctl try-restart salt-minion.service &>/dev/null || :
434%endif
435
436%endif
437
438%changelog
439* Fri Mar 27 2015 Stephen Spencer <stephen@revsys.com> - 2014.7.2-2
440- avoid replacing the salt*.service files. Systemd ignores /etc/security/limits*
441  in favor of directives entered in the service files.
442
443  See systemd.directives(7), systemd.exec(5), systemd-system.conf(5)
444
445* Tue Feb 17 2015 Erik Johnson <erik@saltstack.com> - 2014.7.2-1
446- Update to bugfix release 2014.7.2
447
448* Mon Jan 19 2015 Erik Johnson <erik@saltstack.com> - 2014.7.1-1
449- Update to bugfix release 2014.7.1
450
451* Fri Nov  7 2014 Erik Johnson <erik@saltstack.com> - 2014.7.0-3
452- Make salt-api its own package
453
454* Thu Nov  6 2014 Erik Johnson <erik@saltstack.com> - 2014.7.0-2
455- Fix changelog
456
457* Thu Nov  6 2014 Erik Johnson <erik@saltstack.com> - 2014.7.0-1
458- Update to feature release 2014.7.0
459
460* Fri Oct 17 2014 Erik Johnson <erik@saltstack.com> - 2014.1.13-1
461- Update to bugfix release 2014.1.13
462
463* Mon Sep 29 2014 Erik Johnson <erik@saltstack.com> - 2014.1.11-1
464- Update to bugfix release 2014.1.11
465
466* Sun Aug 10 2014 Erik Johnson <erik@saltstack.com> - 2014.1.10-4
467- Fix incorrect conditional
468
469* Tue Aug  5 2014 Erik Johnson <erik@saltstack.com> - 2014.1.10-2
470- Deploy cachedir with package
471
472* Mon Aug  4 2014 Erik Johnson <erik@saltstack.com> - 2014.1.10-1
473- Update to bugfix release 2014.1.10
474
475* Thu Jul 10 2014 Erik Johnson <erik@saltstack.com> - 2014.1.7-3
476- Add logrotate script
477
478* Thu Jul 10 2014 Erik Johnson <erik@saltstack.com> - 2014.1.7-1
479- Update to bugfix release 2014.1.7
480
481* Wed Jun 11 2014 Erik Johnson <erik@saltstack.com> - 2014.1.5-1
482- Update to bugfix release 2014.1.5
483
484* Tue May  6 2014 Erik Johnson <erik@saltstack.com> - 2014.1.4-1
485- Update to bugfix release 2014.1.4
486
487* Thu Feb 20 2014 Erik Johnson <erik@saltstack.com> - 2014.1.0-1
488- Update to feature release 2014.1.0
489
490* Mon Jan 27 2014 Erik Johnson <erik@saltstack.com> - 0.17.5-1
491- Update to bugfix release 0.17.5
492
493* Thu Dec 19 2013 Erik Johnson <erik@saltstack.com> - 0.17.4-1
494- Update to bugfix release 0.17.4
495
496* Tue Nov 19 2013 Erik Johnson <erik@saltstack.com> - 0.17.2-2
497- Patched to fix pkgrepo.managed regression
498
499* Mon Nov 18 2013 Erik Johnson <erik@saltstack.com> - 0.17.2-1
500- Update to bugfix release 0.17.2
501
502* Thu Oct 17 2013 Erik Johnson <erik@saltstack.com> - 0.17.1-1
503- Update to bugfix release 0.17.1
504
505* Thu Sep 26 2013 Erik Johnson <erik@saltstack.com> - 0.17.0-1
506- Update to feature release 0.17.0
507
508* Wed Sep 11 2013 David Anderson <dave@dubkat.com>
509- Change sourcing order of init functions and salt default file
510
511* Sat Sep 07 2013 Erik Johnson <erik@saltstack.com> - 0.16.4-1
512- Update to patch release 0.16.4
513
514* Sun Aug 25 2013 Florian La Roche <Florian.LaRoche@gmx.net>
515- fixed preun/postun scripts for salt-minion
516
517* Thu Aug 15 2013 Andrew Niemantsverdriet <andrewniemants@gmail.com> - 0.16.3-1
518- Update to patch release 0.16.3
519
520* Thu Aug 8 2013 Clint Savage <herlo1@gmail.com> - 0.16.2-1
521- Update to patch release 0.16.2
522
523* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16.0-2
524- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
525
526* Tue Jul 9 2013 Clint Savage <herlo1@gmail.com> - 0.16.0-1
527- Update to feature release 0.16.0
528
529* Sat Jun 1 2013 Clint Savage <herlo1@gmail.com> - 0.15.3-1
530- Update to patch release 0.15.3
531- Removed OrderedDict patch
532
533* Fri May 31 2013 Clint Savage <herlo1@gmail.com> - 0.15.2-1
534- Update to patch release 0.15.2
535- Patch OrderedDict for failed tests (SaltStack#4912)
536
537* Wed May 8 2013 Clint Savage <herlo1@gmail.com> - 0.15.1-1
538- Update to patch release 0.15.1
539
540* Sat May 4 2013 Clint Savage <herlo1@gmail.com> - 0.15.0-1
541- Update to upstream feature release 0.15.0
542
543* Fri Apr 19 2013 Clint Savage <herlo1@gmail.com> - 0.14.1-1
544- Update to upstream patch release 0.14.1
545
546* Sat Mar 23 2013 Clint Savage <herlo1@gmail.com> - 0.14.0-1
547- Update to upstream feature release 0.14.0
548
549* Fri Mar 22 2013 Clint Savage <herlo1@gmail.com> - 0.13.3-1
550- Update to upstream patch release 0.13.3
551
552* Wed Mar 13 2013 Clint Savage <herlo1@gmail.com> - 0.13.2-1
553- Update to upstream patch release 0.13.2
554
555* Fri Feb 15 2013 Clint Savage <herlo1@gmail.com> - 0.13.1-1
556- Update to upstream patch release 0.13.1
557- Add unittest support
558
559* Sat Feb 02 2013 Clint Savage <herlo1@gmail.com> - 0.12.1-1
560- Remove patches and update to upstream patch release 0.12.1
561
562* Thu Jan 17 2013 Wendall Cada <wendallc@83864.com> - 0.12.0-2
563- Added unittest support
564
565* Wed Jan 16 2013 Clint Savage <herlo1@gmail.com> - 0.12.0-1
566- Upstream release 0.12.0
567
568* Fri Dec 14 2012 Clint Savage <herlo1@gmail.com> - 0.11.1-1
569- Upstream patch release 0.11.1
570- Fixes security vulnerability (https://github.com/saltstack/salt/issues/2916)
571
572* Fri Dec 14 2012 Clint Savage <herlo1@gmail.com> - 0.11.0-1
573- Moved to upstream release 0.11.0
574
575* Wed Dec 05 2012 Mike Chesnut <mchesnut@gmail.com> - 0.10.5-2
576- moved to upstream release 0.10.5
577- removing references to minion.template and master.template, as those files
578  have been removed from the repo
579
580* Sun Nov 18 2012 Clint Savage <herlo1@gmail.com> - 0.10.5-1
581- Moved to upstream release 0.10.5
582- Added pciutils as Requires
583
584* Wed Oct 24 2012 Clint Savage <herlo1@gmail.com> - 0.10.4-1
585- Moved to upstream release 0.10.4
586- Patched jcollie/systemd-service-status (SALT@GH#2335) (RHBZ#869669)
587
588* Tue Oct 2 2012 Clint Savage <herlo1@gmail.com> - 0.10.3-1
589- Moved to upstream release 0.10.3
590- Added systemd scriplets (RHBZ#850408)
591
592* Thu Aug 2 2012 Clint Savage <herlo1@gmail.com> - 0.10.2-2
593- Fix upstream bug #1730 per RHBZ#845295
594
595* Tue Jul 31 2012 Clint Savage <herlo1@gmail.com> - 0.10.2-1
596- Moved to upstream release 0.10.2
597- Removed PyXML as a dependency
598
599* Sat Jun 16 2012 Clint Savage <herlo1@gmail.com> - 0.10.1-1
600- Moved to upstream release 0.10.1
601
602* Sat Apr 28 2012 Clint Savage <herlo1@gmail.com> - 0.9.9.1-1
603- Moved to upstream release 0.9.9.1
604
605* Tue Apr 17 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 0.9.8-2
606- dmidecode is x86 only
607
608* Wed Mar 21 2012 Clint Savage <herlo1@gmail.com> - 0.9.8-1
609- Moved to upstream release 0.9.8
610
611* Thu Mar 8 2012 Clint Savage <herlo1@gmail.com> - 0.9.7-2
612- Added dmidecode as a Requires
613
614* Thu Feb 16 2012 Clint Savage <herlo1@gmail.com> - 0.9.7-1
615- Moved to upstream release 0.9.7
616
617* Tue Jan 24 2012 Clint Savage <herlo1@gmail.com> - 0.9.6-2
618- Added README.fedora and removed deps for optional modules
619
620* Sat Jan 21 2012 Clint Savage <herlo1@gmail.com> - 0.9.6-1
621- New upstream release
622
623* Sun Jan 8 2012 Clint Savage <herlo1@gmail.com> - 0.9.4-6
624- Missed some critical elements for SysV and rpmlint cleanup
625
626* Sun Jan 8 2012 Clint Savage <herlo1@gmail.com> - 0.9.4-5
627- SysV clean up in post
628
629* Sat Jan 7 2012 Clint Savage <herlo1@gmail.com> - 0.9.4-4
630- Cleaning up perms, group and descriptions, adding post scripts for systemd
631
632* Thu Jan 5 2012 Clint Savage <herlo1@gmail.com> - 0.9.4-3
633- Updating for systemd on Fedora 15+
634
635* Thu Dec 1 2011 Clint Savage <herlo1@gmail.com> - 0.9.4-2
636- Removing requirement for Cython. Optional only for salt-minion
637
638* Wed Nov 30 2011 Clint Savage <herlo1@gmail.com> - 0.9.4-1
639- New upstream release with new features and bugfixes
640
641* Thu Nov 17 2011 Clint Savage <herlo1@gmail.com> - 0.9.3-1
642- New upstream release with new features and bugfixes
643
644* Sat Sep 17 2011 Clint Savage <herlo1@gmail.com> - 0.9.2-1
645- Bugfix release from upstream to fix python2.6 issues
646
647* Fri Sep 09 2011 Clint Savage <herlo1@gmail.com> - 0.9.1-1
648- Initial packages
649