1#
2# Sccsid @(#)heirloom-doctools.spec	1.18 (gritter) 3/20/07
3#
4Summary: The Heirloom Documentation Tools.
5Name: heirloom-doctools
6Version: 000000
7Release: 1
8License: Other
9Source: %{name}-%{version}.tar.bz2
10Group: System Environment/Base
11Vendor: Gunnar Ritter <gunnarr@acm.org>
12URL: <http://heirloom.sourceforge.net>
13BuildRoot: %{_tmppath}/%{name}-root
14BuildRequires: heirloom-devtools
15
16%define	bindir		/usr/ucb
17%define	mandir		/usr/share/man/5man
18%define	libdir		/usr/ucblib
19%define	docdir		%{libdir}/doctools
20%define	macdir		%{docdir}/tmac
21%define	fntdir		%{docdir}/font
22%define	tabdir		%{docdir}/nterm
23%define	hypdir		%{docdir}/hyphen
24%define	pstdir		%{docdir}/font/devpost/postscript
25%define	refdir		%{libdir}/reftools
26%define	pubdir		/usr/pub
27
28%define	xcc		gcc
29%define	ccc		g++
30%define	cflags		'-O -fomit-frame-pointer'
31%define	cppflags	'-D__NO_STRING_INLINES -D_GNU_SOURCE'
32%define	yacc		/usr/ccs/bin/yacc
33%define	lex		/usr/ccs/bin/lex
34
35#
36# Combine the settings defined above.
37#
38%define	makeflags	ROOT=%{buildroot} INSTALL=install YACC=%{yacc} LEX=%{lex} MACDIR=%{macdir} FNTDIR=%{fntdir} TABDIR=%{tabdir} HYPDIR=%{hypdir} PUBDIR=%{pubdir} BINDIR=%{bindir} PSTDIR=%{pstdir} LIBDIR=%{libdir} REFDIR=%{refdir} MANDIR=%{mandir} CC=%{xcc} CCC=%{ccc} CFLAGS=%{cflags} CPPFLAGS=%{cppflags}
39
40%description
41The Heirloom Documentation Tools provide troff, nroff, and related
42utilities to format manual pages and other documents for output on
43terminals and printers. They are portable and enhanced versions of
44the respective OpenSolaris utilities, which descend to ditroff and
45the historical Unix troff. troff provides advanced typographical
46features such as kerning, tracking, and hanging characters. It can
47access PostScript Type 1, OpenType, and TrueType fonts directly.
48Internationalized hyphenation, international paper sizes, and UTF-8
49input are supported.
50
51%prep
52rm -rf %{buildroot}
53%setup
54
55%build
56make %{makeflags}
57
58%install
59make %{makeflags} install
60
61rm -f filelist.rpm
62for f in %{bindir} %{macdir} %{fntdir} %{tabdir} %{hypdir} %{pstdir} %{pubdir} \
63	%{libdir} %{refdir}
64do
65	if test -d %{buildroot}/$f
66	then
67		(cd %{buildroot}/$f; find * -type f -o -type l) | sed "s:^:$f/:"
68	else
69		echo $f
70	fi
71done | sort -u | sed '
72	1i\
73%defattr(-,root,root)\
74%{mandir}\
75%doc README CHANGES LICENSE/*
76' >filelist.rpm
77
78%clean
79cd .. && rm -rf %{_builddir}/%{name}-%{version}
80rm -rf %{buildroot}
81
82%files -f filelist.rpm
83