1# This file defines Nix-expression accessible via `nix-shell` and `nix-build`
2# commands. Search NixOS for details.
3
4{ pkgs ?  import <nixpkgs> {} } :
5
6pkgs.stdenv.mkDerivation {
7  src = builtins.filterSource (path: type: type != "directory" || baseNameOf path != "build") ./.;
8  name = "xkb-switch-env";
9  buildInputs = (with pkgs; with xorg; [ cmake libX11 libxkbfile ]);
10}
11