xref: /freebsd/contrib/byacc/package/debian/rules (revision 2b833162)
1#!/usr/bin/make -f
2
3# Uncomment this to turn on verbose mode.
4#export DH_VERBOSE=1
5
6export DEB_BUILD_MAINT_OPTIONS := hardening=+all qa=+bug reproducible=+all
7
8%:
9	dh $@
10
11# dh_autoreconf interferes with portability -- skip it
12override_dh_autoreconf:
13	echo "skip: dh_autoreconf autoreconf-dickey -- -f -i"
14
15override_dh_auto_configure:
16	dh_auto_configure -- \
17		--enable-warnings \
18		--verbose \
19		--enable-stdnoreturn \
20		--enable-btyacc \
21		--with-max-table-size=123456 \
22		--program-transform-name='s,^yacc,byacc2,'
23
24	# workaround for whatis
25	sed -i '/- an LALR/s,^..N,byacc2,' yacc.1
26
27	# omit tests which rely upon getopt error-messages
28	sed -i.bak '/MYFILE=nosuchfile/,/# Test special cases/d' test/run_test.sh
29	diff -u test/run_test.sh.bak test/run_test.sh || echo OK
30