xref: /freebsd/contrib/dialog/package/dialog.spec (revision 9768746b)
1Summary: dialog - display dialog boxes from shell scripts
2%define AppProgram dialog
3%define AppVersion 1.3
4%define AppRelease 20210117
5%define ActualProg c%{AppProgram}
6# $XTermId: dialog.spec,v 1.146 2021/01/16 16:21:23 tom Exp $
7Name: %{ActualProg}
8Version: %{AppVersion}
9Release: %{AppRelease}
10License: LGPL
11Group: Applications/System
12URL: ftp://ftp.invisible-island.net/%{AppProgram}
13Source0: %{AppProgram}-%{AppVersion}-%{AppRelease}.tgz
14Packager: Thomas Dickey <dickey@invisible-island.net>
15
16%package	devel
17Summary:	Development headers/library for the dialog package.
18Requires:	%{ActualProg}, ncurses-devel
19
20%description
21Dialog is a program that will let you present a variety of questions or
22display messages using dialog boxes from a shell script.  These types
23of dialog boxes are implemented (though not all are necessarily compiled
24into dialog):
25
26     buildlist, calendar, checklist, dselect, editbox, form, fselect,
27     gauge, infobox, inputbox, inputmenu, menu, mixedform,
28     mixedgauge, msgbox (message), passwordbox, passwordform, pause,
29     prgbox, programbox, progressbox, radiolist, rangebox, tailbox,
30     tailboxbg, textbox, timebox, treeview, and yesno (yes/no).
31
32This package installs as "cdialog" to avoid conflict with other packages.
33
34%description devel
35This is the development package "cdialog", which includes the header files,
36the linkage information and library documentation.
37%prep
38
39%define debug_package %{nil}
40
41%setup -q -n %{AppProgram}-%{AppVersion}-%{AppRelease}
42
43%build
44
45cp -v package/dialog.map package/%{ActualProg}.map
46
47INSTALL_PROGRAM='${INSTALL}' \
48%configure \
49  --target %{_target_platform} \
50  --prefix=%{_prefix} \
51  --bindir=%{_bindir} \
52  --libdir=%{_libdir} \
53  --mandir=%{_mandir} \
54  --with-package=%{ActualProg} \
55  --enable-header-subdir \
56  --enable-nls \
57  --enable-widec \
58  --with-shared \
59  --with-ncursesw \
60  --with-versioned-syms \
61  --disable-rpath-hack
62
63make
64
65%install
66[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
67
68make install      DESTDIR=$RPM_BUILD_ROOT
69make install-full DESTDIR=$RPM_BUILD_ROOT
70
71strip $RPM_BUILD_ROOT%{_bindir}/%{ActualProg}
72chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib%{ActualProg}.so.*
73
74%clean
75[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
76
77%files
78%defattr(-,root,root)
79%{_bindir}/%{ActualProg}
80%{_mandir}/man1/%{ActualProg}.*
81%{_libdir}/lib%{ActualProg}.so.*
82%{_datadir}/locale/*/LC_MESSAGES/%{ActualProg}.mo
83
84%files devel
85%defattr(-,root,root)
86%{_bindir}/%{ActualProg}-config
87%{_includedir}/%{ActualProg}.h
88%{_includedir}/%{ActualProg}/dlg_colors.h
89%{_includedir}/%{ActualProg}/dlg_config.h
90%{_includedir}/%{ActualProg}/dlg_keys.h
91%{_libdir}/lib%{ActualProg}.so
92%{_mandir}/man3/%{ActualProg}.*
93
94%changelog
95# each patch should add its ChangeLog entries here
96
97* Wed Jul 24 2019 Thomas Dickey
98- split-out "-devel" package
99
100* Sat Dec 09 2017 Thomas Dickey
101- update ftp url
102
103* Thu Apr 21 2016 Thomas Dickey
104- remove stray call to libtool
105
106* Tue Oct 18 2011 Thomas Dickey
107- add executable permissions for shared libraries, discard ".la" file.
108
109* Thu Dec 30 2010 Thomas Dickey
110- initial version
111