1%global ver 9.6p1
2%global rel 1%{?dist}
3
4# OpenSSH privilege separation requires a user & group ID
5%global sshd_uid    74
6%global sshd_gid    74
7
8# Version of ssh-askpass
9%global aversion 1.2.4.1
10
11# Do we want to disable building of x11-askpass? (1=yes 0=no)
12%global no_x11_askpass 0
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%global no_gnome_askpass 0
16
17# Do we want to link against a static libcrypto? (1=yes 0=no)
18%global static_libcrypto 0
19
20# Do we want smartcard support (1=yes 0=no)
21%global scard 0
22
23# Use GTK2 instead of GNOME in gnome-ssh-askpass
24%global gtk2 1
25
26# Use build6x options for older RHEL builds
27# RHEL 7 not yet supported
28%if 0%{?rhel} > 6
29%global build6x 0
30%else
31%global build6x 1
32%endif
33
34%global without_openssl 0
35# build without openssl where 1.1.1 is not available
36%if 0%{?fedora} <= 28
37%global without_openssl 1
38%endif
39%if 0%{?rhel} <= 7
40%global without_openssl 1
41%endif
42
43# Do we want kerberos5 support (1=yes 0=no)
44%global kerberos5 1
45
46# Reserve options to override askpass settings with:
47# rpm -ba|--rebuild --define 'skip_xxx 1'
48%{?skip_x11_askpass:%global no_x11_askpass 1}
49%{?skip_gnome_askpass:%global no_gnome_askpass 1}
50
51# Add option to build without GTK2 for older platforms with only GTK+.
52# RedHat <= 7.2 and Red Hat Advanced Server 2.1 are examples.
53# rpm -ba|--rebuild --define 'no_gtk2 1'
54%{?no_gtk2:%global gtk2 0}
55
56# Is this a build for RHL 6.x or earlier?
57%{?build_6x:%global build6x 1}
58
59# If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
60%if %{build6x}
61%global _sysconfdir /etc
62%endif
63
64# Options for static OpenSSL link:
65# rpm -ba|--rebuild --define "static_openssl 1"
66%{?static_openssl:%global static_libcrypto 1}
67
68# Options for Smartcard support: (needs libsectok and openssl-engine)
69# rpm -ba|--rebuild --define "smartcard 1"
70%{?smartcard:%global scard 1}
71
72# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
73%global rescue 0
74%{?build_rescue:%global rescue 1}
75
76# Turn off some stuff for resuce builds
77%if %{rescue}
78%global kerberos5 0
79%endif
80
81Summary: The OpenSSH implementation of SSH protocol version 2.
82Name: openssh
83Version: %{ver}
84%if %{rescue}
85Release: %{rel}rescue
86%else
87Release: %{rel}
88%endif
89URL: https://www.openssh.com/portable.html
90Source0: https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
91Source1: http://www.jmknoble.net/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
92License: BSD
93Group: Applications/Internet
94BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
95Obsoletes: ssh
96%if %{build6x}
97PreReq: initscripts >= 5.00
98%else
99Requires: initscripts >= 5.20
100%endif
101BuildRequires: perl
102%if ! %{without_openssl}
103BuildRequires: openssl-devel >= 1.1.1
104%endif
105BuildRequires: /bin/login
106%if ! %{build6x}
107BuildRequires: glibc-devel, pam
108%else
109BuildRequires: /usr/include/security/pam_appl.h
110%endif
111%if ! %{no_x11_askpass}
112BuildRequires: /usr/include/X11/Xlib.h
113# Xt development tools
114BuildRequires: libXt-devel
115# Provides xmkmf
116BuildRequires: imake
117# Rely on relatively recent gtk
118BuildRequires: gtk2-devel
119%endif
120%if ! %{no_gnome_askpass}
121BuildRequires: pkgconfig
122%endif
123%if %{kerberos5}
124BuildRequires: krb5-devel
125BuildRequires: krb5-libs
126%endif
127
128%package clients
129Summary: OpenSSH clients.
130Requires: openssh = %{version}-%{release}
131Group: Applications/Internet
132Obsoletes: ssh-clients
133
134%package server
135Summary: The OpenSSH server daemon.
136Group: System Environment/Daemons
137Obsoletes: ssh-server
138Requires: openssh = %{version}-%{release}, chkconfig >= 0.9
139%if ! %{build6x}
140Requires: /etc/pam.d/system-auth
141%endif
142
143%package askpass
144Summary: A passphrase dialog for OpenSSH and X.
145Group: Applications/Internet
146Requires: openssh = %{version}-%{release}
147Obsoletes: ssh-extras
148
149%package askpass-gnome
150Summary: A passphrase dialog for OpenSSH, X, and GNOME.
151Group: Applications/Internet
152Requires: openssh = %{version}-%{release}
153Obsoletes: ssh-extras
154
155%description
156SSH (Secure SHell) is a program for logging into and executing
157commands on a remote machine. SSH is intended to replace rlogin and
158rsh, and to provide secure encrypted communications between two
159untrusted hosts over an insecure network. X11 connections and
160arbitrary TCP/IP ports can also be forwarded over the secure channel.
161
162OpenSSH is OpenBSD's version of the last free version of SSH, bringing
163it up to date in terms of security and features, as well as removing
164all patented algorithms to separate libraries.
165
166This package includes the core files necessary for both the OpenSSH
167client and server. To make this package useful, you should also
168install openssh-clients, openssh-server, or both.
169
170%description clients
171OpenSSH is a free version of SSH (Secure SHell), a program for logging
172into and executing commands on a remote machine. This package includes
173the clients necessary to make encrypted connections to SSH servers.
174You'll also need to install the openssh package on OpenSSH clients.
175
176%description server
177OpenSSH is a free version of SSH (Secure SHell), a program for logging
178into and executing commands on a remote machine. This package contains
179the secure shell daemon (sshd). The sshd daemon allows SSH clients to
180securely connect to your SSH server. You also need to have the openssh
181package installed.
182
183%description askpass
184OpenSSH is a free version of SSH (Secure SHell), a program for logging
185into and executing commands on a remote machine. This package contains
186an X11 passphrase dialog for OpenSSH.
187
188%description askpass-gnome
189OpenSSH is a free version of SSH (Secure SHell), a program for logging
190into and executing commands on a remote machine. This package contains
191an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
192environment.
193
194%prep
195
196%if ! %{no_x11_askpass}
197%setup -q -a 1
198%else
199%setup -q
200%endif
201
202%build
203%if %{rescue}
204CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
205%endif
206
207%configure \
208	--sysconfdir=%{_sysconfdir}/ssh \
209	--libexecdir=%{_libexecdir}/openssh \
210	--datadir=%{_datadir}/openssh \
211	--with-default-path=/usr/local/bin:/bin:/usr/bin \
212	--with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
213	--with-privsep-path=%{_var}/empty/sshd \
214	--mandir=%{_mandir} \
215	--with-mantype=man \
216	--disable-strip \
217%if %{without_openssl}
218	--without-openssl \
219%endif
220%if %{scard}
221	--with-smartcard \
222%endif
223%if %{rescue}
224	--without-pam \
225%else
226	--with-pam \
227%endif
228%if %{kerberos5}
229	 --with-kerberos5=$K5DIR \
230%endif
231
232
233%if %{static_libcrypto}
234perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
235%endif
236
237make
238
239%if ! %{no_x11_askpass}
240pushd x11-ssh-askpass-%{aversion}
241%configure --libexecdir=%{_libexecdir}/openssh
242xmkmf -a
243make
244popd
245%endif
246
247# Define a variable to toggle gnome1/gtk2 building.  This is necessary
248# because RPM doesn't handle nested %if statements.
249%if %{gtk2}
250	gtk2=yes
251%else
252	gtk2=no
253%endif
254
255%if ! %{no_gnome_askpass}
256pushd contrib
257if [ $gtk2 = yes ] ; then
258	make gnome-ssh-askpass2
259	mv gnome-ssh-askpass2 gnome-ssh-askpass
260else
261	make gnome-ssh-askpass1
262	mv gnome-ssh-askpass1 gnome-ssh-askpass
263fi
264popd
265%endif
266
267%install
268rm -rf $RPM_BUILD_ROOT
269mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
270mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
271mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
272
273make install DESTDIR=$RPM_BUILD_ROOT
274
275install -d $RPM_BUILD_ROOT/etc/pam.d/
276install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
277install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
278install -m644 contrib/redhat/sshd.pam  $RPM_BUILD_ROOT/etc/pam.d/sshd
279install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
280
281%if ! %{no_x11_askpass}
282install x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
283ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
284%endif
285
286%if ! %{no_gnome_askpass}
287install contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
288%endif
289
290%if ! %{scard}
291	 rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
292%endif
293
294%if ! %{no_gnome_askpass}
295install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
296install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
297install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
298%endif
299
300perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
301
302%clean
303rm -rf $RPM_BUILD_ROOT
304
305%triggerun server -- ssh-server
306if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
307	touch /var/run/sshd.restart
308fi
309
310%triggerun server -- openssh-server < 2.5.0p1
311# Count the number of HostKey and HostDsaKey statements we have.
312gawk	'BEGIN {IGNORECASE=1}
313	 /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
314	 END {exit sawhostkey}' /etc/ssh/sshd_config
315# And if we only found one, we know the client was relying on the old default
316# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
317# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
318# one nullifies the default, which would have loaded both.
319if [ $? -eq 1 ] ; then
320	echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
321	echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
322fi
323
324%triggerpostun server -- ssh-server
325if [ "$1" != 0 ] ; then
326	/sbin/chkconfig --add sshd
327	if test -f /var/run/sshd.restart ; then
328		rm -f /var/run/sshd.restart
329		/sbin/service sshd start > /dev/null 2>&1 || :
330	fi
331fi
332
333%pre server
334%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
335%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
336	-g sshd -M -r sshd 2>/dev/null || :
337
338%post server
339/sbin/chkconfig --add sshd
340
341%postun server
342/sbin/service sshd condrestart > /dev/null 2>&1 || :
343
344%preun server
345if [ "$1" = 0 ]
346then
347	/sbin/service sshd stop > /dev/null 2>&1 || :
348	/sbin/chkconfig --del sshd
349fi
350
351%files
352%defattr(-,root,root)
353%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* PROTOCOL* TODO
354%attr(0755,root,root) %{_bindir}/scp
355%attr(0644,root,root) %{_mandir}/man1/scp.1*
356%attr(0755,root,root) %dir %{_sysconfdir}/ssh
357%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
358%if ! %{rescue}
359%attr(0755,root,root) %{_bindir}/ssh-keygen
360%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
361%attr(0755,root,root) %dir %{_libexecdir}/openssh
362%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
363%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
364%attr(0755,root,root) %{_libexecdir}/openssh/ssh-sk-helper
365%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
366%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
367%attr(0644,root,root) %{_mandir}/man8/ssh-sk-helper.8*
368%endif
369%if %{scard}
370%attr(0755,root,root) %dir %{_datadir}/openssh
371%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
372%endif
373
374%files clients
375%defattr(-,root,root)
376%attr(0755,root,root) %{_bindir}/ssh
377%attr(0644,root,root) %{_mandir}/man1/ssh.1*
378%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
379%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
380%if ! %{rescue}
381%attr(2755,root,nobody) %{_bindir}/ssh-agent
382%attr(0755,root,root) %{_bindir}/ssh-add
383%attr(0755,root,root) %{_bindir}/ssh-keyscan
384%attr(0755,root,root) %{_bindir}/sftp
385%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
386%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
387%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
388%attr(0644,root,root) %{_mandir}/man1/sftp.1*
389%endif
390
391%if ! %{rescue}
392%files server
393%defattr(-,root,root)
394%dir %attr(0111,root,root) %{_var}/empty/sshd
395%attr(0755,root,root) %{_sbindir}/sshd
396%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
397%attr(0644,root,root) %{_mandir}/man8/sshd.8*
398%attr(0644,root,root) %{_mandir}/man5/moduli.5*
399%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
400%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
401%attr(0755,root,root) %dir %{_sysconfdir}/ssh
402%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
403%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
404%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
405%endif
406
407%if ! %{no_x11_askpass}
408%files askpass
409%defattr(-,root,root)
410%doc x11-ssh-askpass-%{aversion}/README
411%doc x11-ssh-askpass-%{aversion}/ChangeLog
412%doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
413%{_libexecdir}/openssh/ssh-askpass
414%attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
415%endif
416
417%if ! %{no_gnome_askpass}
418%files askpass-gnome
419%defattr(-,root,root)
420%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
421%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
422%endif
423
424%changelog
425* Mon Oct 16 2023 Fabio Pedretti <pedretti.fabio@gmail.com>
426- Remove reference of dropped sshd.pam.old file
427- Update openssl-devel dependency to require >= 1.1.1
428- Build with --without-openssl elsewhere
429
430* Thu Oct 28 2021 Damien Miller <djm@mindrot.org>
431- Remove remaining traces of --with-md5-passwords
432
433* Mon Jul 20 2020 Damien Miller <djm@mindrot.org>
434- Add ssh-sk-helper and corresponding manual page.
435
436* Sat Feb 10 2018 Darren Tucker <dtucker@dtucker.net>
437- Update openssl-devel dependency to match current requirements.
438- Handle Fedora >=6 openssl 1.0 compat libs.
439- Remove SSH1 from description.
440- Don't strip binaries at build time so that debuginfo package can be
441  created.
442
443* Sun Nov 16 2014 Nico Kadel-Garcia <nakdel@gmail.com>
444- Add '--mandir' and '--with-mantype' for RHEL 5 compatibility
445- Add 'dist' option to 'ver' so package names reflect OS at build time
446- Always include x11-ssh-askpass tarball in SRPM
447- Add openssh-x11-aspass BuildRequires for libXT-devel, imake, gtk2-devel
448- Discard 'K5DIR' reporting, not usable inside 'mock' for RHEL 5 compatibility
449- Discard obsolete '--with-rsh' configure option
450- Update openssl-devel dependency to 0.9.8f, as found in autoconf
451
452* Wed Jul 14 2010 Tim Rice <tim@multitalents.net>
453- test for skip_x11_askpass (line 77) should have been for no_x11_askpass
454
455* Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
456- Remove noip6 option. This may be controlled at run-time in client config
457  file using new AddressFamily directive
458
459* Mon May 12 2003 Damien Miller <djm@mindrot.org>
460- Don't install profile.d scripts when not building with GNOME/GTK askpass
461  (patch from bet@rahul.net)
462
463* Tue Oct 01 2002 Damien Miller <djm@mindrot.org>
464- Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
465
466* Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
467- Use contrib/ Makefile for building askpass programs
468
469* Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
470- Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
471- Add new {ssh,sshd}_config.5 manpages
472- Add new ssh-keysign program and remove setuid from ssh client
473
474* Fri May 10 2002 Damien Miller <djm@mindrot.org>
475- Merge in spec changes from RedHat, reorgansie a little
476- Add Privsep user, group and directory
477
478* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
479- bump and grind (through the build system)
480
481* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
482- require sharutils for building (mindrot #137)
483- require db1-devel only when building for 6.x (#55105), which probably won't
484  work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
485- require pam-devel by file (not by package name) again
486- add Markus's patch to compile with OpenSSL 0.9.5a (from
487  http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
488  building for 6.x
489
490* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
491- update to 3.1p1
492
493* Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
494- update to SNAP-20020305
495- drop debug patch, fixed upstream
496
497* Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
498- update to SNAP-20020220 for testing purposes (you've been warned, if there's
499  anything to be warned about, gss patches won't apply, I don't mind)
500
501* Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
502- add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
503  exchange, authentication, and named key support
504
505* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
506- remove dependency on db1-devel, which has just been swallowed up whole
507  by gnome-libs-devel
508
509* Sat Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
510- adjust build dependencies so that build6x actually works right (fix
511  from Hugo van der Kooij)
512
513* Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
514- update to 3.0.2p1
515
516* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
517- update to 3.0.1p1
518
519* Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
520- update to current CVS (not for use in distribution)
521
522* Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
523- merge some of Damien Miller <djm@mindrot.org> changes from the upstream
524  3.0p1 spec file and init script
525
526* Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
527- update to 3.0p1
528- update to x11-ssh-askpass 1.2.4.1
529- change build dependency on a file from pam-devel to the pam-devel package
530- replace primes with moduli
531
532* Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
533- incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
534
535* Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
536- Merge changes to rescue build from current sysadmin survival cd
537
538* Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
539- fix scp's server's reporting of file sizes, and build with the proper
540  preprocessor define to get large-file capable open(), stat(), etc.
541  (sftp has been doing this correctly all along) (#51827)
542- configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
543- pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
544- mark profile.d scriptlets as config files (#42337)
545- refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
546- change a couple of log() statements to debug() statements (#50751)
547- pull cvs patch to add -t flag to sshd (#28611)
548- clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
549
550* Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
551- add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
552
553* Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
554- pull cvs patch to fix remote port forwarding with protocol 2
555
556* Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
557- pull cvs patch to add session initialization to no-pty sessions
558- pull cvs patch to not cut off challengeresponse auth needlessly
559- refuse to do X11 forwarding if xauth isn't there, handy if you enable
560  it by default on a system that doesn't have X installed (#49263)
561
562* Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
563- don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
564
565* Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
566- pass OPTIONS correctly to initlog (#50151)
567
568* Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
569- switch to x11-ssh-askpass 1.2.2
570
571* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
572- rebuild in new environment
573
574* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
575- disable the gssapi patch
576
577* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
578- update to 2.9p2
579- refresh to a new version of the gssapi patch
580
581* Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
582- change Copyright: BSD to License: BSD
583- add Markus Friedl's unverified patch for the cookie file deletion problem
584  so that we can verify it
585- drop patch to check if xauth is present (was folded into cookie patch)
586- don't apply gssapi patches for the errata candidate
587- clear supplemental groups list at startup
588
589* Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
590- fix an error parsing the new default sshd_config
591- add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
592  dealing with comments right
593
594* Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
595- add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
596  to be removed before the next beta cycle because it's a big departure
597  from the upstream version
598
599* Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
600- finish marking strings in the init script for translation
601- modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
602  at startup (change merged from openssh.com init script, originally by
603  Pekka Savola)
604- refuse to do X11 forwarding if xauth isn't there, handy if you enable
605  it by default on a system that doesn't have X installed
606
607* Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
608- update to 2.9
609- drop various patches that came from or went upstream or to or from CVS
610
611* Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
612- only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
613
614* Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
615- remove explicit openssl requirement, fixes builddistro issue
616- make initscript stop() function wait until sshd really dead to avoid
617  races in condrestart
618
619* Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
620- mention that challengereponse supports PAM, so disabling password doesn't
621  limit users to pubkey and rsa auth (#34378)
622- bypass the daemon() function in the init script and call initlog directly,
623  because daemon() won't start a daemon it detects is already running (like
624  open connections)
625- require the version of openssl we had when we were built
626
627* Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
628- make do_pam_setcred() smart enough to know when to establish creds and
629  when to reinitialize them
630- add in a couple of other fixes from Damien for inclusion in the errata
631
632* Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
633- update to 2.5.2p2
634- call setcred() again after initgroups, because the "creds" could actually
635  be group memberships
636
637* Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
638- update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
639- don't enable challenge-response by default until we find a way to not
640  have too many userauth requests (we may make up to six pubkey and up to
641  three password attempts as it is)
642- remove build dependency on rsh to match openssh.com's packages more closely
643
644* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
645- remove dependency on openssl -- would need to be too precise
646
647* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
648- rebuild in new environment
649
650* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
651- Revert the patch to move pam_open_session.
652- Init script and spec file changes from Pekka Savola. (#28750)
653- Patch sftp to recognize '-o protocol' arguments. (#29540)
654
655* Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
656- Chuck the closing patch.
657- Add a trigger to add host keys for protocol 2 to the config file, now that
658  configuration file syntax requires us to specify it with HostKey if we
659  specify any other HostKey values, which we do.
660
661* Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
662- Redo patch to move pam_open_session after the server setuid()s to the user.
663- Rework the nopam patch to use be picked up by autoconf.
664
665* Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
666- Update for 2.5.1p1.
667- Add init script mods from Pekka Savola.
668- Tweak the init script to match the CVS contrib script more closely.
669- Redo patch to ssh-add to try to adding both identity and id_dsa to also try
670  adding id_rsa.
671
672* Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
673- Update for 2.5.0p1.
674- Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
675- Resync with parts of Damien Miller's openssh.spec from CVS, including
676  update of x11 askpass to 1.2.0.
677- Only require openssl (don't prereq) because we generate keys in the init
678  script now.
679
680* Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
681- Don't open a PAM session until we've forked and become the user (#25690).
682- Apply Andrew Bartlett's patch for letting pam_authenticate() know which
683  host the user is attempting a login from.
684- Resync with parts of Damien Miller's openssh.spec from CVS.
685- Don't expose KbdInt responses in debug messages (from CVS).
686- Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
687
688* Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
689- i18n-tweak to initscript.
690
691* Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
692- More gettextizing.
693- Close all files after going into daemon mode (needs more testing).
694- Extract patch from CVS to handle auth banners (in the client).
695- Extract patch from CVS to handle compat weirdness.
696
697* Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
698- Finish with the gettextizing.
699
700* Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
701- Fix a bug in auth2-pam.c (#23877)
702- Gettextize the init script.
703
704* Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
705- Incorporate a switch for using PAM configs for 6.x, just in case.
706
707* Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
708- Incorporate Bero's changes for a build specifically for rescue CDs.
709
710* Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
711- Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
712  succeeded, to allow public-key authentication after a failure with "none"
713  authentication.  (#21268)
714
715* Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
716- Update to x11-askpass 1.1.1. (#21301)
717- Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
718
719* Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
720- Merge multiple PAM text messages into subsequent prompts when possible when
721  doing keyboard-interactive authentication.
722
723* Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
724- Disable the built-in MD5 password support.  We're using PAM.
725- Take a crack at doing keyboard-interactive authentication with PAM, and
726  enable use of it in the default client configuration so that the client
727  will try it when the server disallows password authentication.
728- Build with debugging flags.  Build root policies strip all binaries anyway.
729
730* Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
731- Use DESTDIR instead of %%makeinstall.
732- Remove /usr/X11R6/bin from the path-fixing patch.
733
734* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
735- Add the primes file from the latest snapshot to the main package (#20884).
736- Add the dev package to the prereq list (#19984).
737- Remove the default path and mimic login's behavior in the server itself.
738
739* Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
740- Resync with conditional options in Damien Miller's .spec file for an errata.
741- Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
742
743* Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
744- Update to OpenSSH 2.3.0p1.
745- Update to x11-askpass 1.1.0.
746- Enable keyboard-interactive authentication.
747
748* Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
749- Update to ssh-askpass-x11 1.0.3.
750- Change authentication related messages to be private (#19966).
751
752* Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
753- Patch ssh-keygen to be able to list signatures for DSA public key files
754  it generates.
755
756* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
757- Add BuildRequires on /usr/include/security/pam_appl.h to be sure we always
758  build PAM authentication in.
759- Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
760- Clean out no-longer-used patches.
761- Patch ssh-add to try to add both identity and id_dsa, and to error only
762  when neither exists.
763
764* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
765- Update x11-askpass to 1.0.2. (#17835)
766- Add BuildRequiress for /bin/login and /usr/bin/rsh so that configure will
767  always find them in the right place. (#17909)
768- Set the default path to be the same as the one supplied by /bin/login, but
769  add /usr/X11R6/bin. (#17909)
770- Try to handle obsoletion of ssh-server more cleanly.  Package names
771  are different, but init script name isn't. (#17865)
772
773* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
774- Update to 2.2.0p1. (#17835)
775- Tweak the init script to allow proper restarting. (#18023)
776
777* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
778- Update to 20000823 snapshot.
779- Change subpackage requirements from %%{version} to %%{version}-%%{release}
780- Back out the pipe patch.
781
782* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
783- Update to 2.1.1p4, which includes fixes for config file parsing problems.
784- Move the init script back.
785- Add Damien's quick fix for wackiness.
786
787* Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
788- Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
789
790* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
791- Move condrestart to server postun.
792- Move key generation to init script.
793- Actually use the right patch for moving the key generation to the init script.
794- Clean up the init script a bit.
795
796* Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
797- Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
798
799* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
800- Update to 2.1.1p2.
801- Use of strtok() considered harmful.
802
803* Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
804- Get the build root out of the man pages.
805
806* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
807- Add and use condrestart support in the init script.
808- Add newer initscripts as a prereq.
809
810* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
811- Build in new environment (release 2)
812- Move -clients subpackage to Applications/Internet group
813
814* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
815- Update to 2.2.1p1
816
817* Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
818- Patch to build with neither RSA nor RSAref.
819- Miscellaneous FHS-compliance tweaks.
820- Fix for possibly-compressed man pages.
821
822* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
823- Updated for new location
824- Updated for new gnome-ssh-askpass build
825
826* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
827- Added Jim Knoble's <jmknoble@pobox.com> askpass
828
829* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
830- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
831
832* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
833- Added 'Obsoletes' directives
834
835* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
836- Use make install
837- Subpackages
838
839* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
840- Added links for slogin
841- Fixed perms on manpages
842
843* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
844- Renamed init script
845
846* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
847- Back to old binary names
848
849* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
850- Use autoconf
851- New binary names
852
853* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
854- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
855