1%global ver 9.2p1
2%global rel 1%{?dist}
3
4# OpenSSH privilege separation requires a user & group ID
5%global sshd_uid    74
6%global sshd_gid    74
7
8# Version of ssh-askpass
9%global aversion 1.2.4.1
10
11# Do we want to disable building of x11-askpass? (1=yes 0=no)
12%global no_x11_askpass 0
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%global no_gnome_askpass 0
16
17# Do we want to link against a static libcrypto? (1=yes 0=no)
18%global static_libcrypto 0
19
20# Do we want smartcard support (1=yes 0=no)
21%global scard 0
22
23# Use GTK2 instead of GNOME in gnome-ssh-askpass
24%global gtk2 1
25
26# Use build6x options for older RHEL builds
27# RHEL 7 not yet supported
28%if 0%{?rhel} > 6
29%global build6x 0
30%else
31%global build6x 1
32%endif
33
34%if 0%{?fedora} >= 26
35%global compat_openssl 1
36%else
37%global compat_openssl 0
38%endif
39
40# Do we want kerberos5 support (1=yes 0=no)
41%global kerberos5 1
42
43# Reserve options to override askpass settings with:
44# rpm -ba|--rebuild --define 'skip_xxx 1'
45%{?skip_x11_askpass:%global no_x11_askpass 1}
46%{?skip_gnome_askpass:%global no_gnome_askpass 1}
47
48# Add option to build without GTK2 for older platforms with only GTK+.
49# RedHat <= 7.2 and Red Hat Advanced Server 2.1 are examples.
50# rpm -ba|--rebuild --define 'no_gtk2 1'
51%{?no_gtk2:%global gtk2 0}
52
53# Is this a build for RHL 6.x or earlier?
54%{?build_6x:%global build6x 1}
55
56# If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
57%if %{build6x}
58%global _sysconfdir /etc
59%endif
60
61# Options for static OpenSSL link:
62# rpm -ba|--rebuild --define "static_openssl 1"
63%{?static_openssl:%global static_libcrypto 1}
64
65# Options for Smartcard support: (needs libsectok and openssl-engine)
66# rpm -ba|--rebuild --define "smartcard 1"
67%{?smartcard:%global scard 1}
68
69# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
70%global rescue 0
71%{?build_rescue:%global rescue 1}
72
73# Turn off some stuff for resuce builds
74%if %{rescue}
75%global kerberos5 0
76%endif
77
78Summary: The OpenSSH implementation of SSH protocol version 2.
79Name: openssh
80Version: %{ver}
81%if %{rescue}
82Release: %{rel}rescue
83%else
84Release: %{rel}
85%endif
86URL: https://www.openssh.com/portable.html
87Source0: https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
88Source1: http://www.jmknoble.net/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
89License: BSD
90Group: Applications/Internet
91BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
92Obsoletes: ssh
93%if %{build6x}
94PreReq: initscripts >= 5.00
95%else
96Requires: initscripts >= 5.20
97%endif
98BuildRequires: perl
99%if %{compat_openssl}
100BuildRequires: compat-openssl10-devel
101%else
102BuildRequires: openssl-devel >= 1.0.1
103BuildRequires: openssl-devel < 1.1
104%endif
105BuildRequires: /bin/login
106%if ! %{build6x}
107BuildRequires: glibc-devel, pam
108%else
109BuildRequires: /usr/include/security/pam_appl.h
110%endif
111%if ! %{no_x11_askpass}
112BuildRequires: /usr/include/X11/Xlib.h
113# Xt development tools
114BuildRequires: libXt-devel
115# Provides xmkmf
116BuildRequires: imake
117# Rely on relatively recent gtk
118BuildRequires: gtk2-devel
119%endif
120%if ! %{no_gnome_askpass}
121BuildRequires: pkgconfig
122%endif
123%if %{kerberos5}
124BuildRequires: krb5-devel
125BuildRequires: krb5-libs
126%endif
127
128%package clients
129Summary: OpenSSH clients.
130Requires: openssh = %{version}-%{release}
131Group: Applications/Internet
132Obsoletes: ssh-clients
133
134%package server
135Summary: The OpenSSH server daemon.
136Group: System Environment/Daemons
137Obsoletes: ssh-server
138Requires: openssh = %{version}-%{release}, chkconfig >= 0.9
139%if ! %{build6x}
140Requires: /etc/pam.d/system-auth
141%endif
142
143%package askpass
144Summary: A passphrase dialog for OpenSSH and X.
145Group: Applications/Internet
146Requires: openssh = %{version}-%{release}
147Obsoletes: ssh-extras
148
149%package askpass-gnome
150Summary: A passphrase dialog for OpenSSH, X, and GNOME.
151Group: Applications/Internet
152Requires: openssh = %{version}-%{release}
153Obsoletes: ssh-extras
154
155%description
156SSH (Secure SHell) is a program for logging into and executing
157commands on a remote machine. SSH is intended to replace rlogin and
158rsh, and to provide secure encrypted communications between two
159untrusted hosts over an insecure network. X11 connections and
160arbitrary TCP/IP ports can also be forwarded over the secure channel.
161
162OpenSSH is OpenBSD's version of the last free version of SSH, bringing
163it up to date in terms of security and features, as well as removing
164all patented algorithms to separate libraries.
165
166This package includes the core files necessary for both the OpenSSH
167client and server. To make this package useful, you should also
168install openssh-clients, openssh-server, or both.
169
170%description clients
171OpenSSH is a free version of SSH (Secure SHell), a program for logging
172into and executing commands on a remote machine. This package includes
173the clients necessary to make encrypted connections to SSH servers.
174You'll also need to install the openssh package on OpenSSH clients.
175
176%description server
177OpenSSH is a free version of SSH (Secure SHell), a program for logging
178into and executing commands on a remote machine. This package contains
179the secure shell daemon (sshd). The sshd daemon allows SSH clients to
180securely connect to your SSH server. You also need to have the openssh
181package installed.
182
183%description askpass
184OpenSSH is a free version of SSH (Secure SHell), a program for logging
185into and executing commands on a remote machine. This package contains
186an X11 passphrase dialog for OpenSSH.
187
188%description askpass-gnome
189OpenSSH is a free version of SSH (Secure SHell), a program for logging
190into and executing commands on a remote machine. This package contains
191an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
192environment.
193
194%prep
195
196%if ! %{no_x11_askpass}
197%setup -q -a 1
198%else
199%setup -q
200%endif
201
202%build
203%if %{rescue}
204CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
205%endif
206
207%configure \
208	--sysconfdir=%{_sysconfdir}/ssh \
209	--libexecdir=%{_libexecdir}/openssh \
210	--datadir=%{_datadir}/openssh \
211	--with-default-path=/usr/local/bin:/bin:/usr/bin \
212	--with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
213	--with-privsep-path=%{_var}/empty/sshd \
214	--mandir=%{_mandir} \
215	--with-mantype=man \
216	--disable-strip \
217%if %{scard}
218	--with-smartcard \
219%endif
220%if %{rescue}
221	--without-pam \
222%else
223	--with-pam \
224%endif
225%if %{kerberos5}
226	 --with-kerberos5=$K5DIR \
227%endif
228
229
230%if %{static_libcrypto}
231perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
232%endif
233
234make
235
236%if ! %{no_x11_askpass}
237pushd x11-ssh-askpass-%{aversion}
238%configure --libexecdir=%{_libexecdir}/openssh
239xmkmf -a
240make
241popd
242%endif
243
244# Define a variable to toggle gnome1/gtk2 building.  This is necessary
245# because RPM doesn't handle nested %if statements.
246%if %{gtk2}
247	gtk2=yes
248%else
249	gtk2=no
250%endif
251
252%if ! %{no_gnome_askpass}
253pushd contrib
254if [ $gtk2 = yes ] ; then
255	make gnome-ssh-askpass2
256	mv gnome-ssh-askpass2 gnome-ssh-askpass
257else
258	make gnome-ssh-askpass1
259	mv gnome-ssh-askpass1 gnome-ssh-askpass
260fi
261popd
262%endif
263
264%install
265rm -rf $RPM_BUILD_ROOT
266mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
267mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
268mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
269
270make install DESTDIR=$RPM_BUILD_ROOT
271
272install -d $RPM_BUILD_ROOT/etc/pam.d/
273install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
274install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
275%if %{build6x}
276install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
277%else
278install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
279%endif
280install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
281
282%if ! %{no_x11_askpass}
283install x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
284ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
285%endif
286
287%if ! %{no_gnome_askpass}
288install contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
289%endif
290
291%if ! %{scard}
292	 rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
293%endif
294
295%if ! %{no_gnome_askpass}
296install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
297install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
298install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
299%endif
300
301perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
302
303%clean
304rm -rf $RPM_BUILD_ROOT
305
306%triggerun server -- ssh-server
307if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
308	touch /var/run/sshd.restart
309fi
310
311%triggerun server -- openssh-server < 2.5.0p1
312# Count the number of HostKey and HostDsaKey statements we have.
313gawk	'BEGIN {IGNORECASE=1}
314	 /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
315	 END {exit sawhostkey}' /etc/ssh/sshd_config
316# And if we only found one, we know the client was relying on the old default
317# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
318# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
319# one nullifies the default, which would have loaded both.
320if [ $? -eq 1 ] ; then
321	echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
322	echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
323fi
324
325%triggerpostun server -- ssh-server
326if [ "$1" != 0 ] ; then
327	/sbin/chkconfig --add sshd
328	if test -f /var/run/sshd.restart ; then
329		rm -f /var/run/sshd.restart
330		/sbin/service sshd start > /dev/null 2>&1 || :
331	fi
332fi
333
334%pre server
335%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
336%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
337	-g sshd -M -r sshd 2>/dev/null || :
338
339%post server
340/sbin/chkconfig --add sshd
341
342%postun server
343/sbin/service sshd condrestart > /dev/null 2>&1 || :
344
345%preun server
346if [ "$1" = 0 ]
347then
348	/sbin/service sshd stop > /dev/null 2>&1 || :
349	/sbin/chkconfig --del sshd
350fi
351
352%files
353%defattr(-,root,root)
354%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* PROTOCOL* TODO
355%attr(0755,root,root) %{_bindir}/scp
356%attr(0644,root,root) %{_mandir}/man1/scp.1*
357%attr(0755,root,root) %dir %{_sysconfdir}/ssh
358%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
359%if ! %{rescue}
360%attr(0755,root,root) %{_bindir}/ssh-keygen
361%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
362%attr(0755,root,root) %dir %{_libexecdir}/openssh
363%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
364%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
365%attr(0755,root,root) %{_libexecdir}/openssh/ssh-sk-helper
366%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
367%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
368%attr(0644,root,root) %{_mandir}/man8/ssh-sk-helper.8*
369%endif
370%if %{scard}
371%attr(0755,root,root) %dir %{_datadir}/openssh
372%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
373%endif
374
375%files clients
376%defattr(-,root,root)
377%attr(0755,root,root) %{_bindir}/ssh
378%attr(0644,root,root) %{_mandir}/man1/ssh.1*
379%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
380%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
381%if ! %{rescue}
382%attr(2755,root,nobody) %{_bindir}/ssh-agent
383%attr(0755,root,root) %{_bindir}/ssh-add
384%attr(0755,root,root) %{_bindir}/ssh-keyscan
385%attr(0755,root,root) %{_bindir}/sftp
386%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
387%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
388%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
389%attr(0644,root,root) %{_mandir}/man1/sftp.1*
390%endif
391
392%if ! %{rescue}
393%files server
394%defattr(-,root,root)
395%dir %attr(0111,root,root) %{_var}/empty/sshd
396%attr(0755,root,root) %{_sbindir}/sshd
397%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
398%attr(0644,root,root) %{_mandir}/man8/sshd.8*
399%attr(0644,root,root) %{_mandir}/man5/moduli.5*
400%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
401%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
402%attr(0755,root,root) %dir %{_sysconfdir}/ssh
403%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
404%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
405%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
406%endif
407
408%if ! %{no_x11_askpass}
409%files askpass
410%defattr(-,root,root)
411%doc x11-ssh-askpass-%{aversion}/README
412%doc x11-ssh-askpass-%{aversion}/ChangeLog
413%doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
414%{_libexecdir}/openssh/ssh-askpass
415%attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
416%endif
417
418%if ! %{no_gnome_askpass}
419%files askpass-gnome
420%defattr(-,root,root)
421%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
422%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
423%endif
424
425%changelog
426* Thu Oct 28 2021 Damien Miller <djm@mindrot.org>
427- Remove remaining traces of --with-md5-passwords
428
429* Mon Jul 20 2020 Damien Miller <djm@mindrot.org>
430- Add ssh-sk-helper and corresponding manual page.
431
432* Sat Feb 10 2018 Darren Tucker <dtucker@dtucker.net>
433- Update openssl-devel dependency to match current requirements.
434- Handle Fedora >=6 openssl 1.0 compat libs.
435- Remove SSH1 from description.
436- Don't strip binaries at build time so that debuginfo package can be
437  created.
438
439* Sun Nov 16 2014 Nico Kadel-Garcia <nakdel@gmail.com>
440- Add '--mandir' and '--with-mantype' for RHEL 5 compatibility
441- Add 'dist' option to 'ver' so package names reflect OS at build time
442- Always include x11-ssh-askpass tarball in SRPM
443- Add openssh-x11-aspass BuildRequires for libXT-devel, imake, gtk2-devel
444- Discard 'K5DIR' reporting, not usable inside 'mock' for RHEL 5 compatibility
445- Discard obsolete '--with-rsh' configure option
446- Update openssl-devel dependency to 0.9.8f, as found in autoconf
447
448* Wed Jul 14 2010 Tim Rice <tim@multitalents.net>
449- test for skip_x11_askpass (line 77) should have been for no_x11_askpass
450
451* Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
452- Remove noip6 option. This may be controlled at run-time in client config
453  file using new AddressFamily directive
454
455* Mon May 12 2003 Damien Miller <djm@mindrot.org>
456- Don't install profile.d scripts when not building with GNOME/GTK askpass
457  (patch from bet@rahul.net)
458
459* Tue Oct 01 2002 Damien Miller <djm@mindrot.org>
460- Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
461
462* Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
463- Use contrib/ Makefile for building askpass programs
464
465* Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
466- Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
467- Add new {ssh,sshd}_config.5 manpages
468- Add new ssh-keysign program and remove setuid from ssh client
469
470* Fri May 10 2002 Damien Miller <djm@mindrot.org>
471- Merge in spec changes from RedHat, reorgansie a little
472- Add Privsep user, group and directory
473
474* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
475- bump and grind (through the build system)
476
477* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
478- require sharutils for building (mindrot #137)
479- require db1-devel only when building for 6.x (#55105), which probably won't
480  work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
481- require pam-devel by file (not by package name) again
482- add Markus's patch to compile with OpenSSL 0.9.5a (from
483  http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
484  building for 6.x
485
486* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
487- update to 3.1p1
488
489* Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
490- update to SNAP-20020305
491- drop debug patch, fixed upstream
492
493* Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
494- update to SNAP-20020220 for testing purposes (you've been warned, if there's
495  anything to be warned about, gss patches won't apply, I don't mind)
496
497* Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
498- add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
499  exchange, authentication, and named key support
500
501* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
502- remove dependency on db1-devel, which has just been swallowed up whole
503  by gnome-libs-devel
504
505* Sat Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
506- adjust build dependencies so that build6x actually works right (fix
507  from Hugo van der Kooij)
508
509* Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
510- update to 3.0.2p1
511
512* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
513- update to 3.0.1p1
514
515* Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
516- update to current CVS (not for use in distribution)
517
518* Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
519- merge some of Damien Miller <djm@mindrot.org> changes from the upstream
520  3.0p1 spec file and init script
521
522* Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
523- update to 3.0p1
524- update to x11-ssh-askpass 1.2.4.1
525- change build dependency on a file from pam-devel to the pam-devel package
526- replace primes with moduli
527
528* Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
529- incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
530
531* Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
532- Merge changes to rescue build from current sysadmin survival cd
533
534* Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
535- fix scp's server's reporting of file sizes, and build with the proper
536  preprocessor define to get large-file capable open(), stat(), etc.
537  (sftp has been doing this correctly all along) (#51827)
538- configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
539- pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
540- mark profile.d scriptlets as config files (#42337)
541- refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
542- change a couple of log() statements to debug() statements (#50751)
543- pull cvs patch to add -t flag to sshd (#28611)
544- clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
545
546* Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
547- add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
548
549* Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
550- pull cvs patch to fix remote port forwarding with protocol 2
551
552* Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
553- pull cvs patch to add session initialization to no-pty sessions
554- pull cvs patch to not cut off challengeresponse auth needlessly
555- refuse to do X11 forwarding if xauth isn't there, handy if you enable
556  it by default on a system that doesn't have X installed (#49263)
557
558* Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
559- don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
560
561* Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
562- pass OPTIONS correctly to initlog (#50151)
563
564* Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
565- switch to x11-ssh-askpass 1.2.2
566
567* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
568- rebuild in new environment
569
570* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
571- disable the gssapi patch
572
573* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
574- update to 2.9p2
575- refresh to a new version of the gssapi patch
576
577* Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
578- change Copyright: BSD to License: BSD
579- add Markus Friedl's unverified patch for the cookie file deletion problem
580  so that we can verify it
581- drop patch to check if xauth is present (was folded into cookie patch)
582- don't apply gssapi patches for the errata candidate
583- clear supplemental groups list at startup
584
585* Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
586- fix an error parsing the new default sshd_config
587- add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
588  dealing with comments right
589
590* Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
591- add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
592  to be removed before the next beta cycle because it's a big departure
593  from the upstream version
594
595* Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
596- finish marking strings in the init script for translation
597- modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
598  at startup (change merged from openssh.com init script, originally by
599  Pekka Savola)
600- refuse to do X11 forwarding if xauth isn't there, handy if you enable
601  it by default on a system that doesn't have X installed
602
603* Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
604- update to 2.9
605- drop various patches that came from or went upstream or to or from CVS
606
607* Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
608- only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
609
610* Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
611- remove explicit openssl requirement, fixes builddistro issue
612- make initscript stop() function wait until sshd really dead to avoid
613  races in condrestart
614
615* Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
616- mention that challengereponse supports PAM, so disabling password doesn't
617  limit users to pubkey and rsa auth (#34378)
618- bypass the daemon() function in the init script and call initlog directly,
619  because daemon() won't start a daemon it detects is already running (like
620  open connections)
621- require the version of openssl we had when we were built
622
623* Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
624- make do_pam_setcred() smart enough to know when to establish creds and
625  when to reinitialize them
626- add in a couple of other fixes from Damien for inclusion in the errata
627
628* Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
629- update to 2.5.2p2
630- call setcred() again after initgroups, because the "creds" could actually
631  be group memberships
632
633* Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
634- update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
635- don't enable challenge-response by default until we find a way to not
636  have too many userauth requests (we may make up to six pubkey and up to
637  three password attempts as it is)
638- remove build dependency on rsh to match openssh.com's packages more closely
639
640* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
641- remove dependency on openssl -- would need to be too precise
642
643* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
644- rebuild in new environment
645
646* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
647- Revert the patch to move pam_open_session.
648- Init script and spec file changes from Pekka Savola. (#28750)
649- Patch sftp to recognize '-o protocol' arguments. (#29540)
650
651* Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
652- Chuck the closing patch.
653- Add a trigger to add host keys for protocol 2 to the config file, now that
654  configuration file syntax requires us to specify it with HostKey if we
655  specify any other HostKey values, which we do.
656
657* Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
658- Redo patch to move pam_open_session after the server setuid()s to the user.
659- Rework the nopam patch to use be picked up by autoconf.
660
661* Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
662- Update for 2.5.1p1.
663- Add init script mods from Pekka Savola.
664- Tweak the init script to match the CVS contrib script more closely.
665- Redo patch to ssh-add to try to adding both identity and id_dsa to also try
666  adding id_rsa.
667
668* Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
669- Update for 2.5.0p1.
670- Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
671- Resync with parts of Damien Miller's openssh.spec from CVS, including
672  update of x11 askpass to 1.2.0.
673- Only require openssl (don't prereq) because we generate keys in the init
674  script now.
675
676* Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
677- Don't open a PAM session until we've forked and become the user (#25690).
678- Apply Andrew Bartlett's patch for letting pam_authenticate() know which
679  host the user is attempting a login from.
680- Resync with parts of Damien Miller's openssh.spec from CVS.
681- Don't expose KbdInt responses in debug messages (from CVS).
682- Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
683
684* Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
685- i18n-tweak to initscript.
686
687* Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
688- More gettextizing.
689- Close all files after going into daemon mode (needs more testing).
690- Extract patch from CVS to handle auth banners (in the client).
691- Extract patch from CVS to handle compat weirdness.
692
693* Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
694- Finish with the gettextizing.
695
696* Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
697- Fix a bug in auth2-pam.c (#23877)
698- Gettextize the init script.
699
700* Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
701- Incorporate a switch for using PAM configs for 6.x, just in case.
702
703* Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
704- Incorporate Bero's changes for a build specifically for rescue CDs.
705
706* Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
707- Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
708  succeeded, to allow public-key authentication after a failure with "none"
709  authentication.  (#21268)
710
711* Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
712- Update to x11-askpass 1.1.1. (#21301)
713- Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
714
715* Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
716- Merge multiple PAM text messages into subsequent prompts when possible when
717  doing keyboard-interactive authentication.
718
719* Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
720- Disable the built-in MD5 password support.  We're using PAM.
721- Take a crack at doing keyboard-interactive authentication with PAM, and
722  enable use of it in the default client configuration so that the client
723  will try it when the server disallows password authentication.
724- Build with debugging flags.  Build root policies strip all binaries anyway.
725
726* Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
727- Use DESTDIR instead of %%makeinstall.
728- Remove /usr/X11R6/bin from the path-fixing patch.
729
730* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
731- Add the primes file from the latest snapshot to the main package (#20884).
732- Add the dev package to the prereq list (#19984).
733- Remove the default path and mimic login's behavior in the server itself.
734
735* Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
736- Resync with conditional options in Damien Miller's .spec file for an errata.
737- Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
738
739* Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
740- Update to OpenSSH 2.3.0p1.
741- Update to x11-askpass 1.1.0.
742- Enable keyboard-interactive authentication.
743
744* Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
745- Update to ssh-askpass-x11 1.0.3.
746- Change authentication related messages to be private (#19966).
747
748* Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
749- Patch ssh-keygen to be able to list signatures for DSA public key files
750  it generates.
751
752* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
753- Add BuildRequires on /usr/include/security/pam_appl.h to be sure we always
754  build PAM authentication in.
755- Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
756- Clean out no-longer-used patches.
757- Patch ssh-add to try to add both identity and id_dsa, and to error only
758  when neither exists.
759
760* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
761- Update x11-askpass to 1.0.2. (#17835)
762- Add BuildRequiress for /bin/login and /usr/bin/rsh so that configure will
763  always find them in the right place. (#17909)
764- Set the default path to be the same as the one supplied by /bin/login, but
765  add /usr/X11R6/bin. (#17909)
766- Try to handle obsoletion of ssh-server more cleanly.  Package names
767  are different, but init script name isn't. (#17865)
768
769* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
770- Update to 2.2.0p1. (#17835)
771- Tweak the init script to allow proper restarting. (#18023)
772
773* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
774- Update to 20000823 snapshot.
775- Change subpackage requirements from %%{version} to %%{version}-%%{release}
776- Back out the pipe patch.
777
778* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
779- Update to 2.1.1p4, which includes fixes for config file parsing problems.
780- Move the init script back.
781- Add Damien's quick fix for wackiness.
782
783* Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
784- Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
785
786* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
787- Move condrestart to server postun.
788- Move key generation to init script.
789- Actually use the right patch for moving the key generation to the init script.
790- Clean up the init script a bit.
791
792* Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
793- Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
794
795* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
796- Update to 2.1.1p2.
797- Use of strtok() considered harmful.
798
799* Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
800- Get the build root out of the man pages.
801
802* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
803- Add and use condrestart support in the init script.
804- Add newer initscripts as a prereq.
805
806* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
807- Build in new environment (release 2)
808- Move -clients subpackage to Applications/Internet group
809
810* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
811- Update to 2.2.1p1
812
813* Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
814- Patch to build with neither RSA nor RSAref.
815- Miscellaneous FHS-compliance tweaks.
816- Fix for possibly-compressed man pages.
817
818* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
819- Updated for new location
820- Updated for new gnome-ssh-askpass build
821
822* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
823- Added Jim Knoble's <jmknoble@pobox.com> askpass
824
825* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
826- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
827
828* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
829- Added 'Obsoletes' directives
830
831* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
832- Use make install
833- Subpackages
834
835* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
836- Added links for slogin
837- Fixed perms on manpages
838
839* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
840- Renamed init script
841
842* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
843- Back to old binary names
844
845* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
846- Use autoconf
847- New binary names
848
849* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
850- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
851