1Source: openzfs-linux
2Section: contrib/kernel
3Priority: optional
4Maintainer: ZFS on Linux specific mailing list <zfs-discuss@list.zfsonlinux.org>
5Build-Depends: debhelper-compat (= 12),
6               dh-python,
7               dh-sequence-dkms | dkms (>> 2.1.1.2-5),
8               libaio-dev,
9               libblkid-dev,
10               libcurl4-openssl-dev,
11               libelf-dev,
12               libpam0g-dev,
13               libssl-dev | libssl1.0-dev,
14               libtool,
15               libudev-dev,
16               lsb-release,
17               po-debconf,
18               python3-all-dev,
19               python3-cffi,
20               python3-setuptools,
21               python3-sphinx,
22               uuid-dev,
23               zlib1g-dev
24Standards-Version: 4.5.1
25Homepage: https://openzfs.org/
26Vcs-Git: https://github.com/openzfs/zfs.git
27Vcs-Browser: https://github.com/openzfs/zfs
28Rules-Requires-Root: no
29XS-Autobuild: yes
30
31Package: openzfs-libnvpair3
32Section: contrib/libs
33Architecture: linux-any
34Depends: ${misc:Depends}, ${shlibs:Depends}
35Breaks: libnvpair1, libnvpair3
36Replaces: libnvpair1, libnvpair3, libnvpair3linux
37Conflicts: libnvpair3linux
38Description: Solaris name-value library for Linux
39 This library provides routines for packing and unpacking nv pairs for
40 transporting data across process boundaries, transporting between
41 kernel and userland, and possibly saving onto disk files.
42
43Package: openzfs-libpam-zfs
44Section: contrib/admin
45Architecture: linux-any
46Depends: libpam-runtime, ${misc:Depends}, ${shlibs:Depends}
47Replaces: libpam-zfs
48Conflicts: libpam-zfs
49Description: PAM module for managing encryption keys for ZFS
50 OpenZFS is a storage platform that encompasses the functionality of
51 traditional filesystems and volume managers. It supports data checksums,
52 compression, encryption, snapshots, and more.
53 .
54 This provides a Pluggable Authentication Module (PAM) that automatically
55 unlocks encrypted ZFS datasets upon login.
56
57Package: openzfs-libuutil3
58Section: contrib/libs
59Architecture: linux-any
60Depends: ${misc:Depends}, ${shlibs:Depends}
61Breaks: libuutil1, libuutil3
62Replaces: libuutil1, libuutil3, libuutil3linux
63Conflicts: libuutil3linux
64Description: Solaris userland utility library for Linux
65 This library provides a variety of glue functions for ZFS on Linux:
66  * libspl: The Solaris Porting Layer userland library, which provides APIs
67    that make it possible to run Solaris user code in a Linux environment
68    with relatively minimal modification.
69  * libavl: The Adelson-Velskii Landis balanced binary tree manipulation
70    library.
71  * libefi: The Extensible Firmware Interface library for GUID disk
72    partitioning.
73  * libshare: NFS, SMB, and iSCSI service integration for ZFS.
74
75Package: openzfs-libzfs-dev
76Section: contrib/libdevel
77Architecture: linux-any
78Depends: libssl-dev | libssl1.0-dev,
79         openzfs-libnvpair3 (= ${binary:Version}),
80         openzfs-libuutil3 (= ${binary:Version}),
81         openzfs-libzfs4 (= ${binary:Version}),
82         openzfs-libzfsbootenv1 (= ${binary:Version}),
83         openzfs-libzpool5 (= ${binary:Version}),
84         ${misc:Depends}
85Replaces: libzfslinux-dev
86Conflicts: libzfslinux-dev
87Provides: libnvpair-dev, libuutil-dev
88Description: OpenZFS filesystem development files for Linux
89 Header files and static libraries for compiling software against
90 libraries of OpenZFS filesystem.
91 .
92 This package includes the development files of libnvpair3, libuutil3,
93 libzpool5 and libzfs4.
94
95Package: openzfs-libzfs4
96Section: contrib/libs
97Architecture: linux-any
98Depends: ${misc:Depends}, ${shlibs:Depends}
99# The libcurl4 is loaded through dlopen("libcurl.so.4").
100# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=988521
101Recommends: libcurl4
102Breaks: libzfs2, libzfs4
103Replaces: libzfs2, libzfs4, libzfs4linux
104Conflicts: libzfs4linux
105Description: OpenZFS filesystem library for Linux - general support
106 OpenZFS is a storage platform that encompasses the functionality of
107 traditional filesystems and volume managers. It supports data checksums,
108 compression, encryption, snapshots, and more.
109 .
110 The OpenZFS library provides support for managing OpenZFS filesystems.
111
112Package: openzfs-libzfsbootenv1
113Section: contrib/libs
114Architecture: linux-any
115Depends: ${misc:Depends}, ${shlibs:Depends}
116Breaks: libzfs2, libzfs4
117Replaces: libzfs2, libzfs4, libzfsbootenv1linux
118Conflicts: libzfsbootenv1linux
119Description: OpenZFS filesystem library for Linux - label info support
120 OpenZFS is a storage platform that encompasses the functionality of
121 traditional filesystems and volume managers. It supports data checksums,
122 compression, encryption, snapshots, and more.
123 .
124 The zfsbootenv library provides support for modifying ZFS label information.
125
126Package: openzfs-libzpool5
127Section: contrib/libs
128Architecture: linux-any
129Depends: ${misc:Depends}, ${shlibs:Depends}
130Breaks: libzpool2, libzpool5
131Replaces: libzpool2, libzpool5, libzpool5linux
132Conflicts: libzpool5linux
133Description: OpenZFS pool library for Linux
134 OpenZFS is a storage platform that encompasses the functionality of
135 traditional filesystems and volume managers. It supports data checksums,
136 compression, encryption, snapshots, and more.
137 .
138 This zpool library provides support for managing zpools.
139
140Package: openzfs-python3-pyzfs
141Section: contrib/python
142Architecture: linux-any
143Depends: python3-cffi,
144         openzfs-zfsutils (= ${binary:Version}),
145         ${misc:Depends},
146         ${python3:Depends}
147Replaces: python3-pyzfs
148Conflicts: python3-pyzfs
149Description: wrapper for libzfs_core C library
150 libzfs_core is intended to be a stable interface for programmatic
151 administration of ZFS. This wrapper provides one-to-one wrappers for
152 libzfs_core API functions, but the signatures and types are more natural to
153 Python.
154 .
155 nvlists are wrapped as dictionaries or lists depending on their usage.
156 Some parameters have default values depending on typical use for
157 increased convenience. Enumerations and bit flags become strings and lists
158 of strings in Python. Errors are reported as exceptions rather than integer
159 errno-style error codes.  The wrapper takes care to provide one-to-many
160 mapping of the error codes to the exceptions by interpreting a context
161 in which the error code is produced.
162
163Package: openzfs-pyzfs-doc
164Section: contrib/doc
165Architecture: all
166Depends: ${misc:Depends}, ${sphinxdoc:Depends}
167Recommends: openzfs-python3-pyzfs
168Replaces: pyzfs-doc
169Conflicts: pyzfs-doc
170Description: wrapper for libzfs_core C library (documentation)
171 libzfs_core is intended to be a stable interface for programmatic
172 administration of ZFS. This wrapper provides one-to-one wrappers for
173 libzfs_core API functions, but the signatures and types are more natural to
174 Python.
175 .
176 nvlists are wrapped as dictionaries or lists depending on their usage.
177 Some parameters have default values depending on typical use for
178 increased convenience. Enumerations and bit flags become strings and lists
179 of strings in Python. Errors are reported as exceptions rather than integer
180 errno-style error codes.  The wrapper takes care to provide one-to-many
181 mapping of the error codes to the exceptions by interpreting a context
182 in which the error code is produced.
183 .
184 This package contains the documentation.
185
186Package: openzfs-zfs-dkms
187Architecture: all
188Depends: dkms (>> 2.1.1.2-5),
189         file,
190         libc6-dev | libc-dev,
191         lsb-release,
192         python3 (>> 3.12) | python3-distutils | libpython3-stdlib (<< 3.6.4),
193         ${misc:Depends},
194         ${perl:Depends}
195Recommends: openzfs-zfs-zed, openzfs-zfsutils (>= ${source:Version}), ${linux:Recommends}
196# suggests debhelper because e.g. `dkms mkdeb -m zfs -v 0.8.2` needs dh_testdir (#909183)
197Suggests: debhelper
198Breaks: spl-dkms (<< 0.8.0~rc1)
199Replaces: spl-dkms, zfs-dkms
200Provides: openzfs-zfs-modules
201Description: OpenZFS filesystem kernel modules for Linux
202 OpenZFS is a storage platform that encompasses the functionality of
203 traditional filesystems and volume managers. It supports data checksums,
204 compression, encryption, snapshots, and more.
205 .
206 This DKMS package includes the SPA, DMU, ZVOL, and ZPL components of
207 OpenZFS.
208
209Package: openzfs-zfs-initramfs
210Architecture: all
211Depends: busybox-initramfs | busybox-static | busybox,
212         initramfs-tools,
213         openzfs-zfs-modules | openzfs-zfs-dkms,
214         openzfs-zfsutils (>= ${source:Version}),
215         ${misc:Depends}
216Breaks: zfsutils-linux (<= 0.7.11-2)
217Replaces: zfsutils-linux (<= 0.7.11-2), zfs-initramfs
218Conflicts: zfs-initramfs
219Description: OpenZFS root filesystem capabilities for Linux - initramfs
220 OpenZFS is a storage platform that encompasses the functionality of
221 traditional filesystems and volume managers. It supports data checksums,
222 compression, encryption, snapshots, and more.
223 .
224 This package adds OpenZFS to the system initramfs with a hook
225 for the initramfs-tools infrastructure.
226
227Package: openzfs-zfs-dracut
228Architecture: all
229Depends: dracut,
230         openzfs-zfs-modules | openzfs-zfs-dkms,
231         openzfs-zfsutils (>= ${source:Version}),
232         ${misc:Depends}
233Conflicts: zfs-dracut
234Replaces: zfs-dracut
235Description: OpenZFS root filesystem capabilities for Linux - dracut
236 OpenZFS is a storage platform that encompasses the functionality of
237 traditional filesystems and volume managers. It supports data checksums,
238 compression, encryption, snapshots, and more.
239 .
240 This package adds OpenZFS to the system initramfs with a hook
241 for the dracut infrastructure.
242
243Package: openzfs-zfsutils
244Section: contrib/admin
245Architecture: linux-any
246Pre-Depends: ${misc:Pre-Depends}
247Depends: openzfs-libnvpair3 (= ${binary:Version}),
248         openzfs-libuutil3 (= ${binary:Version}),
249         openzfs-libzfs4 (= ${binary:Version}),
250         openzfs-libzpool5 (= ${binary:Version}),
251         python3,
252         ${misc:Depends},
253         ${shlibs:Depends}
254Recommends: lsb-base, openzfs-zfs-modules | openzfs-zfs-dkms, openzfs-zfs-zed
255Breaks: openrc,
256        spl (<< 0.7.9-2),
257        spl-dkms (<< 0.8.0~rc1),
258        openzfs-zfs-dkms (<< ${source:Version}),
259        openzfs-zfs-dkms (>> ${source:Version}...)
260Replaces: spl (<< 0.7.9-2), spl-dkms, zfsutils-linux
261Conflicts: zfs, zfs-fuse, zfsutils-linux
262Suggests: nfs-kernel-server,
263          samba-common-bin (>= 3.0.23),
264          openzfs-zfs-initramfs | openzfs-zfs-dracut
265Provides: openzfsutils
266Description: command-line tools to manage OpenZFS filesystems
267 OpenZFS is a storage platform that encompasses the functionality of
268 traditional filesystems and volume managers. It supports data checksums,
269 compression, encryption, snapshots, and more.
270 .
271 This package provides the zfs and zpool commands to create and administer
272 OpenZFS filesystems.
273
274Package: openzfs-zfs-zed
275Section: contrib/admin
276Architecture: linux-any
277Pre-Depends: ${misc:Pre-Depends}
278Depends: openzfs-zfs-modules | openzfs-zfs-dkms,
279         openzfs-zfsutils (>= ${binary:Version}),
280         ${misc:Depends},
281         ${shlibs:Depends}
282Conflicts: zfs, zfs-zed
283Replaces: zfs-zed
284Description: OpenZFS Event Daemon
285 OpenZFS is a storage platform that encompasses the functionality of
286 traditional filesystems and volume managers. It supports data checksums,
287 compression, encryption, snapshots, and more.
288 .
289 ZED (ZFS Event Daemon) monitors events generated by the ZFS kernel
290 module. When a zevent (ZFS Event) is posted, ZED will run any ZEDLETs
291 (ZFS Event Daemon Linkage for Executable Tasks) that have been enabled
292 for the corresponding zevent class.
293 .
294 This package provides the OpenZFS Event Daemon (zed).
295
296Package: openzfs-zfs-test
297Section: contrib/admin
298Architecture: linux-any
299Depends: acl,
300         attr,
301         bc,
302         fio,
303         ksh,
304         lsscsi,
305         mdadm,
306         parted,
307         python3,
308         openzfs-python3-pyzfs,
309         sudo,
310         sysstat,
311         openzfs-zfs-modules | openzfs-zfs-dkms,
312         openzfs-zfsutils (>=${binary:Version}),
313         ${misc:Depends},
314         ${shlibs:Depends}
315Recommends: nfs-kernel-server
316Breaks: zfsutils-linux (<= 0.7.9-2)
317Replaces: zfsutils-linux (<= 0.7.9-2), zfs-test
318Conflicts: zutils, zfs-test
319Description: OpenZFS test infrastructure and support scripts
320 OpenZFS is a storage platform that encompasses the functionality of
321 traditional filesystems and volume managers. It supports data checksums,
322 compression, encryption, snapshots, and more.
323 .
324 This package provides the OpenZFS test infrastructure for destructively
325 testing and validating a system using OpenZFS. It is entirely optional
326 and should only be installed and used in test environments.
327