xref: /reactos/dll/win32/crtdll/crtdll.spec (revision c321d3e8)
1*c321d3e8SJérôme Gardou# Old C runtime library.
2c2c66affSColin Finck
3*c321d3e8SJérôme Gardou@ cdecl ??2@YAPAXI@Z(long) MSVCRT_operator_new # void * __cdecl operator new(unsigned int)
4*c321d3e8SJérôme Gardou@ cdecl ??3@YAXPAX@Z(ptr) MSVCRT_operator_delete # void __cdecl operator delete(void *)
5*c321d3e8SJérôme Gardou@ cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) MSVCRT__set_new_handler # int (__cdecl*__cdecl _set_new_handler(int (__cdecl*)(unsigned int)))(unsigned int)
6*c321d3e8SJérôme Gardou@ cdecl _CIacos()
7*c321d3e8SJérôme Gardou@ cdecl _CIasin()
8*c321d3e8SJérôme Gardou@ cdecl _CIatan()
9*c321d3e8SJérôme Gardou@ cdecl _CIatan2()
10*c321d3e8SJérôme Gardou@ cdecl _CIcos()
11*c321d3e8SJérôme Gardou@ cdecl _CIcosh()
12*c321d3e8SJérôme Gardou@ cdecl _CIexp()
13*c321d3e8SJérôme Gardou@ cdecl _CIfmod()
14*c321d3e8SJérôme Gardou@ cdecl _CIlog()
15*c321d3e8SJérôme Gardou@ cdecl _CIlog10()
16*c321d3e8SJérôme Gardou@ cdecl _CIpow()
17*c321d3e8SJérôme Gardou@ cdecl _CIsin()
18*c321d3e8SJérôme Gardou@ cdecl _CIsinh()
19*c321d3e8SJérôme Gardou@ cdecl _CIsqrt()
20*c321d3e8SJérôme Gardou@ cdecl _CItan()
21*c321d3e8SJérôme Gardou@ cdecl _CItanh()
22*c321d3e8SJérôme Gardou@ extern _HUGE_dll _HUGE
23*c321d3e8SJérôme Gardou@ cdecl _XcptFilter()
24c2c66affSColin Finck@ cdecl __GetMainArgs(ptr ptr ptr long)
25*c321d3e8SJérôme Gardou@ extern __argc_dll __argc
26*c321d3e8SJérôme Gardou@ extern __argv_dll __argv
27*c321d3e8SJérôme Gardou@ cdecl __dllonexit(ptr ptr ptr)
28*c321d3e8SJérôme Gardou@ cdecl __doserrno()
29*c321d3e8SJérôme Gardou@ cdecl __fpecode()
30*c321d3e8SJérôme Gardou@ cdecl __isascii(long)
31*c321d3e8SJérôme Gardou@ cdecl __iscsym(long)
32*c321d3e8SJérôme Gardou@ cdecl __iscsymf(long)
33*c321d3e8SJérôme Gardou@ extern __mb_cur_max_dll __mb_cur_max
34*c321d3e8SJérôme Gardou@ cdecl __pxcptinfoptrs()
35*c321d3e8SJérôme Gardou@ cdecl __threadhandle()
36*c321d3e8SJérôme Gardou@ cdecl __threadid()
37*c321d3e8SJérôme Gardou@ cdecl __toascii(long)
38*c321d3e8SJérôme Gardou@ cdecl _abnormal_termination()
39*c321d3e8SJérôme Gardou@ cdecl _access(str long)
40*c321d3e8SJérôme Gardou@ extern _acmdln_dll _acmdln
41*c321d3e8SJérôme Gardou@ extern _aexit_rtn_dll _aexit_rtn
42*c321d3e8SJérôme Gardou@ cdecl _amsg_exit(long)
43*c321d3e8SJérôme Gardou@ cdecl _assert(str str long)
44c2c66affSColin Finck@ extern _basemajor_dll CRTDLL__basemajor_dll
45c2c66affSColin Finck@ extern _baseminor_dll CRTDLL__baseminor_dll
46c2c66affSColin Finck@ extern _baseversion_dll CRTDLL__baseversion_dll
47*c321d3e8SJérôme Gardou@ cdecl _beep(long long)
48*c321d3e8SJérôme Gardou@ cdecl _beginthread(ptr long ptr)
49*c321d3e8SJérôme Gardou@ cdecl _c_exit()
50*c321d3e8SJérôme Gardou@ cdecl _cabs(long)
51*c321d3e8SJérôme Gardou@ cdecl _cexit()
52*c321d3e8SJérôme Gardou@ cdecl _cgets(str)
53*c321d3e8SJérôme Gardou@ cdecl _chdir(str)
54*c321d3e8SJérôme Gardou@ cdecl _chdrive(long)
55*c321d3e8SJérôme Gardou@ cdecl _chgsign( double )
56*c321d3e8SJérôme Gardou@ cdecl _chmod(str long)
57*c321d3e8SJérôme Gardou@ cdecl _chsize(long long)
58*c321d3e8SJérôme Gardou@ cdecl _clearfp()
59*c321d3e8SJérôme Gardou@ cdecl _close(long)
60*c321d3e8SJérôme Gardou@ cdecl _commit(long)
61*c321d3e8SJérôme Gardou@ extern _commode_dll _commode
62*c321d3e8SJérôme Gardou@ cdecl _control87(long long)
63*c321d3e8SJérôme Gardou@ cdecl _controlfp(long long)
64*c321d3e8SJérôme Gardou@ cdecl _copysign( double double )
65*c321d3e8SJérôme Gardou@ varargs _cprintf(str)
66c2c66affSColin Finck@ extern _cpumode_dll CRTDLL__cpumode_dll
67*c321d3e8SJérôme Gardou@ cdecl _cputs(str)
68*c321d3e8SJérôme Gardou@ cdecl _creat(str long)
69*c321d3e8SJérôme Gardou@ varargs _cscanf(str)
70*c321d3e8SJérôme Gardou@ extern _ctype
71*c321d3e8SJérôme Gardou@ cdecl _cwait(ptr long long)
72*c321d3e8SJérôme Gardou@ extern _daylight_dll _daylight
73*c321d3e8SJérôme Gardou@ cdecl _dup(long)
74*c321d3e8SJérôme Gardou@ cdecl _dup2(long long)
75*c321d3e8SJérôme Gardou@ cdecl _ecvt( double long ptr ptr)
76*c321d3e8SJérôme Gardou@ cdecl _endthread()
77*c321d3e8SJérôme Gardou@ extern _environ_dll _environ
78*c321d3e8SJérôme Gardou@ cdecl _eof(long)
79*c321d3e8SJérôme Gardou@ cdecl _errno()
80*c321d3e8SJérôme Gardou@ cdecl _except_handler2(ptr ptr ptr ptr)
81*c321d3e8SJérôme Gardou@ varargs _execl(str str)
82*c321d3e8SJérôme Gardou@ varargs _execle(str str)
83*c321d3e8SJérôme Gardou@ varargs _execlp(str str)
84*c321d3e8SJérôme Gardou@ varargs _execlpe(str str)
85*c321d3e8SJérôme Gardou@ cdecl _execv(str str)
86*c321d3e8SJérôme Gardou@ cdecl _execve(str str str)
87*c321d3e8SJérôme Gardou@ cdecl _execvp(str str)
88*c321d3e8SJérôme Gardou@ cdecl _execvpe(str str str)
89*c321d3e8SJérôme Gardou@ cdecl _exit(long)
90*c321d3e8SJérôme Gardou@ cdecl _expand(ptr long)
91*c321d3e8SJérôme Gardou@ cdecl _fcloseall()
92*c321d3e8SJérôme Gardou@ cdecl _fcvt( double long ptr ptr)
93*c321d3e8SJérôme Gardou@ cdecl _fdopen(long str)
94*c321d3e8SJérôme Gardou@ cdecl _fgetchar()
95*c321d3e8SJérôme Gardou@ cdecl _fgetwchar()
96*c321d3e8SJérôme Gardou@ cdecl _filbuf(ptr)
97c2c66affSColin Finck@ extern _fileinfo_dll
98*c321d3e8SJérôme Gardou@ cdecl _filelength(long)
99*c321d3e8SJérôme Gardou@ cdecl _fileno(ptr)
100*c321d3e8SJérôme Gardou@ cdecl _findclose(long)
101*c321d3e8SJérôme Gardou@ cdecl _findfirst(str ptr)
102*c321d3e8SJérôme Gardou@ cdecl _findnext(long ptr)
103*c321d3e8SJérôme Gardou@ cdecl _finite( double )
104*c321d3e8SJérôme Gardou@ cdecl _flsbuf(long ptr)
105*c321d3e8SJérôme Gardou@ cdecl _flushall()
106*c321d3e8SJérôme Gardou@ extern _fmode_dll _fmode
107*c321d3e8SJérôme Gardou@ cdecl _fpclass(double)
108*c321d3e8SJérôme Gardou@ cdecl _fpieee_flt(long ptr ptr)
109*c321d3e8SJérôme Gardou@ cdecl _fpreset()
110*c321d3e8SJérôme Gardou@ cdecl _fputchar(long)
111*c321d3e8SJérôme Gardou@ cdecl _fputwchar(long)
112*c321d3e8SJérôme Gardou@ cdecl _fsopen(str str long)
113c2c66affSColin Finck@ cdecl _fstat(long ptr) CRTDLL__fstat
114*c321d3e8SJérôme Gardou@ cdecl _ftime(ptr)
115*c321d3e8SJérôme Gardou@ cdecl -ret64 _ftol()
116*c321d3e8SJérôme Gardou@ cdecl _fullpath(ptr str long)
117*c321d3e8SJérôme Gardou@ cdecl _futime(long ptr)
118*c321d3e8SJérôme Gardou@ cdecl _gcvt( double long str)
119*c321d3e8SJérôme Gardou@ cdecl _get_osfhandle(long)
120*c321d3e8SJérôme Gardou@ cdecl _getch()
121*c321d3e8SJérôme Gardou@ cdecl _getche()
122*c321d3e8SJérôme Gardou@ cdecl _getcwd(str long)
123*c321d3e8SJérôme Gardou@ cdecl _getdcwd(long str long)
124*c321d3e8SJérôme Gardou@ cdecl _getdiskfree(long ptr)
125*c321d3e8SJérôme Gardou@ cdecl _getdllprocaddr(long str long)
126*c321d3e8SJérôme Gardou@ cdecl _getdrive()
127*c321d3e8SJérôme Gardou@ cdecl _getdrives()
128*c321d3e8SJérôme Gardou@ cdecl _getpid()
129*c321d3e8SJérôme Gardou@ cdecl _getsystime(ptr)
130*c321d3e8SJérôme Gardou@ cdecl _getw(ptr)
131*c321d3e8SJérôme Gardou@ cdecl _global_unwind2(ptr)
132*c321d3e8SJérôme Gardou@ cdecl _heapchk()
133*c321d3e8SJérôme Gardou@ cdecl _heapmin()
134*c321d3e8SJérôme Gardou@ cdecl _heapset(long)
135*c321d3e8SJérôme Gardou@ cdecl _heapwalk(ptr)
136*c321d3e8SJérôme Gardou@ cdecl _hypot(double double)
137*c321d3e8SJérôme Gardou@ cdecl _initterm(ptr ptr)
138*c321d3e8SJérôme Gardou@ extern _iob
139*c321d3e8SJérôme Gardou@ cdecl _isatty(long)
140*c321d3e8SJérôme Gardou@ cdecl _isctype(long long)
141*c321d3e8SJérôme Gardou@ cdecl _ismbbalnum(long)
142*c321d3e8SJérôme Gardou@ cdecl _ismbbalpha(long)
143*c321d3e8SJérôme Gardou@ cdecl _ismbbgraph(long)
144*c321d3e8SJérôme Gardou@ cdecl _ismbbkalnum(long)
145*c321d3e8SJérôme Gardou@ cdecl _ismbbkana(long)
146*c321d3e8SJérôme Gardou@ cdecl _ismbbkpunct(long)
147*c321d3e8SJérôme Gardou@ cdecl _ismbblead(long)
148*c321d3e8SJérôme Gardou@ cdecl _ismbbprint(long)
149*c321d3e8SJérôme Gardou@ cdecl _ismbbpunct(long)
150*c321d3e8SJérôme Gardou@ cdecl _ismbbtrail(long)
151*c321d3e8SJérôme Gardou@ cdecl _ismbcalpha(long)
152*c321d3e8SJérôme Gardou@ cdecl _ismbcdigit(long)
153*c321d3e8SJérôme Gardou@ cdecl _ismbchira(long)
154*c321d3e8SJérôme Gardou@ cdecl _ismbckata(long)
155*c321d3e8SJérôme Gardou@ cdecl _ismbcl0(long)
156*c321d3e8SJérôme Gardou@ cdecl _ismbcl1(long)
157*c321d3e8SJérôme Gardou@ cdecl _ismbcl2(long)
158*c321d3e8SJérôme Gardou@ cdecl _ismbclegal(long)
159*c321d3e8SJérôme Gardou@ cdecl _ismbclower(long)
160*c321d3e8SJérôme Gardou@ cdecl _ismbcprint(long)
161*c321d3e8SJérôme Gardou@ cdecl _ismbcspace(long)
162*c321d3e8SJérôme Gardou@ cdecl _ismbcsymbol(long)
163*c321d3e8SJérôme Gardou@ cdecl _ismbcupper(long)
164*c321d3e8SJérôme Gardou@ cdecl _ismbslead(ptr ptr)
165*c321d3e8SJérôme Gardou@ cdecl _ismbstrail(ptr ptr)
166*c321d3e8SJérôme Gardou@ cdecl _isnan( double )
167*c321d3e8SJérôme Gardou@ cdecl _itoa(long ptr long)
168*c321d3e8SJérôme Gardou@ cdecl _itow(long ptr long)
169*c321d3e8SJérôme Gardou#  @ cdecl _j0(double)
170*c321d3e8SJérôme Gardou#  @ cdecl _j1(double)
171*c321d3e8SJérôme Gardou#  @ cdecl _jn(long double)
172*c321d3e8SJérôme Gardou@ cdecl _kbhit()
173*c321d3e8SJérôme Gardou@ cdecl _lfind(ptr ptr ptr long ptr)
174*c321d3e8SJérôme Gardou@ cdecl _loaddll(str)
175*c321d3e8SJérôme Gardou@ cdecl _local_unwind2(ptr long)
176*c321d3e8SJérôme Gardou@ cdecl _locking(long long long)
177*c321d3e8SJérôme Gardou@ cdecl _logb( double )
178*c321d3e8SJérôme Gardou@ cdecl _lrotl(long long)
179*c321d3e8SJérôme Gardou@ cdecl _lrotr(long long)
180*c321d3e8SJérôme Gardou@ cdecl _lsearch(ptr ptr long long ptr)
181*c321d3e8SJérôme Gardou@ cdecl _lseek(long long long)
182*c321d3e8SJérôme Gardou@ cdecl _ltoa(long ptr long)
183*c321d3e8SJérôme Gardou@ cdecl _ltow(long ptr long)
184*c321d3e8SJérôme Gardou@ cdecl _makepath(str str str str str)
185*c321d3e8SJérôme Gardou@ cdecl _matherr(ptr)
186*c321d3e8SJérôme Gardou@ cdecl _mbbtombc(long)
187*c321d3e8SJérôme Gardou@ cdecl _mbbtype(long long)
188*c321d3e8SJérôme Gardou@ cdecl _mbccpy(str str)
189*c321d3e8SJérôme Gardou@ cdecl _mbcjistojms(long)
190*c321d3e8SJérôme Gardou@ cdecl _mbcjmstojis(long)
191*c321d3e8SJérôme Gardou@ cdecl _mbclen(ptr)
192*c321d3e8SJérôme Gardou@ cdecl _mbctohira(long)
193*c321d3e8SJérôme Gardou@ cdecl _mbctokata(long)
194*c321d3e8SJérôme Gardou@ cdecl _mbctolower(long)
195*c321d3e8SJérôme Gardou@ cdecl _mbctombb(long)
196*c321d3e8SJérôme Gardou@ cdecl _mbctoupper(long)
197*c321d3e8SJérôme Gardou@ extern _mbctype
198*c321d3e8SJérôme Gardou@ cdecl _mbsbtype(str long)
199*c321d3e8SJérôme Gardou@ cdecl _mbscat(str str)
200*c321d3e8SJérôme Gardou@ cdecl _mbschr(str long)
201*c321d3e8SJérôme Gardou@ cdecl _mbscmp(str str)
202*c321d3e8SJérôme Gardou@ cdecl _mbscpy(ptr str)
203*c321d3e8SJérôme Gardou@ cdecl _mbscspn(str str)
204*c321d3e8SJérôme Gardou@ cdecl _mbsdec(ptr ptr)
205*c321d3e8SJérôme Gardou@ cdecl _mbsdup(str)
206*c321d3e8SJérôme Gardou@ cdecl _mbsicmp(str str)
207*c321d3e8SJérôme Gardou@ cdecl _mbsinc(str)
208*c321d3e8SJérôme Gardou@ cdecl _mbslen(str)
209*c321d3e8SJérôme Gardou@ cdecl _mbslwr(str)
210*c321d3e8SJérôme Gardou@ cdecl _mbsnbcat(str str long)
211*c321d3e8SJérôme Gardou@ cdecl _mbsnbcmp(str str long)
212*c321d3e8SJérôme Gardou@ cdecl _mbsnbcnt(ptr long)
213*c321d3e8SJérôme Gardou@ cdecl _mbsnbcpy(ptr str long)
214*c321d3e8SJérôme Gardou@ cdecl _mbsnbicmp(str str long)
215*c321d3e8SJérôme Gardou@ cdecl _mbsnbset(str long long)
216*c321d3e8SJérôme Gardou@ cdecl _mbsncat(str str long)
217*c321d3e8SJérôme Gardou@ cdecl _mbsnccnt(str long)
218*c321d3e8SJérôme Gardou@ cdecl _mbsncmp(str str long)
219*c321d3e8SJérôme Gardou@ cdecl _mbsncpy(str str long)
220*c321d3e8SJérôme Gardou@ cdecl _mbsnextc(str)
221*c321d3e8SJérôme Gardou@ cdecl _mbsnicmp(str str long)
222*c321d3e8SJérôme Gardou@ cdecl _mbsninc(str long)
223*c321d3e8SJérôme Gardou@ cdecl _mbsnset(str long long)
224*c321d3e8SJérôme Gardou@ cdecl _mbspbrk(str str)
225*c321d3e8SJérôme Gardou@ cdecl _mbsrchr(str long)
226*c321d3e8SJérôme Gardou@ cdecl _mbsrev(str)
227*c321d3e8SJérôme Gardou@ cdecl _mbsset(str long)
228*c321d3e8SJérôme Gardou@ cdecl _mbsspn(str str)
229*c321d3e8SJérôme Gardou@ cdecl _mbsspnp(str str)
230*c321d3e8SJérôme Gardou@ cdecl _mbsstr(str str)
231*c321d3e8SJérôme Gardou@ cdecl _mbstok(str str)
232*c321d3e8SJérôme Gardou@ cdecl _mbstrlen(str)
233*c321d3e8SJérôme Gardou@ cdecl _mbsupr(str)
234*c321d3e8SJérôme Gardou@ cdecl _memccpy(ptr ptr long long)
235*c321d3e8SJérôme Gardou@ cdecl _memicmp(str str long)
236*c321d3e8SJérôme Gardou@ cdecl _mkdir(str)
237*c321d3e8SJérôme Gardou@ cdecl _mktemp(str)
238*c321d3e8SJérôme Gardou@ cdecl _msize(ptr)
239*c321d3e8SJérôme Gardou@ cdecl _nextafter(double double)
240*c321d3e8SJérôme Gardou@ cdecl _onexit(ptr)
241*c321d3e8SJérôme Gardou@ varargs _open(str long)
242*c321d3e8SJérôme Gardou@ cdecl _open_osfhandle(long long)
243c2c66affSColin Finck@ extern _osmajor_dll CRTDLL__osmajor_dll
244c2c66affSColin Finck@ extern _osminor_dll CRTDLL__osminor_dll
245c2c66affSColin Finck@ extern _osmode_dll CRTDLL__osmode_dll
246*c321d3e8SJérôme Gardou@ extern _osver_dll _osver
247c2c66affSColin Finck@ extern _osversion_dll CRTDLL__osversion_dll
248*c321d3e8SJérôme Gardou@ cdecl _pclose(ptr)
249*c321d3e8SJérôme Gardou@ extern _pctype_dll _pctype
250*c321d3e8SJérôme Gardou@ extern _pgmptr_dll _pgmptr
251*c321d3e8SJérôme Gardou@ cdecl _pipe(ptr long long)
252*c321d3e8SJérôme Gardou@ cdecl _popen(str str)
253*c321d3e8SJérôme Gardou@ cdecl _purecall()
254*c321d3e8SJérôme Gardou@ cdecl _putch(long)
255*c321d3e8SJérôme Gardou@ cdecl _putenv(str)
256*c321d3e8SJérôme Gardou@ cdecl _putw(long ptr)
257*c321d3e8SJérôme Gardou@ extern _pwctype_dll _pwctype
258*c321d3e8SJérôme Gardou@ cdecl _read(long ptr long)
259*c321d3e8SJérôme Gardou@ cdecl _rmdir(str)
260*c321d3e8SJérôme Gardou@ cdecl _rmtmp()
261*c321d3e8SJérôme Gardou@ cdecl _rotl(long long)
262*c321d3e8SJérôme Gardou@ cdecl _rotr(long long)
263*c321d3e8SJérôme Gardou@ cdecl _scalb( double long)
264*c321d3e8SJérôme Gardou@ cdecl _searchenv(str str ptr)
265*c321d3e8SJérôme Gardou@ cdecl _seterrormode(long)
266*c321d3e8SJérôme Gardou@ cdecl -i386 _setjmp(ptr)
267*c321d3e8SJérôme Gardou@ cdecl _setmode(long long)
268*c321d3e8SJérôme Gardou@ cdecl _setsystime(ptr long)
269*c321d3e8SJérôme Gardou@ cdecl _sleep(long)
270*c321d3e8SJérôme Gardou@ varargs _snprintf(str long str)
271*c321d3e8SJérôme Gardou@ varargs _snwprintf(wstr long wstr)
272*c321d3e8SJérôme Gardou@ varargs _sopen(str long long)
273*c321d3e8SJérôme Gardou@ varargs _spawnl(long str str)
274*c321d3e8SJérôme Gardou@ varargs _spawnle(long str str)
275*c321d3e8SJérôme Gardou@ varargs _spawnlp(long str str)
276*c321d3e8SJérôme Gardou@ varargs _spawnlpe(long str str)
277*c321d3e8SJérôme Gardou@ cdecl _spawnv(long str ptr)
278*c321d3e8SJérôme Gardou@ cdecl _spawnve(long str ptr ptr)
279*c321d3e8SJérôme Gardou@ cdecl _spawnvp(long str ptr)
280*c321d3e8SJérôme Gardou@ cdecl _spawnvpe(long str ptr ptr)
281*c321d3e8SJérôme Gardou@ cdecl _splitpath(str ptr ptr ptr ptr)
282c2c66affSColin Finck@ cdecl _stat(str ptr) CRTDLL__stat
283*c321d3e8SJérôme Gardou@ cdecl _statusfp()
284*c321d3e8SJérôme Gardou@ cdecl _strcmpi(str str)
285*c321d3e8SJérôme Gardou@ cdecl _strdate(ptr)
286c2c66affSColin Finck@ cdecl _strdec(str str)
287*c321d3e8SJérôme Gardou@ cdecl _strdup(str)
288*c321d3e8SJérôme Gardou@ cdecl _strerror(long)
289*c321d3e8SJérôme Gardou@ cdecl _stricmp(str str)
290*c321d3e8SJérôme Gardou@ cdecl _stricoll(str str)
291c2c66affSColin Finck@ cdecl _strinc(str)
292*c321d3e8SJérôme Gardou@ cdecl _strlwr(str)
293c2c66affSColin Finck@ cdecl _strncnt(str long)
294c2c66affSColin Finck@ cdecl _strnextc(str)
295*c321d3e8SJérôme Gardou@ cdecl _strnicmp(str str long)
296c2c66affSColin Finck@ cdecl _strninc(str long)
297*c321d3e8SJérôme Gardou@ cdecl _strnset(str long long)
298*c321d3e8SJérôme Gardou@ cdecl _strrev(str)
299*c321d3e8SJérôme Gardou@ cdecl _strset(str long)
300c2c66affSColin Finck@ cdecl _strspnp(str str)
301*c321d3e8SJérôme Gardou@ cdecl _strtime(ptr)
302*c321d3e8SJérôme Gardou@ cdecl _strupr(str)
303*c321d3e8SJérôme Gardou@ cdecl _swab(str str long)
304*c321d3e8SJérôme Gardou@ extern _sys_errlist
305*c321d3e8SJérôme Gardou@ extern _sys_nerr_dll _sys_nerr
306*c321d3e8SJérôme Gardou@ cdecl _tell(long)
307*c321d3e8SJérôme Gardou@ cdecl _tempnam(str str)
308*c321d3e8SJérôme Gardou@ extern _timezone_dll _timezone
309*c321d3e8SJérôme Gardou@ cdecl _tolower(long)
310*c321d3e8SJérôme Gardou@ cdecl _toupper(long)
311*c321d3e8SJérôme Gardou@ extern _tzname
312*c321d3e8SJérôme Gardou@ cdecl _tzset()
313*c321d3e8SJérôme Gardou@ cdecl _ultoa(long ptr long)
314*c321d3e8SJérôme Gardou@ cdecl _ultow(long ptr long)
315*c321d3e8SJérôme Gardou@ cdecl _umask(long)
316*c321d3e8SJérôme Gardou@ cdecl _ungetch(long)
317*c321d3e8SJérôme Gardou@ cdecl _unlink(str)
318*c321d3e8SJérôme Gardou@ cdecl _unloaddll(long)
319*c321d3e8SJérôme Gardou@ cdecl _utime(str ptr)
320*c321d3e8SJérôme Gardou@ cdecl _vsnprintf(ptr long ptr ptr)
321*c321d3e8SJérôme Gardou@ cdecl _vsnwprintf(ptr long wstr long)
322*c321d3e8SJérôme Gardou@ cdecl _wcsdup(wstr)
323*c321d3e8SJérôme Gardou@ cdecl _wcsicmp(wstr wstr)
324*c321d3e8SJérôme Gardou@ cdecl _wcsicoll(wstr wstr)
325*c321d3e8SJérôme Gardou@ cdecl _wcslwr(wstr)
326*c321d3e8SJérôme Gardou@ cdecl _wcsnicmp(wstr wstr long)
327*c321d3e8SJérôme Gardou@ cdecl _wcsnset(wstr long long)
328*c321d3e8SJérôme Gardou@ cdecl _wcsrev(wstr)
329*c321d3e8SJérôme Gardou@ cdecl _wcsset(wstr long)
330*c321d3e8SJérôme Gardou@ cdecl _wcsupr(wstr)
331*c321d3e8SJérôme Gardou@ extern _winmajor_dll _winmajor
332*c321d3e8SJérôme Gardou@ extern _winminor_dll _winminor
333*c321d3e8SJérôme Gardou@ extern _winver_dll _winver
334*c321d3e8SJérôme Gardou@ cdecl _write(long ptr long)
335*c321d3e8SJérôme Gardou@ cdecl _wtoi(wstr)
336*c321d3e8SJérôme Gardou@ cdecl _wtol(wstr)
337*c321d3e8SJérôme Gardou#  @ cdecl _y0(double)
338*c321d3e8SJérôme Gardou#  @ cdecl _y1(double)
339*c321d3e8SJérôme Gardou#  @ cdecl _yn(long double )
340*c321d3e8SJérôme Gardou@ cdecl abort()
341*c321d3e8SJérôme Gardou@ cdecl abs(long)
342*c321d3e8SJérôme Gardou@ cdecl acos(double)
343*c321d3e8SJérôme Gardou@ cdecl asctime(ptr)
344*c321d3e8SJérôme Gardou@ cdecl asin(double)
345*c321d3e8SJérôme Gardou@ cdecl atan(double)
346*c321d3e8SJérôme Gardou@ cdecl atan2(double double)
347*c321d3e8SJérôme Gardou@ cdecl atexit(ptr)
348*c321d3e8SJérôme Gardou@ cdecl atof(str)
349*c321d3e8SJérôme Gardou@ cdecl atoi(str)
350*c321d3e8SJérôme Gardou@ cdecl atol(str)
351*c321d3e8SJérôme Gardou@ cdecl bsearch(ptr ptr long long ptr)
352*c321d3e8SJérôme Gardou@ cdecl calloc(long long)
353*c321d3e8SJérôme Gardou@ cdecl ceil(double)
354*c321d3e8SJérôme Gardou@ cdecl clearerr(ptr)
355*c321d3e8SJérôme Gardou@ cdecl clock()
356*c321d3e8SJérôme Gardou@ cdecl cos(double)
357*c321d3e8SJérôme Gardou@ cdecl cosh(double)
358*c321d3e8SJérôme Gardou@ cdecl ctime(ptr)
359*c321d3e8SJérôme Gardou@ cdecl difftime(long long)
360*c321d3e8SJérôme Gardou@ cdecl div(long long)
361*c321d3e8SJérôme Gardou@ cdecl exit(long)
362*c321d3e8SJérôme Gardou@ cdecl exp(double)
363*c321d3e8SJérôme Gardou@ cdecl fabs(double)
364*c321d3e8SJérôme Gardou@ cdecl fclose(ptr)
365*c321d3e8SJérôme Gardou@ cdecl feof(ptr)
366*c321d3e8SJérôme Gardou@ cdecl ferror(ptr)
367*c321d3e8SJérôme Gardou@ cdecl fflush(ptr)
368*c321d3e8SJérôme Gardou@ cdecl fgetc(ptr)
369*c321d3e8SJérôme Gardou@ cdecl fgetpos(ptr ptr)
370*c321d3e8SJérôme Gardou@ cdecl fgets(ptr long ptr)
371*c321d3e8SJérôme Gardou@ cdecl fgetwc(ptr)
372*c321d3e8SJérôme Gardou@ cdecl floor(double)
373*c321d3e8SJérôme Gardou@ cdecl fmod(double double)
374*c321d3e8SJérôme Gardou@ cdecl fopen(str str)
375*c321d3e8SJérôme Gardou@ varargs fprintf(ptr str)
376*c321d3e8SJérôme Gardou@ cdecl fputc(long ptr)
377*c321d3e8SJérôme Gardou@ cdecl fputs(str ptr)
378*c321d3e8SJérôme Gardou@ cdecl fputwc(long ptr)
379*c321d3e8SJérôme Gardou@ cdecl fread(ptr long long ptr)
380*c321d3e8SJérôme Gardou@ cdecl free(ptr)
381*c321d3e8SJérôme Gardou@ cdecl freopen(str str ptr)
382*c321d3e8SJérôme Gardou@ cdecl frexp(double ptr)
383*c321d3e8SJérôme Gardou@ varargs fscanf(ptr str)
384*c321d3e8SJérôme Gardou@ cdecl fseek(ptr long long)
385*c321d3e8SJérôme Gardou@ cdecl fsetpos(ptr ptr)
386*c321d3e8SJérôme Gardou@ cdecl ftell(ptr)
387*c321d3e8SJérôme Gardou@ varargs fwprintf(ptr wstr)
388*c321d3e8SJérôme Gardou@ cdecl fwrite(ptr long long ptr)
389*c321d3e8SJérôme Gardou@ varargs fwscanf(ptr wstr)
390*c321d3e8SJérôme Gardou@ cdecl getc(ptr)
391*c321d3e8SJérôme Gardou@ cdecl getchar()
392*c321d3e8SJérôme Gardou@ cdecl getenv(str)
393*c321d3e8SJérôme Gardou@ cdecl gets(str)
394*c321d3e8SJérôme Gardou@ cdecl gmtime(ptr)
395*c321d3e8SJérôme Gardou@ cdecl is_wctype(long long)
396*c321d3e8SJérôme Gardou@ cdecl isalnum(long)
397*c321d3e8SJérôme Gardou@ cdecl isalpha(long)
398*c321d3e8SJérôme Gardou@ cdecl iscntrl(long)
399*c321d3e8SJérôme Gardou@ cdecl isdigit(long)
400*c321d3e8SJérôme Gardou@ cdecl isgraph(long)
401*c321d3e8SJérôme Gardou@ cdecl isleadbyte(long)
402*c321d3e8SJérôme Gardou@ cdecl islower(long)
403*c321d3e8SJérôme Gardou@ cdecl isprint(long)
404*c321d3e8SJérôme Gardou@ cdecl ispunct(long)
405*c321d3e8SJérôme Gardou@ cdecl isspace(long)
406*c321d3e8SJérôme Gardou@ cdecl isupper(long)
407*c321d3e8SJérôme Gardou@ cdecl iswalnum(long)
408*c321d3e8SJérôme Gardou@ cdecl iswalpha(long)
409*c321d3e8SJérôme Gardou@ cdecl iswascii(long)
410*c321d3e8SJérôme Gardou@ cdecl iswcntrl(long)
411*c321d3e8SJérôme Gardou@ cdecl iswctype(long long)
412*c321d3e8SJérôme Gardou@ cdecl iswdigit(long)
413*c321d3e8SJérôme Gardou@ cdecl iswgraph(long)
414*c321d3e8SJérôme Gardou@ cdecl iswlower(long)
415*c321d3e8SJérôme Gardou@ cdecl iswprint(long)
416*c321d3e8SJérôme Gardou@ cdecl iswpunct(long)
417*c321d3e8SJérôme Gardou@ cdecl iswspace(long)
418*c321d3e8SJérôme Gardou@ cdecl iswupper(long)
419*c321d3e8SJérôme Gardou@ cdecl iswxdigit(long)
420*c321d3e8SJérôme Gardou@ cdecl isxdigit(long)
421*c321d3e8SJérôme Gardou@ cdecl labs(long)
422*c321d3e8SJérôme Gardou@ cdecl ldexp( double long)
423*c321d3e8SJérôme Gardou@ cdecl ldiv(long long)
424*c321d3e8SJérôme Gardou@ cdecl localeconv()
425*c321d3e8SJérôme Gardou@ cdecl localtime(ptr)
426*c321d3e8SJérôme Gardou@ cdecl log(double)
427*c321d3e8SJérôme Gardou@ cdecl log10(double)
428*c321d3e8SJérôme Gardou@ cdecl -i386 longjmp(ptr long)
429*c321d3e8SJérôme Gardou@ cdecl malloc(long)
430*c321d3e8SJérôme Gardou@ cdecl mblen(ptr long)
431*c321d3e8SJérôme Gardou@ cdecl mbstowcs(ptr str long)
432*c321d3e8SJérôme Gardou@ cdecl mbtowc(wstr str long)
433*c321d3e8SJérôme Gardou@ cdecl memchr(ptr long long)
434*c321d3e8SJérôme Gardou@ cdecl memcmp(ptr ptr long)
435*c321d3e8SJérôme Gardou@ cdecl memcpy(ptr ptr long)
436*c321d3e8SJérôme Gardou@ cdecl memmove(ptr ptr long)
437*c321d3e8SJérôme Gardou@ cdecl memset(ptr long long)
438*c321d3e8SJérôme Gardou@ cdecl mktime(ptr)
439*c321d3e8SJérôme Gardou@ cdecl modf(double ptr)
440*c321d3e8SJérôme Gardou@ cdecl perror(str)
441*c321d3e8SJérôme Gardou@ cdecl pow(double double)
442*c321d3e8SJérôme Gardou@ varargs printf(str)
443*c321d3e8SJérôme Gardou@ cdecl putc(long ptr)
444*c321d3e8SJérôme Gardou@ cdecl putchar(long)
445*c321d3e8SJérôme Gardou@ cdecl puts(str)
446*c321d3e8SJérôme Gardou@ cdecl qsort(ptr long long ptr)
447*c321d3e8SJérôme Gardou@ cdecl raise(long)
448*c321d3e8SJérôme Gardou@ cdecl rand()
449*c321d3e8SJérôme Gardou@ cdecl realloc(ptr long)
450*c321d3e8SJérôme Gardou@ cdecl remove(str)
451*c321d3e8SJérôme Gardou@ cdecl rename(str str)
452*c321d3e8SJérôme Gardou@ cdecl rewind(ptr)
453*c321d3e8SJérôme Gardou@ varargs scanf(str)
454*c321d3e8SJérôme Gardou@ cdecl setbuf(ptr ptr)
455*c321d3e8SJérôme Gardou@ cdecl setlocale(long str)
456*c321d3e8SJérôme Gardou@ cdecl setvbuf(ptr str long long)
457*c321d3e8SJérôme Gardou@ cdecl signal(long long)
458*c321d3e8SJérôme Gardou@ cdecl sin(double)
459*c321d3e8SJérôme Gardou@ cdecl sinh(double)
460*c321d3e8SJérôme Gardou@ varargs sprintf(ptr str)
461*c321d3e8SJérôme Gardou@ cdecl sqrt(double)
462*c321d3e8SJérôme Gardou@ cdecl srand(long)
463*c321d3e8SJérôme Gardou@ varargs sscanf(str str)
464*c321d3e8SJérôme Gardou@ cdecl strcat(str str)
465*c321d3e8SJérôme Gardou@ cdecl strchr(str long)
466*c321d3e8SJérôme Gardou@ cdecl strcmp(str str)
467*c321d3e8SJérôme Gardou@ cdecl strcoll(str str)
468*c321d3e8SJérôme Gardou@ cdecl strcpy(ptr str)
469*c321d3e8SJérôme Gardou@ cdecl strcspn(str str)
470*c321d3e8SJérôme Gardou@ cdecl strerror(long)
471*c321d3e8SJérôme Gardou@ cdecl strftime(str long str ptr)
472*c321d3e8SJérôme Gardou@ cdecl strlen(str)
473*c321d3e8SJérôme Gardou@ cdecl strncat(str str long)
474*c321d3e8SJérôme Gardou@ cdecl strncmp(str str long)
475*c321d3e8SJérôme Gardou@ cdecl strncpy(ptr str long)
476*c321d3e8SJérôme Gardou@ cdecl strpbrk(str str)
477*c321d3e8SJérôme Gardou@ cdecl strrchr(str long)
478*c321d3e8SJérôme Gardou@ cdecl strspn(str str)
479*c321d3e8SJérôme Gardou@ cdecl strstr(str str)
480*c321d3e8SJérôme Gardou@ cdecl strtod(str ptr)
481*c321d3e8SJérôme Gardou@ cdecl strtok(str str)
482*c321d3e8SJérôme Gardou@ cdecl strtol(str ptr long)
483*c321d3e8SJérôme Gardou@ cdecl strtoul(str ptr long)
484*c321d3e8SJérôme Gardou@ cdecl strxfrm(ptr str long)
485*c321d3e8SJérôme Gardou@ varargs swprintf(wstr wstr)
486*c321d3e8SJérôme Gardou@ varargs swscanf(wstr wstr)
487*c321d3e8SJérôme Gardou@ cdecl system(str)
488*c321d3e8SJérôme Gardou@ cdecl tan(double)
489*c321d3e8SJérôme Gardou@ cdecl tanh(double)
490*c321d3e8SJérôme Gardou@ cdecl time(ptr)
491*c321d3e8SJérôme Gardou@ cdecl tmpfile()
492*c321d3e8SJérôme Gardou@ cdecl tmpnam(str)
493*c321d3e8SJérôme Gardou@ cdecl tolower(long)
494*c321d3e8SJérôme Gardou@ cdecl toupper(long)
495*c321d3e8SJérôme Gardou@ cdecl towlower(long)
496*c321d3e8SJérôme Gardou@ cdecl towupper(long)
497*c321d3e8SJérôme Gardou@ cdecl ungetc(long ptr)
498*c321d3e8SJérôme Gardou@ cdecl ungetwc(long ptr)
499*c321d3e8SJérôme Gardou@ cdecl vfprintf(ptr str long)
500*c321d3e8SJérôme Gardou@ cdecl vfwprintf(ptr wstr long)
501*c321d3e8SJérôme Gardou@ cdecl vprintf(str long)
502*c321d3e8SJérôme Gardou@ cdecl vsprintf(ptr str ptr)
503*c321d3e8SJérôme Gardou@ cdecl vswprintf(ptr wstr long)
504*c321d3e8SJérôme Gardou@ cdecl vwprintf(wstr long)
505*c321d3e8SJérôme Gardou@ cdecl wcscat(wstr wstr)
506*c321d3e8SJérôme Gardou@ cdecl wcschr(wstr long)
507*c321d3e8SJérôme Gardou@ cdecl wcscmp(wstr wstr)
508*c321d3e8SJérôme Gardou@ cdecl wcscoll(wstr wstr)
509*c321d3e8SJérôme Gardou@ cdecl wcscpy(ptr wstr)
510*c321d3e8SJérôme Gardou@ cdecl wcscspn(wstr wstr)
511*c321d3e8SJérôme Gardou@ cdecl wcsftime(ptr long wstr ptr)
512*c321d3e8SJérôme Gardou@ cdecl wcslen(wstr)
513*c321d3e8SJérôme Gardou@ cdecl wcsncat(wstr wstr long)
514*c321d3e8SJérôme Gardou@ cdecl wcsncmp(wstr wstr long)
515*c321d3e8SJérôme Gardou@ cdecl wcsncpy(ptr wstr long)
516*c321d3e8SJérôme Gardou@ cdecl wcspbrk(wstr wstr)
517*c321d3e8SJérôme Gardou@ cdecl wcsrchr(wstr long)
518*c321d3e8SJérôme Gardou@ cdecl wcsspn(wstr wstr)
519*c321d3e8SJérôme Gardou@ cdecl wcsstr(wstr wstr)
520*c321d3e8SJérôme Gardou@ cdecl wcstod(wstr ptr)
521*c321d3e8SJérôme Gardou@ cdecl wcstok(wstr wstr)
522*c321d3e8SJérôme Gardou@ cdecl wcstol(wstr ptr long)
523*c321d3e8SJérôme Gardou@ cdecl wcstombs(ptr ptr long)
524*c321d3e8SJérôme Gardou@ cdecl wcstoul(wstr ptr long)
525*c321d3e8SJérôme Gardou@ cdecl wcsxfrm(ptr wstr long)
526*c321d3e8SJérôme Gardou@ cdecl wctomb(ptr long)
527*c321d3e8SJérôme Gardou@ varargs wprintf(wstr)
528*c321d3e8SJérôme Gardou@ varargs wscanf(wstr)
529