xref: /reactos/dll/win32/mapi32/mapi32.spec (revision 40462c92)
1  8 stub mapi32_8
2 10 stdcall MAPILogonEx(long ptr ptr long ptr)
3 11 stdcall MAPILogonEx@20(long ptr ptr long ptr) MAPILogonEx
4 12 stdcall MAPIAllocateBuffer(long ptr)
5 13 stdcall MAPIAllocateBuffer@8(long ptr) MAPIAllocateBuffer
6 14 stdcall MAPIAllocateMore(long ptr ptr)
7 15 stdcall MAPIAllocateMore@12(long ptr ptr) MAPIAllocateMore
8 16 stdcall MAPIFreeBuffer(ptr)
9 17 stdcall MAPIFreeBuffer@4(ptr) MAPIFreeBuffer
10 18 stdcall MAPIAdminProfiles(long ptr)
11 19 stdcall MAPIAdminProfiles@8(long ptr) MAPIAdminProfiles
12 20 stdcall MAPIInitialize(ptr)
13 21 stdcall MAPIInitialize@4(ptr) MAPIInitialize
14 22 stdcall MAPIUninitialize()
15 23 stdcall MAPIUninitialize@0() MAPIUninitialize
16 24 stub PRProviderInit
17 25 stub LAUNCHWIZARD
18 26 stub LaunchWizard@20
19 @ stdcall -private DllGetClassObject(ptr ptr ptr)
20 @ stdcall -private DllCanUnloadNow()
21 29 stdcall MAPIOpenFormMgr(ptr ptr)
22 30 stdcall MAPIOpenFormMgr@8(ptr ptr) MAPIOpenFormMgr
23 31 stdcall MAPIOpenLocalFormContainer(ptr)
24 32 stdcall MAPIOpenLocalFormContainer@4(ptr) MAPIOpenLocalFormContainer
25 33 stdcall ScInitMapiUtil@4(long) ScInitMapiUtil
26 34 stdcall DeinitMapiUtil@0() DeinitMapiUtil
27 35 stub ScGenerateMuid@4
28 36 stub HrAllocAdviseSink@12
29 41 stdcall WrapProgress@20(ptr ptr ptr ptr ptr) WrapProgress
30 42 stdcall HrThisThreadAdviseSink@8(ptr ptr) HrThisThreadAdviseSink
31 43 stub ScBinFromHexBounded@12
32 44 stdcall FBinFromHex@8(ptr ptr) FBinFromHex
33 45 stdcall HexFromBin@12(ptr long ptr) HexFromBin
34 46 stub BuildDisplayTable@40
35 47 stdcall SwapPlong@8(ptr long) SwapPlong
36 48 stdcall SwapPword@8(ptr long) SwapPword
37 49 stub MAPIInitIdle@4
38 50 stub MAPIDeinitIdle@0
39 51 stub InstallFilterHook@4
40 52 stub FtgRegisterIdleRoutine@20
41 53 stub EnableIdleRoutine@8
42 54 stub DeregisterIdleRoutine@4
43 55 stub ChangeIdleRoutine@28
44 59 stdcall MAPIGetDefaultMalloc@0() MAPIGetDefaultMalloc
45 60 stdcall CreateIProp@24(ptr ptr ptr ptr ptr ptr) CreateIProp
46 61 stub CreateTable@36
47 62 stdcall MNLS_lstrlenW@4(wstr) MNLS_lstrlenW
48 63 stdcall MNLS_lstrcmpW@8(wstr wstr) MNLS_lstrcmpW
49 64 stdcall MNLS_lstrcpyW@8(ptr wstr) MNLS_lstrcpyW
50 65 stdcall MNLS_CompareStringW@24(long wstr wstr) MNLS_CompareStringW
51 66 stdcall MNLS_MultiByteToWideChar@24(long long str long ptr long) kernel32.MultiByteToWideChar
52 67 stdcall MNLS_WideCharToMultiByte@32(long long wstr long ptr long ptr ptr) kernel32.WideCharToMultiByte
53 68 stdcall MNLS_IsBadStringPtrW@8(ptr long) kernel32.IsBadStringPtrW
54 72 stdcall FEqualNames@8(ptr ptr) FEqualNames
55 73 stub WrapStoreEntryID@24
56 74 stdcall IsBadBoundedStringPtr@8(ptr long) IsBadBoundedStringPtr
57 75 stdcall HrQueryAllRows@24(ptr ptr ptr ptr long ptr) HrQueryAllRows
58 76 stdcall PropCopyMore@16(ptr ptr ptr ptr) PropCopyMore
59 77 stdcall UlPropSize@4(ptr) UlPropSize
60 78 stdcall FPropContainsProp@12(ptr ptr long) FPropContainsProp
61 79 stdcall FPropCompareProp@12(ptr long ptr) FPropCompareProp
62 80 stdcall LPropCompareProp@8(ptr ptr) LPropCompareProp
63 81 stub HrAddColumns@16
64 82 stub HrAddColumnsEx@20
65121 stdcall -ret64 FtAddFt@16(int64 int64) MAPI32_FtAddFt
66122 stub FtAdcFt@20
67123 stdcall -ret64 FtSubFt@16(int64 int64) MAPI32_FtSubFt
68124 stdcall -ret64 FtMulDw@12(long int64) MAPI32_FtMulDw
69125 stdcall -ret64 FtMulDwDw@8(long long) MAPI32_FtMulDwDw
70126 stdcall -ret64 FtNegFt@8(int64) MAPI32_FtNegFt
71127 stub FtDivFtBogus@20
72128 stdcall UlAddRef@4(ptr) UlAddRef
73129 stdcall UlRelease@4(ptr) UlRelease
74130 stdcall SzFindCh@8(str long) shlwapi.StrChrA
75131 stdcall SzFindLastCh@8(str str long) shlwapi.StrRChrA
76132 stdcall SzFindSz@8(str str) shlwapi.StrStrA
77133 stdcall UFromSz@4(str) UFromSz
78135 stdcall HrGetOneProp@12(ptr long ptr) HrGetOneProp
79136 stdcall HrSetOneProp@8(ptr ptr) HrSetOneProp
80137 stdcall FPropExists@8(ptr long) FPropExists
81138 stdcall PpropFindProp@12(ptr long long) PpropFindProp
82139 stdcall FreePadrlist@4(ptr) FreePadrlist
83140 stdcall FreeProws@4(ptr) FreeProws
84141 stub HrSzFromEntryID@12
85142 stub HrEntryIDFromSz@12
86143 stub HrComposeEID@28
87144 stub HrDecomposeEID@28
88145 stub HrComposeMsgID@24
89146 stub HrDecomposeMsgID@24
90147 stdcall OpenStreamOnFile@24(ptr ptr long ptr ptr ptr) OpenStreamOnFile
91148 stdcall OpenStreamOnFile(ptr ptr long ptr ptr ptr)
92149 stdcall OpenTnefStream@28(ptr ptr ptr long ptr long ptr) OpenTnefStream
93150 stdcall OpenTnefStream(ptr ptr ptr long ptr long ptr)
94151 stdcall OpenTnefStreamEx@32(ptr ptr ptr long ptr long ptr ptr) OpenTnefStreamEx
95152 stdcall OpenTnefStreamEx(ptr ptr ptr long ptr long ptr ptr)
96153 stdcall GetTnefStreamCodepage@12(ptr ptr ptr) GetTnefStreamCodepage
97154 stdcall GetTnefStreamCodepage(ptr ptr ptr)
98155 stdcall UlFromSzHex@4(ptr) UlFromSzHex
99156 stub UNKOBJ_ScAllocate@12
100157 stub UNKOBJ_ScAllocateMore@16
101158 stub UNKOBJ_Free@8
102159 stub UNKOBJ_FreeRows@8
103160 stub UNKOBJ_ScCOAllocate@12
104161 stub UNKOBJ_ScCOReallocate@12
105162 stub UNKOBJ_COFree@8
106163 stub UNKOBJ_ScSzFromIdsAlloc@20
107164 stub ScCountNotifications@12
108165 stub ScCopyNotifications@16
109166 stub ScRelocNotifications@20
110170 stdcall ScCountProps@12(long ptr ptr) ScCountProps
111171 stdcall ScCopyProps@16(long ptr ptr ptr) ScCopyProps
112172 stdcall ScRelocProps@20(long ptr ptr ptr ptr) ScRelocProps
113173 stdcall LpValFindProp@12(long long ptr) LpValFindProp
114174 stdcall ScDupPropset@16(long ptr ptr ptr) ScDupPropset
115175 stdcall FBadRglpszA@8(ptr long) FBadRglpszA
116176 stdcall FBadRglpszW@8(ptr long) FBadRglpszW
117177 stdcall FBadRowSet@4(ptr) FBadRowSet
118178 stub FBadRglpNameID@8
119179 stdcall FBadPropTag@4(long) FBadPropTag
120180 stdcall FBadRow@4(ptr) FBadRow
121181 stdcall FBadProp@4(ptr) FBadProp
122182 stdcall FBadColumnSet@4(ptr) FBadColumnSet
123183 stdcall RTFSync@12(ptr long ptr) RTFSync
124184 stdcall RTFSync(ptr long ptr)
125185 stdcall WrapCompressedRTFStream@12(ptr long ptr) WrapCompressedRTFStream
126186 stdcall WrapCompressedRTFStream(ptr long ptr)
127187 stub __ValidateParameters@8
128188 stub __CPPValidateParameters@8
129189 stub FBadSortOrderSet@4
130190 stdcall FBadEntryList@4(ptr) FBadEntryList
131191 stub FBadRestriction@4
132192 stub ScUNCFromLocalPath@12
133193 stub ScLocalPathFromUNC@12
134194 stub HrIStorageFromStream@16
135195 stub HrValidateIPMSubtree@20
136196 stub OpenIMsgSession@12
137197 stub CloseIMsgSession@4
138198 stub OpenIMsgOnIStg@44
139199 stub SetAttribIMsgOnIStg@16
140200 stub GetAttribIMsgOnIStg@12
141201 stub MapStorageSCode@4
142202 stub ScMAPIXFromCMC
143203 stub ScMAPIXFromSMAPI
144204 stub EncodeID@12
145205 stub FDecodeID@12
146206 stub CchOfEncoding@4
147207 stdcall CbOfEncoded@4(ptr) CbOfEncoded
148208 stdcall MAPISendDocuments(long str str str long)
149209 stdcall MAPILogon(long str str long long ptr)
150210 stdcall MAPILogoff(ptr long long long)
151211 stdcall MAPISendMail(ptr long ptr long long)
152212 stdcall MAPISaveMail(ptr long ptr long long str)
153213 stdcall MAPIReadMail(ptr long str long long ptr)
154214 stdcall MAPIFindNext(ptr long str str long long ptr)
155215 stdcall MAPIDeleteMail(ptr long str long long)
156217 stdcall MAPIAddress(ptr long str long str long ptr long long ptr ptr)
157218 stdcall MAPIDetails(ptr long ptr long long)
158219 stdcall MAPIResolveName(ptr long str long long ptr)
159220 stub BMAPISendMail
160221 stub BMAPISaveMail
161222 stub BMAPIReadMail
162223 stub BMAPIGetReadMail
163224 stub BMAPIFindNext
164225 stub BMAPIAddress
165226 stub BMAPIGetAddress
166227 stub BMAPIDetails
167228 stub BMAPIResolveName
168229 stub cmc_act_on
169230 stub cmc_free
170231 stub cmc_list
171232 stub cmc_logoff
172233 stub cmc_logon
173234 stub cmc_look_up
174235 stdcall cmc_query_configuration( long long ptr ptr )
175236 stub cmc_read
176237 stub cmc_send
177238 stub cmc_send_documents
178239 stdcall HrDispatchNotifications@4(long) HrDispatchNotifications
179241 stub HrValidateParameters@8
180244 stub ScCreateConversationIndex@16
181246 stdcall HrGetOmiProvidersFlags(long long)
182247 stdcall HrGetOmiProvidersFlags@8(long long) HrGetOmiProvidersFlags
183248 stdcall HrSetOmiProvidersFlagsInvalid(long)
184249 stdcall HrSetOmiProvidersFlagsInvalid@4(long) HrSetOmiProvidersFlagsInvalid
185250 stdcall GetOutlookVersion()
186251 stdcall GetOutlookVersion@0() GetOutlookVersion
187252 stdcall FixMAPI()
188253 stdcall FixMAPI@0() FixMAPI
189254 stdcall FGetComponentPath(str str ptr long long)
190255 stdcall FGetComponentPath@20(str str ptr long long) FGetComponentPath
191256 stdcall MAPISendMailW(ptr long ptr long long)
192