xref: /reactos/dll/win32/mpr/mpr.spec (revision 53221834)
1# ordinal exports
2 1 stub MPR_1
3 2 stub MPR_2
4 3 stub MPR_3
5 4 stub MPR_4
6 5 stub MPR_5
7 6 stub MPR_6
8 7 stub MPR_7
9 8 stub MPR_8
10 9 stub MPR_9
1112 stub MPR_12
1213 stub MPR_13
1314 stub MPR_14
1415 stub MPR_15
1516 stub MPR_16
1617 stub MPR_17
1718 stub MPR_18
1819 stub MPR_19
1920 stub MPR_20
2021 stub MPR_21
2122 stdcall @(long) MPR_Alloc
2223 stdcall @(ptr long) MPR_ReAlloc
2324 stdcall @(ptr) MPR_Free
2425 stdcall @(ptr long) _MPR_25
25
26@ stub I_MprSaveConn
27@ stdcall MultinetGetConnectionPerformanceA(ptr ptr)
28@ stdcall MultinetGetConnectionPerformanceW(ptr ptr)
29@ stdcall MultinetGetErrorTextA(long long long)
30@ stdcall MultinetGetErrorTextW(long long long)
31@ stdcall NPSAuthenticationDialogA(ptr)
32@ stdcall NPSCopyStringA(str ptr ptr)
33@ stdcall NPSDeviceGetNumberA(str ptr ptr)
34@ stdcall NPSDeviceGetStringA(long long ptr ptr)
35@ stdcall NPSGetProviderHandleA(ptr)
36@ stdcall NPSGetProviderNameA(ptr ptr)
37@ stdcall NPSGetSectionNameA(ptr ptr)
38@ stdcall NPSNotifyGetContextA(ptr)
39@ stdcall NPSNotifyRegisterA(long ptr)
40@ stdcall NPSSetCustomTextA(str)
41@ stdcall NPSSetExtendedErrorA(long str)
42@ stdcall PwdChangePasswordA(str ptr long ptr)
43@ stdcall PwdChangePasswordW(wstr ptr long ptr)
44@ stdcall PwdGetPasswordStatusA(str long ptr)
45@ stdcall PwdGetPasswordStatusW(wstr long ptr)
46@ stdcall PwdSetPasswordStatusA(str long long)
47@ stdcall PwdSetPasswordStatusW(wstr long long)
48@ stub RestoreConnectionA0
49@ stdcall WNetAddConnection2A(ptr str str long)
50@ stdcall WNetAddConnection2W(ptr wstr wstr long)
51@ stdcall WNetAddConnection3A(long ptr str str long)
52@ stdcall WNetAddConnection3W(long ptr wstr wstr long)
53@ stdcall WNetAddConnectionA(str str str)
54@ stdcall WNetAddConnectionW(wstr wstr wstr)
55@ stdcall WNetCachePassword(str long str long long long)
56@ stdcall WNetCancelConnection2A(str long long)
57@ stdcall WNetCancelConnection2W(wstr long long)
58@ stdcall WNetCancelConnectionA(str long)
59@ stdcall WNetCancelConnectionW(wstr long)
60@ stdcall WNetClearConnections(ptr)
61@ stdcall WNetCloseEnum(long)
62@ stdcall WNetConnectionDialog1A(ptr)
63@ stdcall WNetConnectionDialog1W(ptr)
64@ stdcall WNetConnectionDialog(long long)
65@ stub WNetConnectionDialog2 # (ptr long wstr long)
66@ stub WNetDirectoryNotifyA
67@ stub WNetDirectoryNotifyW # (ptr wstr long)
68@ stdcall WNetDisconnectDialog1A(ptr)
69@ stdcall WNetDisconnectDialog1W(ptr)
70@ stdcall WNetDisconnectDialog(long long)
71@ stub WNetDisconnectDialog2 # (ptr long wstr long)
72@ stdcall WNetEnumCachedPasswords(str long long ptr long)
73@ stdcall WNetEnumResourceA(long ptr ptr ptr)
74@ stdcall WNetEnumResourceW(long ptr ptr ptr)
75@ stub WNetFMXEditPerm
76@ stub WNetFMXGetPermCaps
77@ stub WNetFMXGetPermHelp
78@ stub WNetFormatNetworkNameA
79@ stub WNetFormatNetworkNameW # (wstr wstr ptr ptr long long)
80@ stdcall WNetGetCachedPassword(ptr long ptr ptr long)
81@ stub WNetGetConnection2A
82@ stub WNetGetConnection2W # (wstr ptr ptr)
83@ stub WNetGetConnection3A
84@ stub WNetGetConnection3W
85@ stdcall WNetGetConnectionA(str ptr ptr)
86@ stdcall WNetGetConnectionW(wstr ptr ptr)
87@ stdcall -stub WNetGetDirectoryTypeA(str ptr long)
88@ stdcall -stub WNetGetDirectoryTypeW(wstr ptr long)
89@ stub WNetGetHomeDirectoryA
90@ stub WNetGetHomeDirectoryW
91@ stdcall WNetGetLastErrorA(ptr ptr long ptr long)
92@ stdcall WNetGetLastErrorW(ptr ptr long ptr long)
93@ stdcall WNetGetNetworkInformationA(str ptr)
94@ stdcall WNetGetNetworkInformationW(wstr ptr)
95@ stub WNetGetPropertyTextA
96@ stub WNetGetPropertyTextW # (long long wstr ptr long long)
97@ stdcall WNetGetProviderNameA(long ptr ptr)
98@ stdcall WNetGetProviderNameW(long ptr ptr)
99@ stub WNetGetProviderTypeA
100@ stub WNetGetProviderTypeW
101@ stdcall WNetGetResourceInformationA(ptr ptr ptr ptr)
102@ stdcall WNetGetResourceInformationW(ptr ptr ptr ptr)
103@ stdcall WNetGetResourceParentA(ptr ptr ptr)
104@ stdcall WNetGetResourceParentW(ptr ptr ptr)
105@ stub WNetGetSearchDialog
106@ stdcall WNetGetUniversalNameA (str long ptr ptr)
107@ stdcall WNetGetUniversalNameW (wstr long ptr ptr)
108@ stdcall WNetGetUserA(str ptr ptr)
109@ stdcall WNetGetUserW(wstr wstr ptr)
110@ stdcall WNetLogoffA(str long)
111@ stdcall WNetLogoffW(wstr long)
112@ stdcall WNetLogonA(str long)
113@ stub WNetLogonNotify
114@ stdcall WNetLogonW(wstr long)
115@ stdcall WNetOpenEnumA(long long long ptr ptr)
116@ stdcall WNetOpenEnumW(long long long ptr ptr)
117@ stub WNetPasswordChangeNotify
118@ stub WNetPropertyDialogA
119@ stub WNetPropertyDialogW # (ptr long long wstr long)
120@ stdcall WNetRemoveCachedPassword(ptr long long)
121@ stub WNetRestoreConnection
122@ stub WNetRestoreConnection2W
123@ stdcall WNetRestoreConnectionA(long str)
124@ stdcall WNetRestoreConnectionW(long wstr)
125# WNetRestoreSingleConnectionW # (ptr wstr long) # Not in WS03 yet?
126@ stdcall WNetSetConnectionA(str long ptr)
127@ stdcall WNetSetConnectionW(wstr long ptr)
128@ stub WNetSetLastErrorA # {long str str)
129@ stub WNetSetLastErrorW # {long wstr wstr)
130@ stub WNetSupportGlobalEnum
131@ stdcall WNetUseConnectionA(long ptr str str long str ptr ptr)
132@ stdcall WNetUseConnectionW(long ptr wstr wstr long wstr ptr ptr)
133@ stdcall WNetVerifyPasswordA(str ptr)
134@ stdcall WNetVerifyPasswordW(wstr ptr)
135