xref: /reactos/dll/win32/rpcrt4/rpcrt4.spec (revision 40462c92)
11 stdcall CreateProxyFromTypeInfo(ptr ptr ptr ptr ptr)
22 stdcall CreateStubFromTypeInfo(ptr ptr ptr ptr)
3# I_RpcServerTurnOnOffKeepalives
44 stdcall CStdStubBuffer_AddRef(ptr)
55 stdcall CStdStubBuffer_Connect(ptr ptr)
66 stdcall CStdStubBuffer_CountRefs(ptr)
77 stdcall CStdStubBuffer_DebugServerQueryInterface(ptr ptr)
88 stdcall CStdStubBuffer_DebugServerRelease(ptr ptr)
99 stdcall CStdStubBuffer_Disconnect(ptr)
1010 stdcall CStdStubBuffer_Invoke(ptr ptr ptr)
1111 stdcall CStdStubBuffer_IsIIDSupported(ptr ptr)
1212 stdcall CStdStubBuffer_QueryInterface(ptr ptr ptr)
1313 stdcall DceErrorInqTextA (long ptr)
1414 stdcall DceErrorInqTextW (long ptr)
15# DllGetClassObject
16# DllInstall
17@ stdcall -private DllRegisterServer()
1818 stub GlobalMutexClearExternal
1919 stub GlobalMutexRequestExternal
2020 stdcall IUnknown_AddRef_Proxy(ptr)
2121 stdcall IUnknown_QueryInterface_Proxy(ptr ptr ptr)
2222 stdcall IUnknown_Release_Proxy(ptr)
2323 stdcall I_RpcAbortAsyncCall(ptr long) I_RpcAsyncAbortCall
2424 stdcall I_RpcAllocate(long)
2525 stdcall I_RpcAsyncAbortCall(ptr long)
2626 stdcall I_RpcAsyncSetHandle(ptr ptr)
2727 stub I_RpcBCacheAllocate
2828 stub I_RpcBCacheFree
2929 stub I_RpcBindingCopy
30# I_RpcBindingHandleToAsyncHandle
3131 stub I_RpcBindingInqConnId
3232 stub I_RpcBindingInqDynamicEndPoint
3333 stub I_RpcBindingInqDynamicEndPointA
3434 stub I_RpcBindingInqDynamicEndPointW
3535 stdcall I_RpcBindingInqLocalClientPID(ptr ptr)
36# I_RpcBindingInqMarshalledTargetInfo
3737 stub I_RpcBindingInqSecurityContext
3838 stdcall I_RpcBindingInqTransportType(ptr ptr)
3939 stub I_RpcBindingInqWireIdForSnego
4040 stub I_RpcBindingIsClientLocal
4141 stub I_RpcBindingToStaticStringBindingW
4242 stub I_RpcClearMutex
4343 stub I_RpcConnectionInqSockBuffSize
4444 stub I_RpcConnectionSetSockBuffSize
4545 stub I_RpcDeleteMutex
4646 stub I_RpcEnableWmiTrace
4747 stdcall I_RpcExceptionFilter(long) RpcExceptionFilter
4848 stdcall I_RpcFree(ptr)
4949 stdcall I_RpcFreeBuffer(ptr)
5050 stub I_RpcFreePipeBuffer
5151 stdcall I_RpcGetBuffer(ptr)
5252 stub I_RpcGetBufferWithObject
5353 stdcall I_RpcGetCurrentCallHandle()
5454 stub I_RpcGetExtendedError
5555 stub I_RpcIfInqTransferSyntaxes
5656 stub I_RpcLogEvent
5757 stdcall I_RpcMapWin32Status(long)
58# I_RpcNDRCGetWireRepresentation
59# I_RpcNDRSContextEmergencyCleanup
6060 stdcall I_RpcNegotiateTransferSyntax(ptr)
6161 stub I_RpcNsBindingSetEntryName
6262 stub I_RpcNsBindingSetEntryNameA
6363 stub I_RpcNsBindingSetEntryNameW
6464 stub I_RpcNsInterfaceExported
6565 stub I_RpcNsInterfaceUnexported
6666 stub I_RpcParseSecurity
6767 stub I_RpcPauseExecution
6868 stub I_RpcProxyNewConnection
6969 stub I_RpcReallocPipeBuffer
7070 stdcall I_RpcReceive(ptr)
71# I_RpcRecordCalloutFailure
72# I_RpcReplyToClientWithStatus
7373 stub I_RpcRequestMutex
7474 stub I_RpcSNCHOption
7575 stdcall I_RpcSend(ptr)
7676 stdcall I_RpcSendReceive(ptr)
7777 stub I_RpcServerAllocateIpPort
78# I_RpcServerCheckClientRestriction
7979 stub I_RpcServerInqAddressChangeFn
8080 stub I_RpcServerInqLocalConnAddress
8181 stub I_RpcServerInqTransportType
82# I_RpcServerIsClientDisconnected
8383 stub I_RpcServerRegisterForwardFunction
8484 stub I_RpcServerSetAddressChangeFn
8585 stub I_RpcServerUseProtseq2A
8686 stub I_RpcServerUseProtseq2W
8787 stub I_RpcServerUseProtseqEp2A
8888 stub I_RpcServerUseProtseqEp2W
89# I_RpcSessionStrictContextHandle
9090 stub I_RpcSetAsyncHandle
9191 stub I_RpcSsDontSerializeContext
9292 stub I_RpcSystemFunction001
9393 stub I_RpcTransConnectionAllocatePacket
9494 stub I_RpcTransConnectionFreePacket
9595 stub I_RpcTransConnectionReallocPacket
9696 stub I_RpcTransDatagramAllocate2
9797 stub I_RpcTransDatagramAllocate
9898 stub I_RpcTransDatagramFree
9999 stub I_RpcTransGetThreadEvent
100100 stub I_RpcTransIoCancelled
101101 stub I_RpcTransServerNewConnection
102102 stub I_RpcTurnOnEEInfoPropagation
103103 stdcall I_UuidCreate(ptr)
104104 stub MIDL_wchar_strcpy
105105 stub MIDL_wchar_strlen
106106 stdcall MesBufferHandleReset(ptr long long ptr long ptr)
107107 stdcall MesDecodeBufferHandleCreate(ptr long ptr)
108108 stdcall MesDecodeIncrementalHandleCreate(ptr ptr ptr)
109109 stdcall MesEncodeDynBufferHandleCreate(ptr ptr ptr)
110110 stdcall MesEncodeFixedBufferHandleCreate(ptr long ptr ptr)
111111 stdcall MesEncodeIncrementalHandleCreate(ptr ptr ptr ptr)
112112 stdcall MesHandleFree(ptr)
113113 stdcall MesIncrementalHandleReset(ptr ptr ptr ptr ptr long)
114114 stub MesInqProcEncodingId
115115 stdcall NDRCContextBinding(ptr)
116116 stdcall NDRCContextMarshall(ptr ptr)
117117 stdcall NDRCContextUnmarshall(ptr ptr ptr long)
118118 stdcall NDRSContextMarshall2(ptr ptr ptr ptr ptr long)
119119 stdcall NDRSContextMarshall(ptr ptr ptr)
120120 stdcall NDRSContextMarshallEx(ptr ptr ptr ptr)
121121 stdcall NDRSContextUnmarshall2(ptr ptr long ptr long)
122122 stdcall NDRSContextUnmarshall(ptr long)
123123 stdcall NDRSContextUnmarshallEx(ptr ptr long)
124124 stub NDRcopy
125125 stdcall NdrAllocate(ptr long)
126126 varargs NdrAsyncClientCall(ptr ptr)
127127 stdcall NdrAsyncServerCall(ptr)
128128 stdcall NdrByteCountPointerBufferSize(ptr ptr ptr)
129129 stdcall NdrByteCountPointerFree(ptr ptr ptr)
130130 stdcall NdrByteCountPointerMarshall(ptr ptr ptr)
131131 stdcall NdrByteCountPointerUnmarshall(ptr ptr ptr long)
132132 stdcall NdrCStdStubBuffer2_Release(ptr ptr)
133133 stdcall NdrCStdStubBuffer_Release(ptr ptr)
134134 stdcall NdrClearOutParameters(ptr ptr ptr)
135135 varargs -arch=i386 NdrClientCall(ptr ptr) NdrClientCall2
136136 varargs NdrClientCall2(ptr ptr)
137137 stdcall NdrClientContextMarshall(ptr ptr long)
138138 stdcall NdrClientContextUnmarshall(ptr ptr ptr)
139139 stub NdrClientInitialize
140140 stdcall NdrClientInitializeNew(ptr ptr ptr long)
141141 stdcall NdrComplexArrayBufferSize(ptr ptr ptr)
142142 stdcall NdrComplexArrayFree(ptr ptr ptr)
143143 stdcall NdrComplexArrayMarshall(ptr ptr ptr)
144144 stdcall NdrComplexArrayMemorySize(ptr ptr)
145145 stdcall NdrComplexArrayUnmarshall(ptr ptr ptr long)
146146 stdcall NdrComplexStructBufferSize(ptr ptr ptr)
147147 stdcall NdrComplexStructFree(ptr ptr ptr)
148148 stdcall NdrComplexStructMarshall(ptr ptr ptr)
149149 stdcall NdrComplexStructMemorySize(ptr ptr)
150150 stdcall NdrComplexStructUnmarshall(ptr ptr ptr long)
151151 stdcall NdrConformantArrayBufferSize(ptr ptr ptr)
152152 stdcall NdrConformantArrayFree(ptr ptr ptr)
153153 stdcall NdrConformantArrayMarshall(ptr ptr ptr)
154154 stdcall NdrConformantArrayMemorySize(ptr ptr)
155155 stdcall NdrConformantArrayUnmarshall(ptr ptr ptr long)
156156 stdcall NdrConformantStringBufferSize(ptr ptr ptr)
157157 stdcall NdrConformantStringMarshall(ptr ptr ptr)
158158 stdcall NdrConformantStringMemorySize(ptr ptr)
159159 stdcall NdrConformantStringUnmarshall(ptr ptr ptr long)
160160 stdcall NdrConformantStructBufferSize(ptr ptr ptr)
161161 stdcall NdrConformantStructFree(ptr ptr ptr)
162162 stdcall NdrConformantStructMarshall(ptr ptr ptr)
163163 stdcall NdrConformantStructMemorySize(ptr ptr)
164164 stdcall NdrConformantStructUnmarshall(ptr ptr ptr long)
165165 stdcall NdrConformantVaryingArrayBufferSize(ptr ptr ptr)
166166 stdcall NdrConformantVaryingArrayFree(ptr ptr ptr)
167167 stdcall NdrConformantVaryingArrayMarshall(ptr ptr ptr)
168168 stdcall NdrConformantVaryingArrayMemorySize(ptr ptr)
169169 stdcall NdrConformantVaryingArrayUnmarshall(ptr ptr ptr long)
170170 stdcall NdrConformantVaryingStructBufferSize(ptr ptr ptr)
171171 stdcall NdrConformantVaryingStructFree(ptr ptr ptr)
172172 stdcall NdrConformantVaryingStructMarshall(ptr ptr ptr)
173173 stdcall NdrConformantVaryingStructMemorySize(ptr ptr)
174174 stdcall NdrConformantVaryingStructUnmarshall(ptr ptr ptr long)
175175 stdcall NdrContextHandleInitialize(ptr ptr)
176176 stdcall NdrContextHandleSize(ptr ptr ptr)
177177 stdcall NdrConvert2(ptr ptr long)
178178 stdcall NdrConvert(ptr ptr)
179179 stdcall NdrCorrelationFree(ptr)
180180 stdcall NdrCorrelationInitialize(ptr ptr long long)
181181 stdcall NdrCorrelationPass(ptr)
182182 stub NdrCreateServerInterfaceFromStub
183183 stub NdrDcomAsyncClientCall
184184 stub NdrDcomAsyncStubCall
185185 stdcall NdrDllCanUnloadNow(ptr)
186186 stdcall NdrDllGetClassObject(ptr ptr ptr ptr ptr ptr)
187187 stdcall NdrDllRegisterProxy(long ptr ptr)
188188 stdcall NdrDllUnregisterProxy(long ptr ptr)
189189 stdcall NdrEncapsulatedUnionBufferSize(ptr ptr ptr)
190190 stdcall NdrEncapsulatedUnionFree(ptr ptr ptr)
191191 stdcall NdrEncapsulatedUnionMarshall(ptr ptr ptr)
192192 stdcall NdrEncapsulatedUnionMemorySize(ptr ptr)
193193 stdcall NdrEncapsulatedUnionUnmarshall(ptr ptr ptr long)
194194 stdcall NdrFixedArrayBufferSize(ptr ptr ptr)
195195 stdcall NdrFixedArrayFree(ptr ptr ptr)
196196 stdcall NdrFixedArrayMarshall(ptr ptr ptr)
197197 stdcall NdrFixedArrayMemorySize(ptr ptr)
198198 stdcall NdrFixedArrayUnmarshall(ptr ptr ptr long)
199199 stdcall NdrFreeBuffer(ptr)
200200 stdcall NdrFullPointerFree(ptr ptr)
201201 stdcall NdrFullPointerInsertRefId(ptr long ptr)
202202 stdcall NdrFullPointerQueryPointer(ptr ptr long ptr)
203203 stdcall NdrFullPointerQueryRefId(ptr long long ptr)
204204 stdcall NdrFullPointerXlatFree(ptr)
205205 stdcall NdrFullPointerXlatInit(long long)
206206 stdcall NdrGetBuffer(ptr long ptr)
207207 stub NdrGetDcomProtocolVersion
208208 stub NdrGetSimpleTypeBufferAlignment
209209 stub NdrGetSimpleTypeBufferSize
210210 stub NdrGetSimpleTypeMemorySize
211211 stub NdrGetTypeFlags
212212 stdcall NdrGetUserMarshalInfo(ptr long ptr)
213213 stdcall NdrInterfacePointerBufferSize(ptr ptr ptr)
214214 stdcall NdrInterfacePointerFree(ptr ptr ptr)
215215 stdcall NdrInterfacePointerMarshall(ptr ptr ptr)
216216 stdcall NdrInterfacePointerMemorySize(ptr ptr)
217217 stdcall NdrInterfacePointerUnmarshall(ptr ptr ptr long)
218218 stdcall NdrMapCommAndFaultStatus(ptr ptr ptr long)
219219 varargs NdrMesProcEncodeDecode(ptr ptr ptr)
220220 stub NdrMesProcEncodeDecode2
221221 stub NdrMesSimpleTypeAlignSize
222222 stub NdrMesSimpleTypeDecode
223223 stub NdrMesSimpleTypeEncode
224224 stub NdrMesTypeAlignSize2
225225 stub NdrMesTypeAlignSize
226226 stdcall NdrMesTypeDecode2(ptr ptr ptr ptr ptr)
227227 stub NdrMesTypeDecode
228228 stdcall NdrMesTypeEncode2(ptr ptr ptr ptr ptr)
229229 stub NdrMesTypeEncode
230230 stdcall NdrMesTypeFree2(ptr ptr ptr ptr ptr)
231231 stdcall NdrNonConformantStringBufferSize(ptr ptr ptr)
232232 stdcall NdrNonConformantStringMarshall(ptr ptr ptr)
233233 stdcall NdrNonConformantStringMemorySize(ptr ptr)
234234 stdcall NdrNonConformantStringUnmarshall(ptr ptr ptr long)
235235 stdcall NdrNonEncapsulatedUnionBufferSize(ptr ptr ptr)
236236 stdcall NdrNonEncapsulatedUnionFree(ptr ptr ptr)
237237 stdcall NdrNonEncapsulatedUnionMarshall(ptr ptr ptr)
238238 stdcall NdrNonEncapsulatedUnionMemorySize(ptr ptr)
239239 stdcall NdrNonEncapsulatedUnionUnmarshall(ptr ptr ptr long)
240240 stub NdrNsGetBuffer
241241 stub NdrNsSendReceive
242242 stdcall NdrOleAllocate(long)
243243 stdcall NdrOleFree(ptr)
244244 stub NdrOutInit
245245 stub NdrPartialIgnoreClientBufferSize
246246 stub NdrPartialIgnoreClientMarshall
247247 stub NdrPartialIgnoreServerInitialize
248248 stub NdrPartialIgnoreServerUnmarshall
249249 stdcall NdrPointerBufferSize(ptr ptr ptr)
250250 stdcall NdrPointerFree(ptr ptr ptr)
251251 stdcall NdrPointerMarshall(ptr ptr ptr)
252252 stdcall NdrPointerMemorySize(ptr ptr)
253253 stdcall NdrPointerUnmarshall(ptr ptr ptr long)
254254 stdcall NdrProxyErrorHandler(long)
255255 stdcall NdrProxyFreeBuffer(ptr ptr)
256256 stdcall NdrProxyGetBuffer(ptr ptr)
257257 stdcall NdrProxyInitialize(ptr ptr ptr ptr long)
258258 stdcall NdrProxySendReceive(ptr ptr)
259259 stdcall NdrRangeUnmarshall(ptr ptr ptr long)
260260 stub NdrRpcSmClientAllocate
261261 stub NdrRpcSmClientFree
262262 stdcall NdrRpcSmSetClientToOsf(ptr)
263263 stub NdrRpcSsDefaultAllocate
264264 stub NdrRpcSsDefaultFree
265265 stub NdrRpcSsDisableAllocate
266266 stub NdrRpcSsEnableAllocate
267267 stdcall NdrSendReceive(ptr ptr)
268268 stdcall NdrServerCall2(ptr)
269269 stdcall NdrServerCall(ptr)
270@ stdcall -arch=x86_64 NdrServerCallAll(ptr)
271270 stdcall NdrServerContextMarshall(ptr ptr ptr)
272271 stdcall NdrServerContextNewMarshall(ptr ptr ptr ptr)
273272 stdcall NdrServerContextNewUnmarshall(ptr ptr)
274273 stdcall NdrServerContextUnmarshall(ptr)
275274 stub NdrServerInitialize
276275 stub NdrServerInitializeMarshall
277276 stdcall NdrServerInitializeNew(ptr ptr ptr)
278277 stub NdrServerInitializePartial
279278 stub NdrServerInitializeUnmarshall
280279 stub NdrServerMarshall
281280 stub NdrServerUnmarshall
282281 stdcall NdrSimpleStructBufferSize(ptr ptr ptr)
283282 stdcall NdrSimpleStructFree(ptr ptr ptr)
284283 stdcall NdrSimpleStructMarshall(ptr ptr ptr)
285284 stdcall NdrSimpleStructMemorySize(ptr ptr)
286285 stdcall NdrSimpleStructUnmarshall(ptr ptr ptr long)
287286 stdcall NdrSimpleTypeMarshall(ptr ptr long)
288287 stdcall NdrSimpleTypeUnmarshall(ptr ptr long)
289288 stdcall NdrStubCall2(ptr ptr ptr ptr)
290289 stdcall NdrStubCall(ptr ptr ptr ptr)
291290 stdcall NdrStubForwardingFunction(ptr ptr ptr ptr)
292291 stdcall NdrStubGetBuffer(ptr ptr ptr)
293292 stdcall NdrStubInitialize(ptr ptr ptr ptr)
294293 stub NdrStubInitializeMarshall
295294 stub NdrTypeFlags
296295 stub NdrTypeFree
297296 stub NdrTypeMarshall
298297 stub NdrTypeSize
299298 stub NdrTypeUnmarshall
300299 stub NdrUnmarshallBasetypeInline
301300 stdcall NdrUserMarshalBufferSize(ptr ptr ptr)
302301 stdcall NdrUserMarshalFree(ptr ptr ptr)
303302 stdcall NdrUserMarshalMarshall(ptr ptr ptr)
304303 stdcall NdrUserMarshalMemorySize(ptr ptr)
305304 stub NdrUserMarshalSimpleTypeConvert
306305 stdcall NdrUserMarshalUnmarshall(ptr ptr ptr long)
307306 stdcall NdrVaryingArrayBufferSize(ptr ptr ptr)
308307 stdcall NdrVaryingArrayFree(ptr ptr ptr)
309308 stdcall NdrVaryingArrayMarshall(ptr ptr ptr)
310309 stdcall NdrVaryingArrayMemorySize(ptr ptr)
311310 stdcall NdrVaryingArrayUnmarshall(ptr ptr ptr long)
312311 stdcall NdrXmitOrRepAsBufferSize(ptr ptr ptr)
313312 stdcall NdrXmitOrRepAsFree(ptr ptr ptr)
314313 stdcall NdrXmitOrRepAsMarshall(ptr ptr ptr)
315314 stdcall NdrXmitOrRepAsMemorySize(ptr ptr)
316315 stdcall NdrXmitOrRepAsUnmarshall(ptr ptr ptr long)
317316 stub NdrpCreateProxy
318317 stub NdrpCreateStub
319318 stub NdrpGetProcFormatString
320319 stub NdrpGetTypeFormatString
321320 stub NdrpGetTypeGenCookie
322321 stub NdrpMemoryIncrement
323322 stub NdrpReleaseTypeFormatString
324323 stub NdrpReleaseTypeGenCookie
325324 stub NdrpSetRpcSsDefaults
326325 stub NdrpVarVtOfTypeDesc
327326 stdcall RpcAbortAsyncCall(ptr long) RpcAsyncAbortCall
328327 stdcall RpcAsyncAbortCall(ptr long)
329328 stdcall RpcAsyncCancelCall(ptr long)
330329 stdcall RpcAsyncCompleteCall(ptr ptr)
331330 stdcall RpcAsyncGetCallStatus(ptr)
332331 stdcall RpcAsyncInitializeHandle(ptr long)
333332 stub RpcAsyncRegisterInfo
334333 stdcall RpcBindingCopy(ptr ptr)
335334 stdcall RpcBindingFree(ptr)
336335 stdcall RpcBindingFromStringBindingA(str  ptr)
337336 stdcall RpcBindingFromStringBindingW(wstr ptr)
338337 stdcall RpcBindingInqAuthClientA(ptr ptr ptr ptr ptr ptr)
339338 stdcall RpcBindingInqAuthClientExA(ptr ptr ptr ptr ptr ptr long)
340339 stdcall RpcBindingInqAuthClientExW(ptr ptr ptr ptr ptr ptr long)
341340 stdcall RpcBindingInqAuthClientW(ptr ptr ptr ptr ptr ptr)
342341 stdcall RpcBindingInqAuthInfoA(ptr ptr ptr ptr ptr ptr)
343342 stdcall RpcBindingInqAuthInfoExA(ptr ptr ptr ptr ptr ptr long ptr)
344343 stdcall RpcBindingInqAuthInfoExW(ptr ptr ptr ptr ptr ptr long ptr)
345344 stdcall RpcBindingInqAuthInfoW(ptr ptr ptr ptr ptr ptr)
346345 stdcall RpcBindingInqObject(ptr ptr)
347346 stub RpcBindingInqOption
348347 stdcall RpcBindingReset(ptr)
349348 stdcall RpcBindingServerFromClient(ptr ptr)
350349 stdcall RpcBindingSetAuthInfoA(ptr str long long ptr long)
351350 stdcall RpcBindingSetAuthInfoExA(ptr str long long ptr long ptr)
352351 stdcall RpcBindingSetAuthInfoExW(ptr wstr long long ptr long ptr)
353352 stdcall RpcBindingSetAuthInfoW(ptr wstr long long ptr long)
354353 stdcall RpcBindingSetObject(ptr ptr)
355354 stdcall RpcBindingSetOption(ptr long long)
356355 stdcall RpcBindingToStringBindingA(ptr ptr)
357356 stdcall RpcBindingToStringBindingW(ptr ptr)
358357 stdcall RpcBindingVectorFree(ptr)
359358 stdcall RpcCancelAsyncCall(ptr long) RpcAsyncCancelCall
360359 stdcall RpcCancelThread(ptr)
361360 stdcall RpcCancelThreadEx(ptr long)
362361 stub RpcCertGeneratePrincipalNameA
363362 stub RpcCertGeneratePrincipalNameW
364363 stdcall RpcCompleteAsyncCall(ptr ptr) RpcAsyncCompleteCall
365364 stdcall RpcEpRegisterA(ptr ptr ptr str)
366365 stdcall RpcEpRegisterNoReplaceA(ptr ptr ptr str)
367366 stdcall RpcEpRegisterNoReplaceW(ptr ptr ptr wstr)
368367 stdcall RpcEpRegisterW(ptr ptr ptr wstr)
369368 stdcall RpcEpResolveBinding(ptr ptr)
370369 stdcall RpcEpUnregister(ptr ptr ptr)
371370 stub RpcErrorAddRecord
372371 stub RpcErrorClearInformation
373372 stdcall RpcErrorEndEnumeration(ptr)
374373 stdcall RpcErrorGetNextRecord(ptr long ptr)
375# RpcErrorGetNumberOfRecords
376375 stdcall RpcErrorLoadErrorInfo(ptr long ptr)
377376 stub RpcErrorResetEnumeration
378377 stdcall RpcErrorSaveErrorInfo(ptr ptr ptr)
379378 stdcall RpcErrorStartEnumeration(ptr)
380379 stub RpcFreeAuthorizationContext
381380 stdcall RpcGetAsyncCallStatus(ptr) RpcAsyncGetCallStatus
382381 stdcall RpcGetAuthorizationContextForClient(ptr long ptr ptr int64 long ptr ptr)
383382 stub RpcIfIdVectorFree
384383 stub RpcIfInqId
385384 stdcall RpcImpersonateClient(ptr)
386385 stdcall RpcInitializeAsyncHandle(ptr long) RpcAsyncInitializeHandle
387386 stdcall RpcMgmtEnableIdleCleanup()
388387 stdcall RpcMgmtEpEltInqBegin(ptr long ptr long ptr ptr)
389388 stub RpcMgmtEpEltInqDone
390389 stub RpcMgmtEpEltInqNextA
391390 stub RpcMgmtEpEltInqNextW
392391 stub RpcMgmtEpUnregister
393392 stub RpcMgmtInqComTimeout
394393 stub RpcMgmtInqDefaultProtectLevel
395394 stdcall RpcMgmtInqIfIds(ptr ptr)
396395 stdcall -stub RpcMgmtInqServerPrincNameA(ptr long ptr)
397396 stdcall -stub RpcMgmtInqServerPrincNameW(ptr long ptr)
398397 stdcall RpcMgmtInqStats(ptr ptr)
399398 stdcall RpcMgmtIsServerListening(ptr)
400399 stdcall RpcMgmtSetAuthorizationFn(ptr)
401400 stdcall RpcMgmtSetCancelTimeout(long)
402401 stdcall RpcMgmtSetComTimeout(ptr long)
403402 stdcall RpcMgmtSetServerStackSize(long)
404403 stdcall RpcMgmtStatsVectorFree(ptr)
405404 stdcall RpcMgmtStopServerListening(ptr)
406405 stdcall RpcMgmtWaitServerListen()
407406 stdcall RpcNetworkInqProtseqsA(ptr)
408407 stdcall RpcNetworkInqProtseqsW(ptr)
409408 stdcall RpcNetworkIsProtseqValidA(str)
410409 stdcall RpcNetworkIsProtseqValidW(wstr)
411410 stub RpcNsBindingInqEntryNameA
412411 stub RpcNsBindingInqEntryNameW
413412 stub RpcObjectInqType
414413 stub RpcObjectSetInqFn
415414 stdcall RpcObjectSetType(ptr ptr)
416415 stdcall RpcProtseqVectorFreeA(ptr)
417416 stdcall RpcProtseqVectorFreeW(ptr)
418417 stdcall RpcRaiseException(long)
419418 stub RpcRegisterAsyncInfo
420419 stdcall RpcRevertToSelf()
421420 stdcall RpcRevertToSelfEx(ptr)
422421 stdcall RpcServerInqBindings(ptr)
423422 stub RpcServerInqCallAttributesA
424423 stub RpcServerInqCallAttributesW
425424 stdcall RpcServerInqDefaultPrincNameA(long ptr)
426425 stdcall RpcServerInqDefaultPrincNameW(long ptr)
427426 stub RpcServerInqIf
428427 stdcall RpcServerListen(long long long)
429428 stdcall RpcServerRegisterAuthInfoA(str  long ptr ptr)
430429 stdcall RpcServerRegisterAuthInfoW(wstr long ptr ptr)
431430 stdcall RpcServerRegisterIf2(ptr ptr ptr long long long ptr)
432431 stdcall RpcServerRegisterIf(ptr ptr ptr)
433432 stdcall RpcServerRegisterIfEx(ptr ptr ptr long long ptr)
434433 stub RpcServerTestCancel
435434 stdcall RpcServerUnregisterIf(ptr ptr long)
436435 stdcall RpcServerUnregisterIfEx(ptr ptr long)
437436 stub RpcServerUseAllProtseqs
438437 stub RpcServerUseAllProtseqsEx
439438 stub RpcServerUseAllProtseqsIf
440439 stub RpcServerUseAllProtseqsIfEx
441440 stdcall RpcServerUseProtseqA(str long ptr)
442441 stdcall RpcServerUseProtseqEpA(str  long str  ptr)
443442 stdcall RpcServerUseProtseqEpExA(str  long str  ptr ptr)
444443 stdcall RpcServerUseProtseqEpExW(wstr long wstr ptr ptr)
445444 stdcall RpcServerUseProtseqEpW(wstr long wstr ptr)
446445 stub RpcServerUseProtseqExA
447446 stub RpcServerUseProtseqExW
448447 stub RpcServerUseProtseqIfA
449448 stub RpcServerUseProtseqIfExA
450449 stub RpcServerUseProtseqIfExW
451450 stub RpcServerUseProtseqIfW
452451 stdcall RpcServerUseProtseqW(wstr long ptr)
453452 stub RpcServerYield
454453 stub RpcSmAllocate
455454 stub RpcSmClientFree
456455 stdcall RpcSmDestroyClientContext(ptr)
457456 stub RpcSmDisableAllocate
458457 stub RpcSmEnableAllocate
459458 stub RpcSmFree
460459 stub RpcSmGetThreadHandle
461460 stub RpcSmSetClientAllocFree
462461 stub RpcSmSetThreadHandle
463462 stub RpcSmSwapClientAllocFree
464463 stub RpcSsAllocate
465464 stub RpcSsContextLockExclusive
466465 stub RpcSsContextLockShared
467466 stdcall RpcSsDestroyClientContext(ptr)
468467 stub RpcSsDisableAllocate
469468 stdcall RpcSsDontSerializeContext()
470469 stub RpcSsEnableAllocate
471470 stub RpcSsFree
472471 stub RpcSsGetContextBinding
473472 stub RpcSsGetThreadHandle
474473 stub RpcSsSetClientAllocFree
475474 stub RpcSsSetThreadHandle
476475 stub RpcSsSwapClientAllocFree
477476 stdcall RpcStringBindingComposeA(str str str str str ptr)
478477 stdcall RpcStringBindingComposeW(wstr wstr wstr wstr wstr ptr)
479478 stdcall RpcStringBindingParseA(str  ptr ptr ptr ptr ptr)
480479 stdcall RpcStringBindingParseW(wstr ptr ptr ptr ptr ptr)
481480 stdcall RpcStringFreeA(ptr)
482481 stdcall RpcStringFreeW(ptr)
483482 stub RpcTestCancel
484483 stub RpcUserFree
485484 stub SimpleTypeAlignment
486485 stub SimpleTypeBufferSize
487486 stub SimpleTypeMemorySize
488487 stdcall TowerConstruct(ptr ptr ptr ptr ptr ptr)
489488 stdcall TowerExplode(ptr ptr ptr ptr ptr ptr)
490489 stdcall UuidCompare(ptr ptr ptr)
491490 stdcall UuidCreate(ptr)
492491 stdcall UuidCreateNil(ptr)
493492 stdcall UuidCreateSequential(ptr)
494493 stdcall UuidEqual(ptr ptr ptr)
495494 stdcall UuidFromStringA(str ptr)
496495 stdcall UuidFromStringW(wstr ptr)
497496 stdcall UuidHash(ptr ptr)
498497 stdcall UuidIsNil(ptr ptr)
499498 stdcall UuidToStringA(ptr ptr)
500499 stdcall UuidToStringW(ptr ptr)
501500 stub char_array_from_ndr
502501 stub char_from_ndr
503502 stub data_from_ndr
504503 stub data_into_ndr
505504 stub data_size_ndr
506505 stub double_array_from_ndr
507506 stub double_from_ndr
508507 stub enum_from_ndr
509508 stub float_array_from_ndr
510509 stub float_from_ndr
511510 stub long_array_from_ndr
512511 stub long_from_ndr
513512 stub long_from_ndr_temp
514513 stub pfnFreeRoutines
515514 stub pfnMarshallRoutines
516515 stub pfnSizeRoutines
517516 stub pfnUnmarshallRoutines
518517 stub short_array_from_ndr
519518 stub short_from_ndr
520519 stub short_from_ndr_temp
521520 stub tree_into_ndr
522521 stub tree_peek_ndr
523522 stub tree_size_ndr
524