xref: /reactos/dll/win32/rpcrt4/rpcrt4.spec (revision 7eead935)
11 stdcall CreateProxyFromTypeInfo(ptr ptr ptr ptr ptr)
22 stdcall CreateStubFromTypeInfo(ptr ptr ptr ptr)
3# I_RpcServerTurnOnOffKeepalives
44 stdcall CStdStubBuffer_AddRef(ptr)
55 stdcall CStdStubBuffer_Connect(ptr ptr)
66 stdcall CStdStubBuffer_CountRefs(ptr)
77 stdcall CStdStubBuffer_DebugServerQueryInterface(ptr ptr)
88 stdcall CStdStubBuffer_DebugServerRelease(ptr ptr)
99 stdcall CStdStubBuffer_Disconnect(ptr)
1010 stdcall CStdStubBuffer_Invoke(ptr ptr ptr)
1111 stdcall CStdStubBuffer_IsIIDSupported(ptr ptr)
1212 stdcall CStdStubBuffer_QueryInterface(ptr ptr ptr)
1313 stdcall DceErrorInqTextA (long ptr)
1414 stdcall DceErrorInqTextW (long ptr)
15# DllGetClassObject
16# DllInstall
17@ stdcall -private DllRegisterServer()
1818 stub GlobalMutexClearExternal
1919 stub GlobalMutexRequestExternal
2020 stdcall IUnknown_AddRef_Proxy(ptr)
2121 stdcall IUnknown_QueryInterface_Proxy(ptr ptr ptr)
2222 stdcall IUnknown_Release_Proxy(ptr)
2323 stdcall I_RpcAbortAsyncCall(ptr long) I_RpcAsyncAbortCall
2424 stdcall I_RpcAllocate(long)
2525 stdcall I_RpcAsyncAbortCall(ptr long)
2626 stdcall I_RpcAsyncSetHandle(ptr ptr)
2727 stub I_RpcBCacheAllocate
2828 stub I_RpcBCacheFree
2929 stub I_RpcBindingCopy
30# I_RpcBindingHandleToAsyncHandle
3131 stub I_RpcBindingInqConnId
3232 stub I_RpcBindingInqDynamicEndPoint
3333 stub I_RpcBindingInqDynamicEndPointA
3434 stub I_RpcBindingInqDynamicEndPointW
3535 stdcall I_RpcBindingInqLocalClientPID(ptr ptr)
36# I_RpcBindingInqMarshalledTargetInfo
3737 stub I_RpcBindingInqSecurityContext
3838 stdcall I_RpcBindingInqTransportType(ptr ptr)
3939 stub I_RpcBindingInqWireIdForSnego
4040 stub I_RpcBindingIsClientLocal
4141 stub I_RpcBindingToStaticStringBindingW
4242 stub I_RpcClearMutex
4343 stub I_RpcConnectionInqSockBuffSize
4444 stub I_RpcConnectionSetSockBuffSize
4545 stub I_RpcDeleteMutex
4646 stub I_RpcEnableWmiTrace
4747 stdcall I_RpcExceptionFilter(long) RpcExceptionFilter
4848 stdcall I_RpcFree(ptr)
4949 stdcall I_RpcFreeBuffer(ptr)
5050 stub I_RpcFreePipeBuffer
5151 stdcall I_RpcGetBuffer(ptr)
5252 stub I_RpcGetBufferWithObject
5353 stdcall I_RpcGetCurrentCallHandle()
5454 stub I_RpcGetExtendedError
5555 stub I_RpcIfInqTransferSyntaxes
5656 stub I_RpcLogEvent
5757 stdcall I_RpcMapWin32Status(long)
58# I_RpcNDRCGetWireRepresentation
59# I_RpcNDRSContextEmergencyCleanup
6060 stdcall I_RpcNegotiateTransferSyntax(ptr)
6161 stub I_RpcNsBindingSetEntryName
6262 stub I_RpcNsBindingSetEntryNameA
6363 stub I_RpcNsBindingSetEntryNameW
6464 stub I_RpcNsInterfaceExported
6565 stub I_RpcNsInterfaceUnexported
6666 stub I_RpcParseSecurity
6767 stub I_RpcPauseExecution
6868 stub I_RpcProxyNewConnection
6969 stub I_RpcReallocPipeBuffer
7070 stdcall I_RpcReceive(ptr)
71# I_RpcRecordCalloutFailure
72# I_RpcReplyToClientWithStatus
7373 stub I_RpcRequestMutex
74# I_RpcSNCHOption
7575 stdcall I_RpcSend(ptr)
7676 stdcall I_RpcSendReceive(ptr)
7777 stub I_RpcServerAllocateIpPort
78# I_RpcServerCheckClientRestriction
7979 stub I_RpcServerInqAddressChangeFn
8080 stub I_RpcServerInqLocalConnAddress
8181 stub I_RpcServerInqTransportType
82# I_RpcServerIsClientDisconnected
8383 stub I_RpcServerRegisterForwardFunction
8484 stub I_RpcServerSetAddressChangeFn
8585 stub I_RpcServerUseProtseq2A
8686 stub I_RpcServerUseProtseq2W
8787 stub I_RpcServerUseProtseqEp2A
8888 stub I_RpcServerUseProtseqEp2W
89# I_RpcSessionStrictContextHandle
9090 stub I_RpcSetAsyncHandle
9191 stub I_RpcSsDontSerializeContext
9292 stub I_RpcSystemFunction001
9393 stub I_RpcTransConnectionAllocatePacket
9494 stub I_RpcTransConnectionFreePacket
9595 stub I_RpcTransConnectionReallocPacket
9696 stub I_RpcTransDatagramAllocate2
9797 stub I_RpcTransDatagramAllocate
9898 stub I_RpcTransDatagramFree
9999 stub I_RpcTransGetThreadEvent
100100 stub I_RpcTransIoCancelled
101101 stub I_RpcTransServerNewConnection
102102 stub I_RpcTurnOnEEInfoPropagation
103103 stdcall I_UuidCreate(ptr)
104104 stub MIDL_wchar_strcpy
105105 stub MIDL_wchar_strlen
106106 stdcall MesBufferHandleReset(ptr long long ptr long ptr)
107107 stdcall MesDecodeBufferHandleCreate(ptr long ptr)
108108 stdcall MesDecodeIncrementalHandleCreate(ptr ptr ptr)
109109 stdcall MesEncodeDynBufferHandleCreate(ptr ptr ptr)
110110 stdcall MesEncodeFixedBufferHandleCreate(ptr long ptr ptr)
111111 stdcall MesEncodeIncrementalHandleCreate(ptr ptr ptr ptr)
112112 stdcall MesHandleFree(ptr)
113113 stdcall MesIncrementalHandleReset(ptr ptr ptr ptr ptr long)
114114 stub MesInqProcEncodingId
115115 stdcall NDRCContextBinding(ptr)
116116 stdcall NDRCContextMarshall(ptr ptr)
117117 stdcall NDRCContextUnmarshall(ptr ptr ptr long)
118118 stdcall NDRSContextMarshall2(ptr ptr ptr ptr ptr long)
119119 stdcall NDRSContextMarshall(ptr ptr ptr)
120120 stdcall NDRSContextMarshallEx(ptr ptr ptr ptr)
121121 stdcall NDRSContextUnmarshall2(ptr ptr long ptr long)
122122 stdcall NDRSContextUnmarshall(ptr long)
123123 stdcall NDRSContextUnmarshallEx(ptr ptr long)
124124 stub NDRcopy
125125 stdcall NdrAllocate(ptr long)
126126 varargs NdrAsyncClientCall(ptr ptr)
127127 stdcall NdrAsyncServerCall(ptr)
128128 stdcall NdrByteCountPointerBufferSize(ptr ptr ptr)
129129 stdcall NdrByteCountPointerFree(ptr ptr ptr)
130130 stdcall NdrByteCountPointerMarshall(ptr ptr ptr)
131131 stdcall NdrByteCountPointerUnmarshall(ptr ptr ptr long)
132132 stdcall NdrCStdStubBuffer2_Release(ptr ptr)
133133 stdcall NdrCStdStubBuffer_Release(ptr ptr)
134134 stdcall NdrClearOutParameters(ptr ptr ptr)
135135 varargs -arch=i386 NdrClientCall(ptr ptr) NdrClientCall2
136136 varargs NdrClientCall2(ptr ptr)
137137 stdcall NdrClientContextMarshall(ptr ptr long)
138138 stdcall NdrClientContextUnmarshall(ptr ptr ptr)
139139 stub NdrClientInitialize
140140 stdcall NdrClientInitializeNew(ptr ptr ptr long)
141141 stdcall NdrComplexArrayBufferSize(ptr ptr ptr)
142142 stdcall NdrComplexArrayFree(ptr ptr ptr)
143143 stdcall NdrComplexArrayMarshall(ptr ptr ptr)
144144 stdcall NdrComplexArrayMemorySize(ptr ptr)
145145 stdcall NdrComplexArrayUnmarshall(ptr ptr ptr long)
146146 stdcall NdrComplexStructBufferSize(ptr ptr ptr)
147147 stdcall NdrComplexStructFree(ptr ptr ptr)
148148 stdcall NdrComplexStructMarshall(ptr ptr ptr)
149149 stdcall NdrComplexStructMemorySize(ptr ptr)
150150 stdcall NdrComplexStructUnmarshall(ptr ptr ptr long)
151151 stdcall NdrConformantArrayBufferSize(ptr ptr ptr)
152152 stdcall NdrConformantArrayFree(ptr ptr ptr)
153153 stdcall NdrConformantArrayMarshall(ptr ptr ptr)
154154 stdcall NdrConformantArrayMemorySize(ptr ptr)
155155 stdcall NdrConformantArrayUnmarshall(ptr ptr ptr long)
156156 stdcall NdrConformantStringBufferSize(ptr ptr ptr)
157157 stdcall NdrConformantStringMarshall(ptr ptr ptr)
158158 stdcall NdrConformantStringMemorySize(ptr ptr)
159159 stdcall NdrConformantStringUnmarshall(ptr ptr ptr long)
160160 stdcall NdrConformantStructBufferSize(ptr ptr ptr)
161161 stdcall NdrConformantStructFree(ptr ptr ptr)
162162 stdcall NdrConformantStructMarshall(ptr ptr ptr)
163163 stdcall NdrConformantStructMemorySize(ptr ptr)
164164 stdcall NdrConformantStructUnmarshall(ptr ptr ptr long)
165165 stdcall NdrConformantVaryingArrayBufferSize(ptr ptr ptr)
166166 stdcall NdrConformantVaryingArrayFree(ptr ptr ptr)
167167 stdcall NdrConformantVaryingArrayMarshall(ptr ptr ptr)
168168 stdcall NdrConformantVaryingArrayMemorySize(ptr ptr)
169169 stdcall NdrConformantVaryingArrayUnmarshall(ptr ptr ptr long)
170170 stdcall NdrConformantVaryingStructBufferSize(ptr ptr ptr)
171171 stdcall NdrConformantVaryingStructFree(ptr ptr ptr)
172172 stdcall NdrConformantVaryingStructMarshall(ptr ptr ptr)
173173 stdcall NdrConformantVaryingStructMemorySize(ptr ptr)
174174 stdcall NdrConformantVaryingStructUnmarshall(ptr ptr ptr long)
175175 stdcall NdrContextHandleInitialize(ptr ptr)
176176 stdcall NdrContextHandleSize(ptr ptr ptr)
177177 stdcall NdrConvert2(ptr ptr long)
178178 stdcall NdrConvert(ptr ptr)
179179 stdcall NdrCorrelationFree(ptr)
180180 stdcall NdrCorrelationInitialize(ptr ptr long long)
181181 stdcall NdrCorrelationPass(ptr)
182# NdrCreateServerInterfaceFromStub
183183 stub NdrDcomAsyncClientCall
184184 stub NdrDcomAsyncStubCall
185185 stdcall NdrDllCanUnloadNow(ptr)
186186 stdcall NdrDllGetClassObject(ptr ptr ptr ptr ptr ptr)
187187 stdcall NdrDllRegisterProxy(long ptr ptr)
188188 stdcall NdrDllUnregisterProxy(long ptr ptr)
189189 stdcall NdrEncapsulatedUnionBufferSize(ptr ptr ptr)
190190 stdcall NdrEncapsulatedUnionFree(ptr ptr ptr)
191191 stdcall NdrEncapsulatedUnionMarshall(ptr ptr ptr)
192192 stdcall NdrEncapsulatedUnionMemorySize(ptr ptr)
193193 stdcall NdrEncapsulatedUnionUnmarshall(ptr ptr ptr long)
194194 stdcall NdrFixedArrayBufferSize(ptr ptr ptr)
195195 stdcall NdrFixedArrayFree(ptr ptr ptr)
196196 stdcall NdrFixedArrayMarshall(ptr ptr ptr)
197197 stdcall NdrFixedArrayMemorySize(ptr ptr)
198198 stdcall NdrFixedArrayUnmarshall(ptr ptr ptr long)
199199 stdcall NdrFreeBuffer(ptr)
200200 stdcall NdrFullPointerFree(ptr ptr)
201201 stdcall NdrFullPointerInsertRefId(ptr long ptr)
202202 stdcall NdrFullPointerQueryPointer(ptr ptr long ptr)
203203 stdcall NdrFullPointerQueryRefId(ptr long long ptr)
204204 stdcall NdrFullPointerXlatFree(ptr)
205205 stdcall NdrFullPointerXlatInit(long long)
206206 stdcall NdrGetBuffer(ptr long ptr)
207207 stub NdrGetDcomProtocolVersion
208208 stub NdrGetSimpleTypeBufferAlignment
209209 stub NdrGetSimpleTypeBufferSize
210210 stub NdrGetSimpleTypeMemorySize
211211 stub NdrGetTypeFlags
212212 stdcall NdrGetUserMarshalInfo(ptr long ptr)
213213 stdcall NdrInterfacePointerBufferSize(ptr ptr ptr)
214214 stdcall NdrInterfacePointerFree(ptr ptr ptr)
215215 stdcall NdrInterfacePointerMarshall(ptr ptr ptr)
216216 stdcall NdrInterfacePointerMemorySize(ptr ptr)
217217 stdcall NdrInterfacePointerUnmarshall(ptr ptr ptr long)
218218 stdcall NdrMapCommAndFaultStatus(ptr ptr ptr long)
219219 varargs NdrMesProcEncodeDecode(ptr ptr ptr)
220220 stub NdrMesProcEncodeDecode2
221221 stub NdrMesSimpleTypeAlignSize
222222 stub NdrMesSimpleTypeDecode
223223 stub NdrMesSimpleTypeEncode
224224 stub NdrMesTypeAlignSize2
225225 stub NdrMesTypeAlignSize
226226 stdcall NdrMesTypeDecode2(ptr ptr ptr ptr ptr)
227227 stub NdrMesTypeDecode
228228 stdcall NdrMesTypeEncode2(ptr ptr ptr ptr ptr)
229229 stub NdrMesTypeEncode
230230 stdcall NdrMesTypeFree2(ptr ptr ptr ptr ptr)
231231 stdcall NdrNonConformantStringBufferSize(ptr ptr ptr)
232232 stdcall NdrNonConformantStringMarshall(ptr ptr ptr)
233233 stdcall NdrNonConformantStringMemorySize(ptr ptr)
234234 stdcall NdrNonConformantStringUnmarshall(ptr ptr ptr long)
235235 stdcall NdrNonEncapsulatedUnionBufferSize(ptr ptr ptr)
236236 stdcall NdrNonEncapsulatedUnionFree(ptr ptr ptr)
237237 stdcall NdrNonEncapsulatedUnionMarshall(ptr ptr ptr)
238238 stdcall NdrNonEncapsulatedUnionMemorySize(ptr ptr)
239239 stdcall NdrNonEncapsulatedUnionUnmarshall(ptr ptr ptr long)
240240 stub NdrNsGetBuffer
241241 stub NdrNsSendReceive
242242 stdcall NdrOleAllocate(long)
243243 stdcall NdrOleFree(ptr)
244244 stub NdrOutInit
245245 stub NdrPartialIgnoreClientBufferSize
246246 stub NdrPartialIgnoreClientMarshall
247247 stub NdrPartialIgnoreServerInitialize
248248 stub NdrPartialIgnoreServerUnmarshall
249249 stdcall NdrPointerBufferSize(ptr ptr ptr)
250250 stdcall NdrPointerFree(ptr ptr ptr)
251251 stdcall NdrPointerMarshall(ptr ptr ptr)
252252 stdcall NdrPointerMemorySize(ptr ptr)
253253 stdcall NdrPointerUnmarshall(ptr ptr ptr long)
254254 stdcall NdrProxyErrorHandler(long)
255255 stdcall NdrProxyFreeBuffer(ptr ptr)
256256 stdcall NdrProxyGetBuffer(ptr ptr)
257257 stdcall NdrProxyInitialize(ptr ptr ptr ptr long)
258258 stdcall NdrProxySendReceive(ptr ptr)
259259 stdcall NdrRangeUnmarshall(ptr ptr ptr long)
260260 stub NdrRpcSmClientAllocate
261261 stub NdrRpcSmClientFree
262262 stdcall NdrRpcSmSetClientToOsf(ptr)
263263 stub NdrRpcSsDefaultAllocate
264264 stub NdrRpcSsDefaultFree
265265 stub NdrRpcSsDisableAllocate
266266 stub NdrRpcSsEnableAllocate
267267 stdcall NdrSendReceive(ptr ptr)
268268 stdcall NdrServerCall2(ptr)
269269 stdcall NdrServerCall(ptr)
270270 stdcall NdrServerContextMarshall(ptr ptr long)
271271 stdcall NdrServerContextNewMarshall(ptr ptr ptr ptr)
272272 stdcall NdrServerContextNewUnmarshall(ptr ptr)
273273 stdcall NdrServerContextUnmarshall(ptr)
274274 stub NdrServerInitialize
275275 stub NdrServerInitializeMarshall
276276 stdcall NdrServerInitializeNew(ptr ptr ptr)
277277 stub NdrServerInitializePartial
278278 stub NdrServerInitializeUnmarshall
279279 stub NdrServerMarshall
280280 stub NdrServerUnmarshall
281281 stdcall NdrSimpleStructBufferSize(ptr ptr ptr)
282282 stdcall NdrSimpleStructFree(ptr ptr ptr)
283283 stdcall NdrSimpleStructMarshall(ptr ptr ptr)
284284 stdcall NdrSimpleStructMemorySize(ptr ptr)
285285 stdcall NdrSimpleStructUnmarshall(ptr ptr ptr long)
286286 stdcall NdrSimpleTypeMarshall(ptr ptr long)
287287 stdcall NdrSimpleTypeUnmarshall(ptr ptr long)
288288 stdcall NdrStubCall2(ptr ptr ptr ptr)
289289 stdcall NdrStubCall(ptr ptr ptr ptr)
290290 stdcall NdrStubForwardingFunction(ptr ptr ptr ptr)
291291 stdcall NdrStubGetBuffer(ptr ptr ptr)
292292 stdcall NdrStubInitialize(ptr ptr ptr ptr)
293293 stub NdrStubInitializeMarshall
294294 stub NdrTypeFlags
295295 stub NdrTypeFree
296296 stub NdrTypeMarshall
297297 stub NdrTypeSize
298298 stub NdrTypeUnmarshall
299299 stub NdrUnmarshallBasetypeInline
300300 stdcall NdrUserMarshalBufferSize(ptr ptr ptr)
301301 stdcall NdrUserMarshalFree(ptr ptr ptr)
302302 stdcall NdrUserMarshalMarshall(ptr ptr ptr)
303303 stdcall NdrUserMarshalMemorySize(ptr ptr)
304304 stub NdrUserMarshalSimpleTypeConvert
305305 stdcall NdrUserMarshalUnmarshall(ptr ptr ptr long)
306306 stdcall NdrVaryingArrayBufferSize(ptr ptr ptr)
307307 stdcall NdrVaryingArrayFree(ptr ptr ptr)
308308 stdcall NdrVaryingArrayMarshall(ptr ptr ptr)
309309 stdcall NdrVaryingArrayMemorySize(ptr ptr)
310310 stdcall NdrVaryingArrayUnmarshall(ptr ptr ptr long)
311311 stdcall NdrXmitOrRepAsBufferSize(ptr ptr ptr)
312312 stdcall NdrXmitOrRepAsFree(ptr ptr ptr)
313313 stdcall NdrXmitOrRepAsMarshall(ptr ptr ptr)
314314 stdcall NdrXmitOrRepAsMemorySize(ptr ptr)
315315 stdcall NdrXmitOrRepAsUnmarshall(ptr ptr ptr long)
316316 stub NdrpCreateProxy
317317 stub NdrpCreateStub
318318 stub NdrpGetProcFormatString
319319 stub NdrpGetTypeFormatString
320320 stub NdrpGetTypeGenCookie
321321 stub NdrpMemoryIncrement
322322 stub NdrpReleaseTypeFormatString
323323 stub NdrpReleaseTypeGenCookie
324324 stub NdrpSetRpcSsDefaults
325325 stub NdrpVarVtOfTypeDesc
326326 stdcall RpcAbortAsyncCall(ptr long) RpcAsyncAbortCall
327327 stdcall RpcAsyncAbortCall(ptr long)
328328 stdcall RpcAsyncCancelCall(ptr long)
329329 stdcall RpcAsyncCompleteCall(ptr ptr)
330330 stdcall RpcAsyncGetCallStatus(ptr)
331331 stdcall RpcAsyncInitializeHandle(ptr long)
332332 stub RpcAsyncRegisterInfo
333333 stdcall RpcBindingCopy(ptr ptr)
334334 stdcall RpcBindingFree(ptr)
335335 stdcall RpcBindingFromStringBindingA(str  ptr)
336336 stdcall RpcBindingFromStringBindingW(wstr ptr)
337337 stdcall RpcBindingInqAuthClientA(ptr ptr ptr ptr ptr ptr)
338338 stdcall RpcBindingInqAuthClientExA(ptr ptr ptr ptr ptr ptr long)
339339 stdcall RpcBindingInqAuthClientExW(ptr ptr ptr ptr ptr ptr long)
340340 stdcall RpcBindingInqAuthClientW(ptr ptr ptr ptr ptr ptr)
341341 stdcall RpcBindingInqAuthInfoA(ptr ptr ptr ptr ptr ptr)
342342 stdcall RpcBindingInqAuthInfoExA(ptr ptr ptr ptr ptr ptr long ptr)
343343 stdcall RpcBindingInqAuthInfoExW(ptr ptr ptr ptr ptr ptr long ptr)
344344 stdcall RpcBindingInqAuthInfoW(ptr ptr ptr ptr ptr ptr)
345345 stdcall RpcBindingInqObject(ptr ptr)
346346 stub RpcBindingInqOption
347347 stdcall RpcBindingReset(ptr)
348348 stdcall RpcBindingServerFromClient(ptr ptr)
349349 stdcall RpcBindingSetAuthInfoA(ptr str long long ptr long)
350350 stdcall RpcBindingSetAuthInfoExA(ptr str long long ptr long ptr)
351351 stdcall RpcBindingSetAuthInfoExW(ptr wstr long long ptr long ptr)
352352 stdcall RpcBindingSetAuthInfoW(ptr wstr long long ptr long)
353353 stdcall RpcBindingSetObject(ptr ptr)
354354 stdcall RpcBindingSetOption(ptr long long)
355355 stdcall RpcBindingToStringBindingA(ptr ptr)
356356 stdcall RpcBindingToStringBindingW(ptr ptr)
357357 stdcall RpcBindingVectorFree(ptr)
358358 stdcall RpcCancelAsyncCall(ptr long) RpcAsyncCancelCall
359359 stdcall RpcCancelThread(ptr)
360360 stdcall RpcCancelThreadEx(ptr long)
361361 stub RpcCertGeneratePrincipalNameA
362362 stub RpcCertGeneratePrincipalNameW
363363 stdcall RpcCompleteAsyncCall(ptr ptr) RpcAsyncCompleteCall
364364 stdcall RpcEpRegisterA(ptr ptr ptr str)
365365 stdcall RpcEpRegisterNoReplaceA(ptr ptr ptr str)
366366 stdcall RpcEpRegisterNoReplaceW(ptr ptr ptr wstr)
367367 stdcall RpcEpRegisterW(ptr ptr ptr wstr)
368368 stdcall RpcEpResolveBinding(ptr ptr)
369369 stdcall RpcEpUnregister(ptr ptr ptr)
370370 stub RpcErrorAddRecord
371371 stub RpcErrorClearInformation
372372 stdcall RpcErrorEndEnumeration(ptr)
373373 stdcall RpcErrorGetNextRecord(ptr long ptr)
374# RpcErrorGetNumberOfRecords
375375 stdcall RpcErrorLoadErrorInfo(ptr long ptr)
376376 stub RpcErrorResetEnumeration
377377 stdcall RpcErrorSaveErrorInfo(ptr ptr ptr)
378378 stdcall RpcErrorStartEnumeration(ptr)
379379 stub RpcFreeAuthorizationContext
380380 stdcall RpcGetAsyncCallStatus(ptr) RpcAsyncGetCallStatus
381# RpcGetAuthorizationContextForClient
382382 stub RpcIfIdVectorFree
383383 stub RpcIfInqId
384384 stdcall RpcImpersonateClient(ptr)
385385 stdcall RpcInitializeAsyncHandle(ptr long) RpcAsyncInitializeHandle
386386 stdcall RpcMgmtEnableIdleCleanup()
387387 stdcall RpcMgmtEpEltInqBegin(ptr long ptr long ptr ptr)
388388 stub RpcMgmtEpEltInqDone
389389 stub RpcMgmtEpEltInqNextA
390390 stub RpcMgmtEpEltInqNextW
391391 stub RpcMgmtEpUnregister
392392 stub RpcMgmtInqComTimeout
393393 stub RpcMgmtInqDefaultProtectLevel
394394 stdcall RpcMgmtInqIfIds(ptr ptr)
395395 stdcall -stub RpcMgmtInqServerPrincNameA(ptr long ptr)
396396 stdcall -stub RpcMgmtInqServerPrincNameW(ptr long ptr)
397397 stdcall RpcMgmtInqStats(ptr ptr)
398398 stdcall RpcMgmtIsServerListening(ptr)
399399 stdcall RpcMgmtSetAuthorizationFn(ptr)
400400 stdcall RpcMgmtSetCancelTimeout(long)
401401 stdcall RpcMgmtSetComTimeout(ptr long)
402402 stdcall RpcMgmtSetServerStackSize(long)
403403 stdcall RpcMgmtStatsVectorFree(ptr)
404404 stdcall RpcMgmtStopServerListening(ptr)
405405 stdcall RpcMgmtWaitServerListen()
406406 stdcall RpcNetworkInqProtseqsA(ptr)
407407 stdcall RpcNetworkInqProtseqsW(ptr)
408408 stdcall RpcNetworkIsProtseqValidA(ptr)
409409 stdcall RpcNetworkIsProtseqValidW(ptr)
410410 stub RpcNsBindingInqEntryNameA
411411 stub RpcNsBindingInqEntryNameW
412412 stub RpcObjectInqType
413413 stub RpcObjectSetInqFn
414414 stdcall RpcObjectSetType(ptr ptr)
415415 stdcall RpcProtseqVectorFreeA(ptr)
416416 stdcall RpcProtseqVectorFreeW(ptr)
417417 stdcall RpcRaiseException(long)
418418 stub RpcRegisterAsyncInfo
419419 stdcall RpcRevertToSelf()
420420 stdcall RpcRevertToSelfEx(ptr)
421421 stdcall RpcServerInqBindings(ptr)
422422 stub RpcServerInqCallAttributesA
423423 stub RpcServerInqCallAttributesW
424424 stdcall RpcServerInqDefaultPrincNameA(long ptr)
425425 stdcall RpcServerInqDefaultPrincNameW(long ptr)
426426 stub RpcServerInqIf
427427 stdcall RpcServerListen(long long long)
428428 stdcall RpcServerRegisterAuthInfoA(str  long ptr ptr)
429429 stdcall RpcServerRegisterAuthInfoW(wstr long ptr ptr)
430430 stdcall RpcServerRegisterIf2(ptr ptr ptr long long long ptr)
431431 stdcall RpcServerRegisterIf(ptr ptr ptr)
432432 stdcall RpcServerRegisterIfEx(ptr ptr ptr long long ptr)
433433 stub RpcServerTestCancel
434434 stdcall RpcServerUnregisterIf(ptr ptr long)
435435 stdcall RpcServerUnregisterIfEx(ptr ptr long)
436436 stub RpcServerUseAllProtseqs
437437 stub RpcServerUseAllProtseqsEx
438438 stub RpcServerUseAllProtseqsIf
439439 stub RpcServerUseAllProtseqsIfEx
440440 stdcall RpcServerUseProtseqA(str long ptr)
441441 stdcall RpcServerUseProtseqEpA(str  long str  ptr)
442442 stdcall RpcServerUseProtseqEpExA(str  long str  ptr ptr)
443443 stdcall RpcServerUseProtseqEpExW(wstr long wstr ptr ptr)
444444 stdcall RpcServerUseProtseqEpW(wstr long wstr ptr)
445445 stub RpcServerUseProtseqExA
446446 stub RpcServerUseProtseqExW
447447 stub RpcServerUseProtseqIfA
448448 stub RpcServerUseProtseqIfExA
449449 stub RpcServerUseProtseqIfExW
450450 stub RpcServerUseProtseqIfW
451451 stdcall RpcServerUseProtseqW(wstr long ptr)
452452 stub RpcServerYield
453453 stub RpcSmAllocate
454454 stub RpcSmClientFree
455455 stdcall RpcSmDestroyClientContext(ptr)
456456 stub RpcSmDisableAllocate
457457 stub RpcSmEnableAllocate
458458 stub RpcSmFree
459459 stub RpcSmGetThreadHandle
460460 stub RpcSmSetClientAllocFree
461461 stub RpcSmSetThreadHandle
462462 stub RpcSmSwapClientAllocFree
463463 stub RpcSsAllocate
464464 stub RpcSsContextLockExclusive
465465 stub RpcSsContextLockShared
466466 stdcall RpcSsDestroyClientContext(ptr)
467467 stub RpcSsDisableAllocate
468468 stdcall RpcSsDontSerializeContext()
469469 stub RpcSsEnableAllocate
470470 stub RpcSsFree
471471 stub RpcSsGetContextBinding
472472 stub RpcSsGetThreadHandle
473473 stub RpcSsSetClientAllocFree
474474 stub RpcSsSetThreadHandle
475475 stub RpcSsSwapClientAllocFree
476476 stdcall RpcStringBindingComposeA(str str str str str ptr)
477477 stdcall RpcStringBindingComposeW(wstr wstr wstr wstr wstr ptr)
478478 stdcall RpcStringBindingParseA(str  ptr ptr ptr ptr ptr)
479479 stdcall RpcStringBindingParseW(wstr ptr ptr ptr ptr ptr)
480480 stdcall RpcStringFreeA(ptr)
481481 stdcall RpcStringFreeW(ptr)
482482 stub RpcTestCancel
483483 stub RpcUserFree
484484 stub SimpleTypeAlignment
485485 stub SimpleTypeBufferSize
486486 stub SimpleTypeMemorySize
487487 stdcall TowerConstruct(ptr ptr ptr ptr ptr ptr)
488488 stdcall TowerExplode(ptr ptr ptr ptr ptr ptr)
489489 stdcall UuidCompare(ptr ptr ptr)
490490 stdcall UuidCreate(ptr)
491491 stdcall UuidCreateNil(ptr)
492492 stdcall UuidCreateSequential(ptr)
493493 stdcall UuidEqual(ptr ptr ptr)
494494 stdcall UuidFromStringA(str ptr)
495495 stdcall UuidFromStringW(wstr ptr)
496496 stdcall UuidHash(ptr ptr)
497497 stdcall UuidIsNil(ptr ptr)
498498 stdcall UuidToStringA(ptr ptr)
499499 stdcall UuidToStringW(ptr ptr)
500500 stub char_array_from_ndr
501501 stub char_from_ndr
502502 stub data_from_ndr
503503 stub data_into_ndr
504504 stub data_size_ndr
505505 stub double_array_from_ndr
506506 stub double_from_ndr
507507 stub enum_from_ndr
508508 stub float_array_from_ndr
509509 stub float_from_ndr
510510 stub long_array_from_ndr
511511 stub long_from_ndr
512512 stub long_from_ndr_temp
513513 stub pfnFreeRoutines
514514 stub pfnMarshallRouteines
515515 stub pfnSizeRoutines
516516 stub pfnUnmarshallRouteines
517517 stub short_array_from_ndr
518518 stub short_from_ndr
519519 stub short_from_ndr_temp
520520 stub tree_into_ndr
521521 stub tree_peek_ndr
522522 stub tree_size_ndr
523