xref: /reactos/dll/win32/schannel/schannel.spec (revision 4561998a)
1@ stdcall AcceptSecurityContext(ptr ptr ptr long long ptr ptr ptr ptr) schan_AcceptSecurityContext
2@ stdcall AcquireCredentialsHandleA(str str long ptr ptr ptr ptr ptr ptr) schan_AcquireCredentialsHandleA
3@ stdcall AcquireCredentialsHandleW(wstr wstr long ptr ptr ptr ptr ptr ptr) schan_AcquireCredentialsHandleW
4@ stdcall ApplyControlToken(ptr ptr) schan_ApplyControlToken
5@ stub CloseSslPerformanceData
6@ stub CollectSslPerformanceData
7@ stdcall CompleteAuthToken(ptr ptr) schan_CompleteAuthToken
8@ stdcall DeleteSecurityContext(ptr) schan_DeleteSecurityContext
9@ stdcall EnumerateSecurityPackagesA(ptr ptr) schan_EnumerateSecurityPackagesA
10@ stdcall EnumerateSecurityPackagesW(ptr ptr) schan_EnumerateSecurityPackagesW
11@ stdcall FreeContextBuffer(ptr) schan_FreeContextBuffer
12@ stdcall FreeCredentialsHandle(ptr) schan_FreeCredentialsHandle
13@ stdcall ImpersonateSecurityContext(ptr) schan_ImpersonateSecurityContext
14@ stdcall InitSecurityInterfaceA() schan_InitSecurityInterfaceA
15@ stdcall InitSecurityInterfaceW() schan_InitSecurityInterfaceW
16@ stdcall InitializeSecurityContextA(ptr ptr str long long long ptr long ptr ptr ptr ptr) schan_InitializeSecurityContextA
17@ stdcall InitializeSecurityContextW(ptr ptr wstr long long long ptr long ptr ptr ptr ptr) schan_InitializeSecurityContextW
18@ stdcall MakeSignature(ptr long ptr long) secur32.MakeSignature
19@ stub OpenSslPerformanceData
20@ stdcall QueryContextAttributesA(ptr long ptr) secur32.QueryContextAttributesA
21@ stdcall QueryContextAttributesW(ptr long ptr) secur32.QueryContextAttributesW
22@ stdcall QuerySecurityPackageInfoA(str ptr) secur32.QuerySecurityPackageInfoA
23@ stdcall QuerySecurityPackageInfoW(wstr ptr) secur32.QuerySecurityPackageInfoW
24@ stdcall RevertSecurityContext(ptr) secur32.RevertSecurityContext
25@ stdcall SealMessage(ptr long ptr long) secur32.SealMessage
26@ stdcall SpLsaModeInitialize(long ptr ptr ptr)
27@ stdcall SpUserModeInitialize(long ptr ptr ptr)
28@ stub SslCrackCertificate
29@ stdcall SslEmptyCacheA(str long)
30@ stdcall SslEmptyCacheW(wstr long)
31@ stub SslFreeCertificate
32@ stub SslGenerateKeyPair
33@ stub SslGenerateRandomBits
34@ stub SslGetMaximumKeySize
35@ stub SslLoadCertificate
36@ stdcall UnsealMessage(ptr ptr long ptr) secur32.UnsealMessage
37@ stdcall VerifySignature(ptr ptr long ptr) secur32.VerifySignature
38